Solved

How to get the nested VM windows 2008 to access the internet?

Posted on 2012-12-30
12
1,316 Views
Last Modified: 2013-01-02
hi guys

I've got a situation where I have a nested environment.

A Vmware Workstation 8.0 running Vmware Esxi 5.0. And on that, is running a Windows 2008 VM.

The IP address of my local PC is 192.168.1.10/24. With a gateway of 192.168.1.1.

The Esxi hypervisor has an IP of 192.168.1.15.

However, the Windows 2008 sitting on there has been given a 192.168.1.20/24 address with a gateway of 192.168.1.1 and it can't access the internet.

I don't know if there are settings I have to play with on the Workstation in order to get the nested VM access to the internet?

Any ideas on how to do this?

Many thanks
Yashy
0
Comment
Question by:Yashy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
12 Comments
 
LVL 121

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 38731058
What have you set the ESXi Virtual Host Networking to?

NAT?

You need to set it to BRIDGED. (VMware Workstation VM needs to be set to BRIDGED).

This also MUST be the E1000 NIC!

you then need to set your networking in the ESXi Host to use VLAN 4095 (ALL).

In this way ALL Virtual and Nested Host Machines will be on the same network as the HOST.
0
 
LVL 1

Author Comment

by:Yashy
ID: 38731102
Everything was what you described, other than the VLAN 4095 which I had to do go and do.

For anybody else reading this who doesn't know how to do it, in order to get to the VLAN 4095, you must:

 - Log on to the Esxhi host (with the Vsphere client)
 - Select the Esxi host.
- Go to the 'Configuration' tab on the right.
- Select 'Networking' on the left hand column and then click on the 'Properties'.
- Select 'Management Network' and click 'Edit'.
- Where it says 'VLAN ID', use the dropdown to select '4095 (ALL)' and click OK.
0
 
LVL 121
ID: 38731109
So it's working now?

and make sure your VMs are also using the Virtual Machine Network 4095 (ALL).

You should find then if you allocate a VM with an IP Address of 192.168.1.x it should be on the same network, from what I recall, there is someting odd with DHCP, so maybe do not expect DHCP from your MAIN LAN to passthrough twice to the nested VMs!
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 
LVL 1

Author Comment

by:Yashy
ID: 38731135
It's not working sadly:(.

I've selected the 'VM Network' to 4095 (ALL).

I've set the IP address of the VM itself with a static IP and a gateway of my router.

When you said 'make sure your VM's are also using the Virtual Machine Network 4095 (ALL)', did you mean the setting that I've mentioned in the second line above?

Because on the Workstation 8, there isn't any place I can see where I can select the VM's to be on the 4095 (ALL)?
0
 
LVL 121
ID: 38731181
okay, I'll need screenshots of:-

VM Settings for ESXi Nested Host

vSwitch and NIC settings of ESXi Host

can you ping host from the nested VM?

can you ping other devices from the nested VM?
0
 
LVL 1

Author Comment

by:Yashy
ID: 38731732
Okay, I've attached all of the necessary screenshots for you.

To answer the questions.

I can't ping host from the nested VM. I get a ping transmit failed. I've attached a screenshot of the IP settings of this VM. I can't ping anything from the nested VM.
Vmware-setting-1.jpg
Vmware-setting-2.jpg
Vmware-setting-3.jpg
Vmare-setting-4.jpg
Vmware-setting-5.jpg
VM-IP-address.jpg
VM-IP-address-2.jpg
0
 
LVL 121
ID: 38731808
so the nested ESXi server is able to get an IP Address 192.168.1.15 from your LAN, same LAN as the VMware Workstation host?

I have seen VLAN issues with ESXi 5.1, I'm wondering if it's the same bug.

all looks okay, does your VM if set to DHCP receive an IP Address?

btw 6 vCPU for your VM is far too many, not that's the network issue!
0
 
LVL 1

Author Comment

by:Yashy
ID: 38731821
Il reduce cpus..hehe.
The esxi host gets its IP via dhcp. And it is on the same network as Workstation on the LAN. The VM however is unable to get dhcp.
0
 
LVL 121
ID: 38731841
Just had another thought ALSO SET THE vSwitch to

ALLOW Promiscious Mode: Accept, either on the vSwitch or Virtual Machine Network.

Promiscuous-mode-network1.jpg
0
 
LVL 1

Author Comment

by:Yashy
ID: 38732343
I tried this also and still doesn't work. I set it to Accept.

The weird thing is that when I add a static IP to the VM, it still sees it as an Unindentified Network. Even if it didn't have internet access, I'd expect the IP address added to make the VM part of an identified network.

Also, I've taken a screenshot for you of something else. In the Vswitch properties, the 'networks' only shows as the IP address range of my own PC (192.168.1.9). Is that correct?
Vmware-setting.jpg
0
 
LVL 121
ID: 38732976
I'll need to debug this, and check, ESXi 4.1, 5.0 and 5.1, and see if something has changed or broken in 5.1!
0
 
LVL 1

Author Comment

by:Yashy
ID: 38733076
Hanccocka - you won't believe it.

It was  my own PC's internal firewall driver. I unchecked it in my network settings and hey presto....all is good:).

Thanks so much again for your help.

Happy new year to you sir.
0

Featured Post

Enroll in June's Course of the Month

June’s Course of the Month is now available! Experts Exchange’s Premium Members, Team Accounts, and Qualified Experts have access to a complimentary course each month as part of their membership—an extra way to sharpen your skills and increase training.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If your vDisk VHD file gets deleted from the image store accidentally or on purpose, you won't be able to remove the vDisk from the PVS console. There is a known workaround that is solid.
When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
Teach the user how to convert virtaul disk file formats and how to rename virtual machine files on datastores. Open vSphere Web Client: Review VM disk settings: Migrate VM to new datastore with a thick provisioned (lazy zeroed) disk format: Rename a…
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question