• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 368
  • Last Modified:

Multiple java coflicts

Hi,

We have a 2 IE based application called callidus & PVCS -serena which works on 1.6.0.21 & 1.5.0.17 respectively, also a locally installed application Borland star team works on different java embedded applet.

Recently they have added an another application which uses java webstart to start a application in fullscreen, which runs only if give IE as " run as administrator " even the user is an administrator(Problem is those users shouldnt have admin privileges),

Problem:

PVCS is a version control app to checkout files - java.lang.UnsatisfiedLinkError:stat when trying to check out files from the web client. if 1.5.0.17 installed working,

Callidus portal working only if 1.6.0.21 jdk is installed,

Borland not working if the applet is removed for the above reason.

Solution required:

How to make IE & the applications to use the exact version of java it requires,
0
satheeshmouli84
Asked:
satheeshmouli84
1 Solution
 
David Johnson, CD, MVPOwnerCommented:
0
 
Sharon SethCommented:
For IE , you can always open the java control panel and check/uncheck which version it uses.
For eg: If your  OS uses Java 1.5 , but you want IE to use 1.4 , then first open the java control panel from control panel and uncechk IE from it. Then open the java control panel from1.4 JRE's bin folder and check IE there.

For apps , you give the full path of the java executable in the startup scripts
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now