Link to home
Start Free TrialLog in
Avatar of Dave Messman
Dave MessmanFlag for United States of America

asked on

Quickbooks H202 error when attempting multi user mode - servermode=2 in ND file after attempting to switch mode

I'm the IT guy for a 50 person company that has 4 accountants.  I have a full understanding of exactly how Quickbooks is supposed to be set up for multi-user use. You'll see the errors I'm seeing at the bottom of this post.  Everything worked well for me until I decided to move from a temporary Windows 7 Quickbooks Database Server host (which did work well) to a a proper Windows Server host.  Knowing that Quickbooks prefers a 32 bit server host, I've tried Windows Server 2008 32 bit, Windows 2003 32 bit, and Windows 7 Pro 32 bit.  

When attempting to switch to multi-user mode from a client workstation, I get an H202 error.  I'll give the brief version of all the normal things that are done on the server side setup (all of which I have done):
1) install QB database server manager on the server
2) share out a folder on the server with appropriate share permissions and file/folder permissions for all accountants (full and full)
3) update database server version for QB 2010 to the current version (R16 as of 12/30/12)
4) Disable firewall on server (I could open up ports one by one, but I disable the firewall just to be super duper sure)
5) Open QB Database Server on the server, browse to the folder where the QBW files are stored and hit SCAN.  The QB database server will create the ND files as needed for multi-user use.  

From this point, my accountants should be able to open QB 2010 (either via the mapped drive or via \\\qb\filename.qbw) and switch to multi-user mode.  The server setup isn't rocket science.  I've spent easily a dozen hours looking at possible reasons this might now work - looking at small things like DNS settings, HOSTS files, and other stuff.  All is normal.  The one error message I'm seeing other than the H202 error on the client workstations is the content of the ND file changing.  Specifically, the ND file changes from servermode=1 to servermode=2 - which as per Intuit, servermode=1 means hosting is on and servermode=2 means hosting is off.  In this case, I have two files that are stored on the Quickbooks share.  I don't have access to the main QBW file since I'm not an accountant so I created a testfile that should operate the exact same way (since it's in the same location).  I can log in as any accountant and map the drive as administrator, but I don't have a login to the main QB file, but I can have my accountants test the issue, and they get the same results as my test company.

Content of test company.qbw when I run the SCAN:
// This is QuickBooks configuration File. It exists while users are connected
// to a company file. Do not delete this file yourself. QuickBooks may not
// operate correctly if you manually delete this file.
FilePath=C:\qb2\Test Company.QBW

Contents of test company.qbw after I attempt to open it from a workstation and get the H202 error:
//This is QuickBooks configuration File. It exists while users are connected
// to a company file. Do not delete this file yourself. QuickBooks may not
// operate correctly IF you manually delete this file.
FilePath=\\\qb2\Test Company.QBW

I can provide any more input you need on this topic.  I've looked and looked and seen no one with this particular problem.

Avatar of John
Flag of Canada image

Allow me to summarize how I do this:

1. Close QuickBooks on all client machines.
2. Install the same version of Server Manager on your server as version of QuickBooks you are going to use.
3. Locate the company file on the same partition on the Server as you located the Server Manager.
4. Open the Server Manager and scan for the ledger.

Now at the client machines, map the folder on the server where the company file is located. You seem to know how to map folders. Use a script in AD, use a NET USE command at the workstation, or use Windows Explorer, Tools, Map Folder. I do not browse for QB company folders.

At one client, open QuickBooks. If it tries to open a file, use the File menu to Close Company File. I want you to get back to the big center QB window to open a file.

Now use File, Utilities to Uncheck (Disable) Host Multi User Access. Do not use Host Multi User Access.  

Now use the center menu to open a company file and navigate to the server folder. Do not open a recent file - it could be the wrong file and give you the error you got.

Try these steps carefully and please post back.

.... Thinkpads_User
Avatar of Dave Messman


I think I have 75% of the problem figured out.  Notice the engine name in each ND file:

This is a version mismatch.  i'm on Quickbooks 2010, so the engine name should end in 20.

Also, I have a backup of my last working ND file and the engine name was:

I don't have Quickbooks 2008 installed anywhere.  Nor did I on any of these machines.  I've been on Quickbooks 2010 since 2010.  And all my servers and workstations are newer than that.

Any thoughts as to how/why the engine name switches to ending in 18 when my workstations try to open Quickbooks?
QuickBooks opens a file, not the server engine. My experience is that the server engine must be the same version as QuickBooks, possibly one version higher, but never lower.

I uninstall ALL server engines on the server and use only one.

Now the ND file is the licensing file and is created automatically by QuickBooks. There should only be one of these files, not multiple files.

I cannot answer the last question because QuickBooks does not invent prior versions.

If you cannot get it running with this, uninstall the server engine again, and then copy the company ledger (.QBW file) and the transaction log (.TLG file) but not the .ND file to a safe location. Copy any backups out to a safe location. Make sure the copies are safe and then delete all the files in the server QuickBooks folder except the .ND file. Do not try to delete it manually. It will delete itself, but check that it does.

Now restore only the .QBW file and the .TLG file to the server folder.

Now go to one client machine, locate reboot.bat in the QB  program folder. Open a command prompt and run reboot. This repairs QuickBooks. Restart this computer, map the relevant folders, open QuickBooks and try again.

.... Thinkpads_User
I think I've narrowed down the problem.  I'm on the right track, but I could use some additional thoughts.

Here's how I see it:

Quickbooks Database Server (only) installed on a Windows Server 2003 32 bit machine with firewall disabled

If I create a brand new file in an empty share, the ND file created will look like this:
FilePath=E:\quickbooks\TestCompany, LLC.QBW

And this brand new file *will* open in multi-user mode.  The content of the ND file does not change.

However, if I try to open one the test file I had used previously that had a problem, I'm getting the same behavior.  When I scan the folder with the previous test file, I get an ND file with this content:
FilePath=E:\quickbooks\Test Company.QBW

For some reason, when the ND file is created for my original test file (or the accountant's main file), the engine name is set to QB_server9_18.

I'm 99% sure that the error is entirely related to this engine name.  For some reason, these files are somehow being associated with the Quickbooks engine from 2008.  I have no idea how this came to be or how to undo it.  Any thoughts?
First, you now have a network, server and QB structure that works (new file works).

Second, then, look to a possible error in your main QB company ledger.

One: Make sure there are no company ledgers on local machines. If there are any, move them to a safe non-QuickBooks backup location on your server. Make sure there are no ledgers on local machines.

Two: Nominate one machine as your main QB machine. Copy (NOT Move) the Company Ledger (.QBW file) and Transaction Log (.TLG file) to the local main machine.

Three: Do a rebuild.

Open QB on the main machine. Close any open files. With the center window, open the local QBW file. Then in QB, File, Utiliies, and select Rebuild. The file rebuild could take a while (hours if a big QBW file).

When the rebuild is complete, open the file and see if it is working locally. Now go to the server and MOVE the company ledger and TLG file to the safe non-QuickBooks backup location. The main ledger folder should now be empty. Do a refresh and there should be no .ND files. The folder should be empty. Let me know if not and what is there.

Now MOVE the local QBW and TLG files to the main server folder location.

Let us summarize:  

1. The QBW has been rebuilt and is in the main folder location. It worked locally (presumably). The TLG file is in the main folder.
2. There are no QBW, TLG, or ND files on any local computer.
3. There is a server backup location with the QBW and TLG files *before* the rebuild.

Now restart the main computer, open QuickBooks, navigate to the main server folder location and open the file.

Hopefully that works. Continued errors of this sort may need the Intuit Repair Service, so be ready for that.

When done, I never tamper with the .ND licensing files.

.... Thinkpads_User
Avatar of tmoore1962

Did you check your services?  I have found that the QB Manager doesn't always remove the previous QB Manager service then you can have multiple instances running
Hopefully the uninstalls and restarts suggested will eliminate prior services. That has been my experience.

.... Thinkpads_User
I have more information, and I *was* on the wrong track before.

Here's what I've got, and I'm 95% sure this is the problem.

I can switch to multi-user mode when I'm logged in as a domain admin, but not as one of my accountants.  

The scenario:
I've got the QB Server all set up in a normal working state.

I log in as a domain admin on my terminal server and open up Quickbooks.  I can open my test files and switch to multi-user mode.  I also worked with one of my accountants and logged in to the terminal server as a domain admin and was able to switch to multi-user.  In the case of my the main accounting file, the accountant was logged onto the machine as a domain admin, but logged into Quickbooks as herself.

However, when I logged on to the terminal server as one of my accountants (who does not have domain admin privileges), she could *not* switch the files to multi-user mode (got H202 error).  

Interestingly, I also logged on as the accountant and opened the main Quickbooks file.  The file that *had been* successfully converted into multi-user mode got an H202 error.  Once she logged in - she was in single user mode.

So my issue is somehow Windows permissions, which is odd to me.  I've created a folder on the server and shared it out with full share permissions to all users and full file/folder permissions to all accountants.  If there are some other kind of permissions to QB server or something similar, I'm not familiar with it.

Any thoughts with this new info?

I think the Accountant must be in Single User mode. I would not allow Multi User and Accountant at the same time. The Accountant can make changes and you cannot risk someone else making changes at the same time. So use Single User mode for the Accountant. Yes, that means the other users must log off. There are other times when QB must be in Single User mode as well.

The Single User / Multi User modes of QuickBooks have nothing to do with Windows permissions at all. QuickBooks is a world unto itself.

.... Thinkpads_User
to clarify, when I'm logged in as the domain admin, the ND file gets a working/correct value and when I'm logged in as an accountant without domain admin privileges, the ND file gets a nonworking value with a servermode of 2.  This is so odd.  I have other working Quickbooks multi-user setups without this problem at all that are set up just like this.
You should let the .ND file take care of itself.

I am sure Accountant must be in Single User mode. It may also be that Accountant must be a member of the QuickBooks administrators group. This is because the Accountant must be able to change anything and is making a temporary copy of transactions that must later be merged.

With respect to Windows authority groups, I have to make my clients members of the Power Users (Power User Legacy) Group for QuickBooks to function. That has been that way for a long while with my clients.

Because of the merging of transactions, it may be (or just may be easier) that the Accountant should be local administrator of the machine they are working on.

I have never had to make a user a domain admin to use QuickBooks.

Also, no one should be using the Accountant role in QuickBooks except for the Accoutant. Some one (not you) would be the QuickBooks administrator. As IT person, you should use the Windows machine and QuickBooks userid of the instance you are testing for.

.... Thinkpads_User
@dmessman:   Here is a summary from my point of view (heavy QuickBooks professional)

1. The .ND file is a licensing file. I never have to or have had to tamper with it. I suggest you let it manage itself.

2. You know how to set up QuickBooks on the server and at the workstation. No need to repeat here.

3. The nominated main computer above should be that of the QuickBooks Administrator. There should only be one QB administrator. This computer should have Windows Authority of Power User.

4. The Accountant only works on the file for a short while (in my experience). The Accountant should work when necessary at the main computer and the Accountant should be able to function in Power User mode in Windows.

4b. If 4 is not pratical, then set up a second machine the same way as the first. This could be the senior bookeeper's machine.

5. Set up the other client machines as Power Users but the QB userids would not be administrator.

6. When the Accountant is not on hand, all clients can be in Multi User mode.

7. When the Accountant is on hand, QB should be in Single User mode on the Accountant'c computer.

All this should work. Please let me know if we need to fine tune it.

.... Thinkpads_User
to clarify, I'm using the term "accountant" as one of the four on-staff accountants.  They should always be working in multi-user mode and never in single user mode (since they work on the file collectively).

From what I gather above, my experience in this particular situation is unique and not something you have seen before:

1) only a domain admin (Quickbooks login irrelevant) can put the QBW file into muiti-user mode.
2) standard Quickbooks users (accountants) are unable to put the file into multi-user mode (get H202 error).  The ND file gets modified as discussed above.

BY most standards, I'm a Windows networking expert, and I'll figure this out.  But as stated above in this post, this seems to be my situation.
1) only a domain admin (Quickbooks login irrelevant) can put the QBW file into muiti-user mode

This is wrong, so something is incorrect about your setup. The QB administrator can move in and out of Multi User Mode without being a domain admin.

2) standard Quickbooks users (accountants) are unable to put the file into multi-user mode

I will check this tomorrow. I am quite sure a regular user can do this. I have an assistant at one client and if I am not in QuickBooks at all, she can go into Single User mode to do taxes and go back to Multi User mode when complete. I will verify this tomorrrow. That workstation for certain is not domain admin.

The summary steps I laid out will allow QB to work in any environment. I a have a number of different networking environments where I suppport QuickBooks.

Did you do the company file rebuild?

... Thinkpads_User
I'm now 99.9% sure this problem is resolved.  After conflicting information and results, I believe this was somehow a DNS resolution issue.

The server I was working with and testing had a static IP address.  I compared and contrasted against the last server I had in use which had a DHCP reservation.  Even though the Quickbooks server had all the same info (or so I believe) set in the static IP address configuration, things began to work when I switched the server from a static IP address to a dynamic IP address with a DHCP reservation.  

Of note - in regard to my theory on mismatching Quickbooks versions, that theory was incorrect.  Even though the engine in the ND file would end in _18, once the file was properly configured after the first opening of the QBW file by the client version of Quickbooks, the ND file would be changed to its permanent values which include an engine name that ends in _20.

I'll confirm 100% resolution as soon as my accountants have successfully opened the company QBW file.  I'm only able to test by myself with sample QBW files that I created and live in the same location as the company QBW file so it has the same behavior.
Avatar of John
Flag of Canada image

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
This issue is fixed.  In the end, the H202 was just what it was supposed to be - a network communications error.  I was chasing ghosts with engine name in the ND file (the engine would be _18 when I would scan folder where the QBW file was stored, but when properly used, the ND file would change itself to end in _20).  I was able to get the file to go to multi-user mode in some situations, but my users could never use it.  

I had read about someone having H202 problems and they narrowed it down to DNS.  I went in and double checked that the DNS servers listed on my workstations and QB data server host were the same and they were.  There must be something in the IP address info that DHCP assigns that I was not assigning statically (or perhaps registration on my internal Windows DNS server).  I don't know.

But I do know this - the only change I made was to set a DHCP reservation and stop using a static IP address on my Quickbooks server (a Win 2008 32 Server bit virtual machine on a Win 2012 Standard host).  That helped me to get things working.  

Thinkpads_user - I appreciate your help.  I came up with the ultimate solution, but while I was troubleshooting, your fast response and (in the end) noting that I shouldn't be looking at group membership as the problem and there was something wrong with my setup got me to go back and re-examine everything.

@dmessman - Thank you. I was happy to work with you and combine our knowledge. Your systems seem a bit different than mine, but I am really happy you got it working and again, I was happy to work alongside you.  Cheers.  .... Thinkpads_User
I just hit this issue after upgrading from QB 2008 to QB 2013 and after reading the information exchange between thinkpads_user and dmessman figured out that my problem was the userid that the DB service was running under.  Unless the userid used by the database service has access to the location where the QB files are stored, you will get H202 errors all day long.  Changing the service to login with a userid that is authorized to the subdirectory (and stopping and restarting the service) fixed my problems.
Thanks for the update. This does not arise at my clients because "administrator" installs the server engine, starts the service, and has access to all the folders.

Interesting in your case that it was not this way.

.... Thinkpads_User
I was as surprised as you were about that as I used the administrator userid to install all of this on my server - but the QB 2013 server install used some made up userid as the owner of the service.  Once I changed it to "administrator" with the right password, it all began working just fine.
These problem occurs only when Quickbooks is not able to contact db server or the qbdb service is not running for some reason, these reasons could be caused by a damaged company file, I use quickbooks on hosting provided by and never faced such issues