Avatar of F_A_H_D
F_A_H_D
 asked on

Cisco 7925g how to install it in the network

Hi.

we have cisco ip telephony consist of cisco call manager version 8 and IP phones extensions

and there is two VLAN one for voice VLAN-50 and Data VLAN-2

phones are taking IP addresses from catalyst 3750 switch and computers taking from another firewall with different IP subnet
Data has different subnet than the voice
i purchased WAP4410N-E access points and i installed it everywhere plus i created separate SSID for voice.

now the issue is that the cordless phones 7925g when i connect to the network through the access point it take IP address from the data gateway not from the 3750 catalyst !!
and even i configure the voice IP address manually it doesnt work at all
and when i configure the data IP address it works but when the cordless phones speak to each others they cannot hear each others

in my case what is the correct procedures and correct setup to setup the cordless in the voice vlan ?
Voice Over IPWireless Networking

Avatar of undefined
Last Comment
Akinsd

8/22/2022 - Mon
Akinsd

Looks like you don't have a route between the vlans
You should also look into configuring IP Helper to ensure your DHCP server assigns the correct subnet to your phones.
F_A_H_D

ASKER
ok
you know what
i configured the access point voice SSID to join the voice VLAN so now the cordless phones thanks god it takes the voice ip addresses like normal extensions

my problem now still cordless phones when they dial each others each one cannot hear speaker voice we keep say Hello Hello

any idea ?
Akinsd

Most likely an issue with RTP setting or Codec mismatch
Your help has saved me hundreds of hours of internet surfing.
fblack61
F_A_H_D

ASKER
mmmm
FYI

cordless to normal phone its ok
normal extension to cordless its also ok
the problem only when it come to cordless to cordless they cannot hear each others
Akinsd

That's a little weird
I guess you have rebooted them
Does the intercom work though?
I'm racking my brain here
F_A_H_D

ASKER
no intercom configured
but FYI the extension numbers configured in the cordless phones already configured for normal phone
thats how i need the setup if some one calling you it should ring in your normal phone as well as the cordless
may be this is the reason ??? should i configure separate extensions and try it out ? or it doesnt make diff ?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Akinsd

Is the ephone-dn a dual-line (shared line)?
F_A_H_D

ASKER
no for the same person but we need to catch these people wherever they roam around
F_A_H_D

ASKER
i tried to configure new DN but unfortunately same result !!
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Akinsd

I don't have a 7925G phone to test right now.
I would say focus on why the RTP connection between wireless phones are not working. I will research on this too to find out why, if the DNs are truly shared lines.
F_A_H_D

ASKER
thank you man for your efforts
i posted also on cisco forums but no reply !!
Akinsd

You're welcome
I'll let you know if I find something
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
F_A_H_D

ASKER
you know i think the access point am using doesnt transfer RTP signals
i think i have to buy Aironet
Akinsd

That is a possibility though.
On a second thought, the phone works between a land phone and the wireless so RTP tunnel must have been created for voice transfer which would mean the RTP traffic traverses wirelessly. Maybe a wireshark capture can reveal some good info.
F_A_H_D

ASKER
do u think updating the phone firmware could help ?
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Craig Beck

Is the phone using power-save mode or constantly-awake?
F_A_H_D

ASKER
power save mode

we are off today .. u know !! i will try something tomorrow

i will configure another access point , so i will have two access points and for each access point i will assign wireless phone and i will try to make a call .. i think it work because i think once wire connection appear in between it work fine

also i contacted the vendor he has to involve his cisco guys to check it
Craig Beck

Try using CAM instead of power-save.  If you enable power-save the AP must do Proxy-ARP (and I don't think the 4400 does).
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
F_A_H_D

ASKER
Finally it works ooohhh :)

i think 4400 doesnt transfer RTP directly between phones so i made each phone use one 4400 by that way i forced the signals to go through wires and finally it works

but the only problem that with each device i have to assign one 4400 :(
ASKER CERTIFIED SOLUTION
Akinsd

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.