Solved

No Tape Drives detected in Windows though HBA connection is Up / operational

Posted on 2012-12-31
8
2,346 Views
Last Modified: 2013-01-08
I have 2 x3850  servers (both servers are member of an MSCS
cluster).  The servers are called DBS01 & DBS02 & both run
Win 2008 R2 Enterprise x64.

The way it's connected in this organization is such that FC
switches are dedicated for SAN & another FC switch is
dedicated for backup tape library to connect to.

So DBS01 & 02 each has 2 fibre connection to a pair of
FC switches which SAN storage is connected up : I have
no issue with this as both servers could detect the SAN
LUNs.

Each server has one single fibre connection to an IBM
FC switch which also has an IBM TS3200 tape library
connected to it.

The problem I face is DBS02's Windows can't detect
any Tape Drive while DBS01's Windows detected them:
refer to the attached four screens.

What did I miss?  Any specific driver needed?  I recall
for DBS01, I did not have to install any driver, just do
a reboot once the IBM 4Gbps FC switch has configured
the port.  DBS02 was rebooted several times to no avail.

I've compared the HBA port configurations for both
DBS01 & DBS02 using HBAnywhere & they're both the
same except that for DBS01, the speed is Auto-Detect
while for DBS02, I had to fix the speed at 4Gbps (because
using Auto-detect, the FC switch's port link light kept
going amber for DBS02).  I've also tried connecting that
 port on DBS02 directly to one of the four tape drive &
HBAnywhere reported the link as Operational / Up.

I've also swap the FC ports ie DBS02 connects up to
DBS01's FC switch port while DBS01 connects up to
DBS02's FC switch port.  No joy
DBS01-FC.jpg
DBS02-FC.jpg
DBS01-TapeDrvPresent.jpg
DBS02-noTapeDrv.jpg
0
Comment
Question by:sunhux
  • 3
  • 3
  • 2
8 Comments
 
LVL 77

Accepted Solution

by:
arnold earned 300 total points
ID: 38733739
It looks/sounds like a zoning issue on the switch where the tape is.
On the other hand not sure you can have multiple devices connect directly to a tape drive.  The access to the tape might be part of the cluster resource
I.e. LUNs and the tape drives are only accessible from the active nde in the cluster.
0
 

Author Comment

by:sunhux
ID: 38733966
> It looks/sounds like a zoning issue on the switch where the tape is.
I did disconnect DBS01 from the FC switch port & connect up DBS02 to
this port.  Still not detecting the tape drives

>On the other hand not sure you can have multiple devices connect directly to a
>tape drive.  The access to the tape might be part of the cluster resource  I.e.
>LUNs and the tape drives are only accessible from the active node in the cluster.
Well it's not direct connection but via an FC switch.  In another DC, we have
another pair of MS SQL clustered DB servers which were able to detect
an Oracle SL500 tape library & they all connect to a common HP FC switch,
so its similar configuration
0
 
LVL 77

Assisted Solution

by:arnold
arnold earned 300 total points
ID: 38733978
Switching a port does not make the wwid/WWN to match in the zoning for access between the FC HBA and the tape library resource.
Compare the configuration of the ports where access to the tape is available to both systems versus the configuration for the two having an issue.
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 16

Assisted Solution

by:Gerald Connolly
Gerald Connolly earned 200 total points
ID: 38734289
I agree, it looks like a zoning issue, what do your switch zones look like? (include what is plugged into what port and relevant WWNs
0
 

Author Comment

by:sunhux
ID: 38739778
Suppose I connect the server's FC port directly (ie bypassing the FC switch) to
the TS3200 FC tape drive, it should detect the drive, & show up as "Tape Drive"
under Device Manager, right?

I'll need to test & showcase this to convince the FC switch administrator that
it's a zoning issue.
0
 
LVL 77

Assisted Solution

by:arnold
arnold earned 300 total points
ID: 38740157
Ask to have the configuration of the working HBA on DBS01 to the one on DBS02.
Include the ports the two are on.
I doubt the FC switch admin needs persuading where a simple, "hey, the system is not able to access an essential resource."
The checking should include on the part of the FC admin is whether the link is present.

You might have an issue with the HBA or the cabling.
What is the status of the HBA that is connected to the switch? Does it reflect as linked?

While it might be a way to test to plug in directly, you would be taking everything else offline and it might be interfering with operations. If you have an FC loopback you can check whether it comes up.
0
 

Author Comment

by:sunhux
ID: 38744090
Ok, thanks chaps.

Actually the FC switch admin is my customer & I sold
them the servers and tape library.

I tried connecting the Emulex HBA (which supports FCAL
& non-FCAL) to the IBM TS3200 FC drive today, setting
the Emulex HBA ports with various topologies (F-port,
Loop, F followed by L & L followed by F) & with different
settings on the FC tape drive as well (N-port, L-port but
due to shortage of time did not manage to try one last
setting on the tape drive ie LN-port) : each time rebooting
the server to redetect the tape drive but no joy.
0
 
LVL 16

Assisted Solution

by:Gerald Connolly
Gerald Connolly earned 200 total points
ID: 38745372
when the hba and the tape were both plugged into the switch, did the switch see both of them? ie did the switch ports show both were active?
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Raid 5 11 81
Server still booting 2 48
Windows shadowcopy - space allocated - exclusive? 4 26
windows not recognising ssd's full capacity & OS bit upgrade 5 51
How to fix error ""Failed to validate the vCentre certificate. Either install or verify the certificate by using the vSphere Data Protection Configuration utility" when you are trying to connect to VDP instance from Vcenter.
Lets start to have a small explanation what is VAAI(vStorage API for Array Integration ) and what are the benefits using it. VAAI is an API framework in VMware that enable some Storage tasks. It first presented in ESXi 4.1, but only after 5.x sup…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question