Libraries empty in Windows 8

The "libaries" feature in Windows 8 has stopped working!!

When you click - it is empty

How do I restore it so that "my documents" appears there?

I tried reset to default, but that seemed to have no effect?

Mark
MawallaceAsked:
Who is Participating?
 
David Johnson, CD, MVPConnect With a Mentor OwnerCommented:
2 possible fixes:
fix #1  from a command prompt:
regsvr32 /i %systemroot%\system32\shell32.dll

Open in new window

reboot

If this doesn't fix it then there is a registry problem Save the following as library-fix.reg and import it and then reboot the computer, your libraries should be back.

For safeties sake, go to control panel | system | system protection  and create a recovery point first.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.library-ms]
@="LibraryFolder"
"Content Type"="application/windows-library+xml"

[HKEY_CLASSES_ROOT\.library-ms\ShellNew]
"Handler"="{c7ca6167-2f46-4c4c-98b2-c92591368971}"
"NullFile"=""
"IconPath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
  74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,69,\
  00,6d,00,61,00,67,00,65,00,72,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,\
  2d,00,31,00,30,00,30,00,31,00,00,00

[HKEY_CLASSES_ROOT\.library-ms\ShellNew\Config]
"IsFolder"=""
"IsOptIn"=""
"NoEmptyFile"=""

[HKEY_CLASSES_ROOT\LibraryFolder]
@="Library Folder"
"NeverShowExt"=""
"NoOpenWith"=""
"IncludeShare"=""
"IncludeSync"=""
"CanRecursivelySearch"=""
"NoPreviousVersions"=""
"FriendlyTypeName"="@shell32.dll,-34560"
"EditFlags"=dword:00100000
"DefaultDropEffect"=dword:00000004
"TileInfo"="prop:System.ItemTypeText"
"ExtendedTileInfo"="prop:System.ItemTypeText"
"InfoTip"="prop:System.ItemTypeText;System.DateModified"
"PreviewDetails"="prop:System.DateModified;*System.SharedWith"
"FullDetails"="prop:System.ItemNameDisplay;System.ItemTypeText;System.DateModified;*System.SharedWith"
"NoJumpListPathTooltip"=""

[HKEY_CLASSES_ROOT\LibraryFolder\background]

[HKEY_CLASSES_ROOT\LibraryFolder\background\shellex]

[HKEY_CLASSES_ROOT\LibraryFolder\background\shellex\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\LibraryFolder\background\shellex\ContextMenuHandlers\New]
@="{D969A300-E7FF-11d0-A93B-00A0C90F2719}"

[HKEY_CLASSES_ROOT\LibraryFolder\background\shellex\ContextMenuHandlers\Sharing]
@="{f81e9010-6ea4-11ce-a7ff-00aa003ca9f6}"

[HKEY_CLASSES_ROOT\LibraryFolder\CLSID]
@="{a5a3563a-5755-4a6f-854e-afa3230b199f}"

[HKEY_CLASSES_ROOT\LibraryFolder\DefaultIcon]
@="%SystemRoot%\\System32\\imageres.dll,-8"

[HKEY_CLASSES_ROOT\LibraryFolder\shellex]

[HKEY_CLASSES_ROOT\LibraryFolder\shellex\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\LibraryFolder\shellex\ContextMenuHandlers\LibraryFolder]
@="{0af96ede-aebf-41ed-a1c8-cf7a685505b6}"

[HKEY_CLASSES_ROOT\LibraryFolder\shellex\IconHandler]
@="{14074e0b-7216-4862-96e6-53cada442a56}"

[HKEY_CLASSES_ROOT\LibraryFolder\shellex\LibraryDescriptionHandler]
@="{fe5afcf2-e681-4ada-9703-ef39b8ecb9bf}"

[HKEY_CLASSES_ROOT\LibraryFolder\shellex\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\LibraryFolder\shellex\PropertySheetHandlers\{66275315-bfa5-451b-88b6-e56ebc8d9b58}]

[HKEY_CLASSES_ROOT\LibraryFolder\shellex\SharingHandler]
@="{fe5afcf2-e681-4ada-9703-ef39b8ecb9bf}"

[HKEY_CLASSES_ROOT\LibraryFolder\shellex\{BB2E617C-0920-11D1-9A0B-00C04FC2D6C1}]
@="{9DBD2C50-62AD-11D0-B806-00C04FD706EC}"

[HKEY_CLASSES_ROOT\LibraryFolder\shellex\{e357fccd-a995-4576-b01f-234630154e96}]
@="{9DBD2C50-62AD-11D0-B806-00C04FD706EC}"

Open in new window

0
 
rbudjCommented:
The default should be Documents, Music, Pictures, Videos.

If restoring the defaults does not work, try going to the individual folders. Go to Documents folder and right-click. Do you see Include in Library?
0
 
MawallaceAuthor Commented:
Yes I do, but this has no effect!

All I see in the Library is a Libary-ms file under each heading!
0
 
MawallaceAuthor Commented:
Tried that - still no success!

Attached is screen image!
screen image
0
 
MawallaceAuthor Commented:
2nd option worked - though I had t do this in safe mode!
0
All Courses

From novice to tech pro — start learning today.