Solved

Gigabit connection between Cisco 2960 and HP 2510G

Posted on 2013-01-01
20
1,022 Views
Last Modified: 2013-03-22
I am unable to set up a gigabit link between a Cisco 2960G-48 and a HP 2510G-48. I currently do not need trunking (tagging), but I have tried setting it up with and without it. I have a separate link between the same HP switch and a Cisco 2960-24 that has worked perfectly for years. The speed/duplex settings are auto on the Cisco switch and auto-1000 on the HP (the HP does not have a 1000 configuration - only auto-1000). I have also tried configuring the Cisco at 1000/full. The link that works does not include the native vlan on the Cisco switch, but otherwise the configuration should be the same. I have configured the 48-port Cisco exactly like the corresponding port on the 24-port Cisco except the vlan settings, but it does not work. Both switches show 1000 Mb/full duplex connectivity, but I cannot get any information to pass between them. If I configure both for 100/full duplex, then they communicate without problems. The only thing I have not done is rebooted both switches since it is hard to find a window to do so.

Thanks in advance for your help.
0
Comment
Question by:fisher_king
  • 9
  • 3
  • 3
  • +4
20 Comments
 
LVL 20

Expert Comment

by:rauenpc
ID: 38735423
What's the entire topology? If you have a physical loop, spanning tree could be blocking traffic. On the spanning tree topic, make sure the modes match up to limit headaches.
0
 

Author Comment

by:fisher_king
ID: 38735606
There are 2 connections between 2 buildings. The link that works at gigabit carries traffic for 2 vlans, 4 and 5. The one I am trying to modify is for vlan 1. It is currently connected to an ASA 5505, which is in turn connected to the HP switch. I am just trying to bypass the ASA and increase the connection to gigabit. Thus, I would not think that spanning-tree would be the issue. But I will turn off spanning-tree on both and test tomorrow night.

Thanks.
0
 
LVL 13

Assisted Solution

by:Sandy
Sandy earned 50 total points
ID: 38735759
check negotiation parameters on both concerned interfaces.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 38735796
please show the configs
0
 

Author Comment

by:fisher_king
ID: 38738868
I disabled spanning-tree on the Cisco port and it was already disabled on the HP switch (device level config).

The problem appears to be with the HP switch. I played with every possible speed/duplex combination on both switches. It works fine if I have the HP set to 100/full, even if the Cisco is set to auto. But if I set the HP to auto, it does not work. Again, the HP does not have a 1000/full configuration option - only auto and auto-1000. I have tried 2 different ports on the HP and they both had the same result.

The cisco config is:
switchport mode access
spanning-tree portfast
speed 100
duplex full

I do not have console access to the HP to get the CLI config, but it has the following settings:
untagged for VLAN 1
100Fdx
flow control disabled
0
 

Author Comment

by:fisher_king
ID: 38738869
I just had the thought that I will update the HP switch IOS and test again.
0
 
LVL 20

Expert Comment

by:rauenpc
ID: 38738876
Although unlikely since you get a link light, you should be using a crossiver cable when connecting two switches together.
0
 
LVL 20

Assisted Solution

by:rauenpc
rauenpc earned 50 total points
ID: 38738882
Oh yeah... i don't suppose you are using the dual personality ports are you? Those are the ports that can be copper or sfp and share a port number. If you have an sfp inserted the copper port doesn't function.
0
 

Author Comment

by:fisher_king
ID: 38738885
No, I am not using the dual-personality ports on either switch. I will try the crossover cable when I can make the link unavailable again.

Thanks for the help.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 38739162
Please enable cisco and HP the spanning tree
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 1

Assisted Solution

by:stilldmoney
stilldmoney earned 100 total points
ID: 38742297
I was looking at the HP website for the 2510G-48 switch you mentioned and I was able to verify that it supports the 802.3ab standard... it justs seems odd that it won't let you manually configure the speed/duplex to 1000/full (auto-1000, very weird).

I would try to connect your Cisco switch to a different switch if you have one or check to see if the dual personality ports are manually configurable to anything other than auto-1000 and try those ports as copper connections. I don't think its a crossover cable issue since most switches have an auto-sense MDI/MDIX feature to ensure connectivity regardless of the cable.

Is there a reason you're not replacing the HP switch?
0
 

Author Comment

by:fisher_king
ID: 38742365
The Cisco switch in question (48-port) is only connected to a Cisco firewall and another Cisco switch (24-port). But the 24-port Cisco is connected to an 8-port HP gigabit at 1000 - and even more strange, it is connected to the same HP 2510 switch at gigabit, but using different vlans (and a separate cable connection). Replacing the switch is not an option - a local government network (that I am responsible for) is sharing resources with a public library and the switch belongs to the library. I can add an 8-port gigabit switch, but prefer to use existing resources whenever possible.

I will check the configuration options for the dual personality ports. I also had the thought to test the connection using the other cable in case there is a cable problem.

Thanks for the help.
0
 
LVL 17

Expert Comment

by:jburgaard
ID: 38745355
Based on "...it is connected to the same HP 2510 switch at gigabit, but using different vlans (and a separate cable connection).." -this gives me a feeling, that this has to do with spanning tree.
HP does not use per vlan spanning tree protocol , they use MSTP, so all vlans in a link are either blocked or forwarded.
A "show span" from HP 2510 would be nice to rule out this .
0
 
LVL 17

Expert Comment

by:jburgaard
ID: 38745391
MSTP C A N be configured so that one instance of spanning tree is forwarding vlan1 on one link and an other instance is setup to forward vlan4 and5 on an other cable.
0
 

Author Comment

by:fisher_king
ID: 38747666
Reading through the HP manual, I noticed that it does not use per vlan spanning tree protocol. But it is disabled for the the entire HP switch. And if it were spanning tree, why does it work fine at 100/fdx - wouldn't MSTP still block the communication? Is it possible to get a "show span" for the HP via the browser interface? I am remote and will have to wait for someone to set up a console session.

The browser interface does not provide separate config options for the dual-personality ports. In the past, the CLI did not provide different options but I will review the manual with regard to the dual-personality ports.

Thanks for the help.
0
 
LVL 17

Assisted Solution

by:jburgaard
jburgaard earned 100 total points
ID: 38747730
"Is it possible to get a "show span" for the HP via the browser interface?" no, I am afraid not.
If you did not already try with an other cable, guess that is your best shot.
0
 

Author Comment

by:fisher_king
ID: 38757551
I have someone onsite to assist me tomorrow evening. I hope to try first with the other cable disconnected, but the library will still be open. If needed, I can also set up a console session with the HP switch.

Thanks again for all the help.
0
 

Author Comment

by:fisher_king
ID: 38769549
I was not able to test the other cable yet (it was in use). But I was able to upgrade the HP IOS and set up a console session with it. The results of "show span" were "STP enabled no." I found the option to set the speed at 1000 through the command line, but I receive the message that it was not a valid command on that port - I tried a regular port and a dual-personality port and received the same result.

I am hoping to try the other cable next week - sorry for the delay, but I am remote and have limited times of onsite assistance.
0
 

Accepted Solution

by:
makarizo earned 200 total points
ID: 38816665
I would concentrate on layer 1.  Fault tolerance is much lower with the gigabit speeds and much more forgiving at 100 mbps.  Any time I have something working at 100 mbps and not gigabit it is usually a bad cable, nic etc.
0
 

Author Comment

by:fisher_king
ID: 38816733
Thanks for the reply. That is my guess also, but I still have not gotten a chance to test using the other cable (I have limited onsite assistance and the cable is in use during that time). I will be onsite in February and plan to test it then.

Thanks again.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now