Remote Desktop / Ping into Server 2008 R2 over VPN

Posted on 2013-01-01
Medium Priority
Last Modified: 2013-01-07
I have a mix of all Windows Server build on my network from 2003 to 2008 R2.  When remoted in from home pver a Cisco VPN I am finding I cannot Remote Desktop or PING the 2008 R2 servers by name.  I can by the IP address.  I can RDP/PING all 2008 and 2003 server by name, just not the 2008 r2.  

Internally on the LAN I can ping and RDP into everything just fine.

The Windows Firewall is off on all of the servers.

 Is there somehting else that needs to be confireued in 2008 R2 to get the name resolution to work remotely?
Question by:Blink1976
LVL 19

Expert Comment

ID: 38735157
By default WIN 2008 servers do not reply on a ping.
You have to enable ping replies...
Enable Ping Replies on Windows Server 2008

Author Comment

ID: 38735475
After a little more digging I have found that I can connect to the Windows 2008 server via RDP and PING remotely by entering the FQDN of the computer not just the computer name.  I don't need to do this when I am inside the network just remotely over VPN.  Is there something in server 2008 vs. 2003 that requires this or is it a VPN/firewall configuration issue?
LVL 13

Expert Comment

ID: 38735567
you need to configure Split tunnel
LVL 31

Accepted Solution

Frosty555 earned 2000 total points
ID: 38735627
If you can ping via the FQDN but not the short name, it's probably a DNS issue.

Your computer needs to have the correct default search domain / suffix configured in Network Connections. The suffix is what your computer automatically tacks onto the end when you type an incomplete short computer name instead of an FQDN.

Also your VPN server should be handing out the remote network's DNS server when you connect. Check using "ipconfig /all" when connected to the VPN

Also FYI, although I don't think this applies in this case - Windows 2008 machines will typically refuse to respond to pings that come from "external" networks EVEN IF they are configured to normally respond to pings.

You can tweak this in the firewall. Go to Advanced Firewall->Inbound Rules->File and Printer Sharing (Echo Request ICMPv4-In)->Scope, and make sure that in the "Remote IP Addresses" section that the "Any IP Address" radio button is selected. By default it is set to respond only to the "Local subnet".

Featured Post

We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
I’m willing to make a bet that your organization stores sensitive data in your Windows File Servers; files and folders that you really don’t want making it into the wrong hands.
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
Suggested Courses

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question