Asterisk setup should be able to have 4 active calls, but allows only 2

How to get Asterisk to failover to maximize  active calls. When I make my fist two calls they both go on one trunk, but when I make my 3rd and 4th call, instead of going to the second trunk, I get a busy signal. I know both trunks are working separately. I have an outbound route setup with the two trunks in the trunk sequence. I'm not sure what other information to give you right now.


Setup FreePBX\PBX-in a flash disro
VIOP.ms trunk and DID
Viatalk trunk and DID
LVL 1
Jeff swicegoodTechnicianAsked:
Who is Participating?
 
PhonebuffConnect With a Mentor Commented:
Okay,

    Based on this I think you need to check on two things --
  -- Got SIP response 603 "Declined" back from 216.246.105.146

Open in new window


    In the Out Route for this dial pattern.. you have both trunks specified under the Trunk Sequence ?  

    In the Trunk Setup do you have Maximum Channels set to two ?  In both trunks do you have the correct Dial Rules, and outbound Dial Prefixes respectfully.

    SIP response 603 is not really a Busy, if the above settings are correct you may have identified a bug in the FreePBX code generation scripts and if so opening a ticket would be the correct action to take to get a patch for it.

    http://www.freepbx.org/trac/simpleticket

    -----------------------
0
 
PhonebuffCommented:
Well,

    This is a little dated but you might want to look here --
    http://www.freepbx.org/book/export/html/1912

     Then start the CLI and check the status of your peer and Registry

      > sip show peers
      > sip show registry

Lastly, look for the dial() in /var/log/asterisk/full and see what kind of errors you are getting.

========================
NOTE: If you post any log data back here use code tags, or place it in a text file and attach it.
0
 
SandyCommented:
check the outbound calling rules in asterisk.
0
 
Jeff swicegoodTechnicianAuthor Commented:
Here is the log data for the call that got the busy signal. As you can see it is just trying the first trunk. As the time this call was placed there were already two calls on Viatalk:

[2013-01-02 12:43:59] VERBOSE[719] logger.c:     -- Executing [s@macro-dialout-trunk:19] Dial("SIP/108-09578178", "SIP/viatalk/8122822787|300|") in new stack
[2013-01-02 12:43:59] WARNING[719] rtp.c: Unable to set TOS to 184
[2013-01-02 12:43:59] VERBOSE[719] logger.c:     -- Called viatalk/8122822787
[2013-01-02 12:43:59] VERBOSE[3494] logger.c:     -- Got SIP response 603 "Declined" back from 216.246.105.146
[2013-01-02 12:43:59] VERBOSE[719] logger.c:     -- SIP/viatalk-0962fa98 is busy
[2013-01-02 12:43:59] VERBOSE[719] logger.c:   == Everyone is busy/congested at this time (1:1/0/0)
[2013-01-02 12:43:59] DEBUG[719] app_macro.c: Executed application: Dial
[2013-01-02 12:43:59] VERBOSE[719] logger.c:     -- Executing [s@macro-dialout-trunk:20] NoOp("SIP/108-09578178", "Dial failed for some reason with DIALSTATUS = BUSY and HANGUPCAUSE = 21") in new stack
[2013-01-02 12:43:59] DEBUG[719] app_macro.c: Executed application: Noop
[2013-01-02 12:43:59] VERBOSE[719] logger.c:     -- Executing [s@macro-dialout-trunk:21] Goto("SIP/108-09578178", "s-BUSY|1") in new stack
[2013-01-02 12:43:59] VERBOSE[719] logger.c:     -- Goto (macro-dialout-trunk,s-BUSY,1)
[2013-01-02 12:43:59] DEBUG[719] app_macro.c: Executed application: Goto
[2013-01-02 12:43:59] VERBOSE[719] logger.c:     -- Executing [s-BUSY@macro-dialout-trunk:1] NoOp("SIP/108-09578178", "Dial failed due to trunk reporting BUSY - giving up") in new stack
[2013-01-02 12:43:59] DEBUG[719] app_macro.c: Executed application: Noop
[2013-01-02 12:43:59] VERBOSE[719] logger.c:     -- Executing [s-BUSY@macro-dialout-trunk:2] PlayTones("SIP/108-09578178", "busy") in new stack
[2013-01-02 12:43:59] DEBUG[719] app_macro.c: Executed application: Playtones

Open in new window



SIP SHOW PEERS
Name/username              Host            Dyn Nat ACL Port     Status               
Voipms/xxxxxx              xxx.xxx.xxx.xxxx       N      5060     OK (260 ms)           
viatalk/xxxxxxxxxx        xxx.xxx.xxx.xxx      N      5060     OK (71 ms)           
972/972                    192.168.0.150    D       A  5060     OK (89 ms)           
540                        (Unspecified)    D   N   A  0        UNKNOWN              
324/324                    (Unspecified)    D   N   A  0        UNKNOWN              
216/216                    192.168.0.163    D   N   A  5060     OK (10 ms)           
1080/1080                  192.168.0.128    D       A  5060     OK (12 ms)           
108/108                    192.168.0.142    D   N   A  5060     OK (4 ms)            
8 sip peers [Monitored: 6 online, 2 offline Unmonitored: 0 online, 0 offline]

Open in new window


SIP SHOW REGISTRY

Host                            Username       Refresh State                Reg.Time                 
atlanta.voip.ms:5060            xxxxxx             105 Registered           Wed, 02 Jan 2013 13:14:15
chicago-1f.vtnoc.net:5060      xxxxxxxxxx        105 Registered           Wed, 02 Jan 2013 13:14:48

Open in new window


@Sandeep I'll check it out
0
 
Jeff swicegoodTechnicianAuthor Commented:
Yes! Setting Maximum channels to 2 did it! Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.