Solved

Getting http: Status 401: Unauthorized on First Debug, but not the Second, Third, Fourth  Debug.

Posted on 2013-01-02
4
646 Views
Last Modified: 2013-01-09
Hi Everyone,

I am getting a http: Status 401: Unauthorized error when I first load my web application and debug.  When I stop debugging and do another Debug, my application loads with no errors appearing.  What is happening?  I stop debugging and do another third debug the application continues to load normally with no errors.

When I close out VS 2005 and come back in the first time and load my application, I get the http: Status 401: Unauthorized each time.  I then stop debugging and debug again, my application works and loads normally.

Maybe its my computer and the VS 2005 on my machine or IS Settings.  Please find the authentication setting I have on my machine attached.

Strange, I do not understand what is happening.

Also, noticed after minimizing the application and then coming back after break and maximizing the application and then trying to debug again, the 401 Status Error appears again on the debug.
Status-401Capture.PNG
SettingsChanged01022013Capture.PNG
0
Comment
Question by:jjc9809
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 23

Assisted Solution

by:Roopesh Reddy
Roopesh Reddy earned 250 total points
ID: 38740593
0
 
LVL 25

Accepted Solution

by:
apeter earned 250 total points
ID: 38741968
Looks like you have a web service within same webproject. Also you are calling the web service on the On_start of the application , Hence the problem for the first time.  From the second time since the intermediate IIS is already available/loaded it is for working fine.

So when ever the Appdomain is unloaded or iisreset, it ill fail..

You have two of fixing this.
1. Move the Web service into a separate site.So this is independent or started before you web project.
2. Don't call the web service inside "Application_start" event.....maybe inside a aspx page. like login page etc
0
 
LVL 23

Expert Comment

by:Roopesh Reddy
ID: 38758746
Hi,

Is this issue solved? Any Updates?
0
 

Author Closing Comment

by:jjc9809
ID: 38758883
I found the authentication properties in IIS 6 were disabled.  Also, we had some permission issues that still have not be resolved.  I appreciate your help.
0

Featured Post

Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here I am going to explain creating proxies at runtime for WCF Service. So basically we use to generate proxies using Add Service Reference and then giving the Url of the WCF service then generate proxy files at client side. Ok, what if something ge…
Parsing a CSV file is a task that we are confronted with regularly, and although there are a vast number of means to do this, as a newbie, the field can be confusing and the tools can seem complex. A simple solution to parsing a customized CSV fi…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question