uncheck hidden attribute

I have a "Shared Documents" folder that has the hidden attribute checked. This was due to a severe virus that has been removed . I tried the following:

Try this:
1. Click Start.
2. In the search box type command prompt and press enter.
3. Type the following commands and press enter after each (Note: Assumes your external drive is H:\ and the folder that is hidden is named "My Folder"):

cd H:\
attrib -H -S "My Folder" /D

I even tried the windows option by modifying the folder options but nothing has worked. Any help
TexanDonnaPAsked:
Who is Participating?
 
☠ MASQ ☠Connect With a Mentor Commented:
Depends on the type of infection you had but if you're comfortable with editing the registry go to:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
If not present create a Value Name: Hidden
Data Type: REG_DWORD (DWORD Value)
Value Data: 1  (1 = show hidden, 2 = do not show)

If the Value is already there change the Value Data to 1
0
 
science-itCommented:
Have you tried running the Command Prompt exe as Administrator? Right-click and select Run as Administrator.
0
 
TexanDonnaPAuthor Commented:
not yet but I will try
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
TexanDonnaPAuthor Commented:
i just tried it and its giving me a error message " Not resetting to"
0
 
science-itCommented:
And if you try removing the "/D" from the statement?
0
 
TexanDonnaPAuthor Commented:
i cd to the c drive directory. There is where I type
attrib -h /s and I have tried other parameters?  How should I do it?
0
 
science-itCommented:
If that doesn't work, I would guess the virus has damaged the file structure. I'd advise creating a new shared folder and copying/moving the contents from the damaged folder to the new one. Then try deleting the old folder.
0
 
science-itCommented:
try it just on the root folder -
attrib -h "shared Folder"
0
 
TexanDonnaPAuthor Commented:
MASQUERAID:

Im following your post but I do not see a hidden value or anything related inside the hidden folder. Help?
0
 
☠ MASQ ☠Commented:
Are you OK on registry editing?
That's where the changes should be made, the folder setting should return to normal afterwards but as I said depends on what kind of nasty you got (and also if it is completely gone).

If you're not familiar with registry editing this utility will do some of the work for you.
http://www.bleepingcomputer.com/download/unhide/
0
 
TexanDonnaPAuthor Commented:
Yea i am ok with registry editing. as long as it fixes the issue.
0
 
TexanDonnaPAuthor Commented:
anything?
0
 
☠ MASQ ☠Commented:
have you completed the edit?
0
 
TexanDonnaPAuthor Commented:
No. Like I said I didnt see a "Hidden Value"
0
 
TexanDonnaPAuthor Commented:
I attached a screen shot
0
 
☠ MASQ ☠Commented:
I don't see the image, if the value isn't present you should add it.
0
 
☠ MASQ ☠Commented:
Thanks, assume this is now fixed (but if it recurs you may need to also change the same setting at HKLM - &/or check that your infection is truly gone).
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.