Solved

Exchange server not running on SBS after failed update

Posted on 2013-01-02
22
1,270 Views
Last Modified: 2013-01-02
Running SBS2011 and Exchange has stopped working.

The problem appears to be related to Update rollup 7v2 for exchange server 2010 service pack 1

It has shown as installed but when i check for updates it wishes to install again and takes over an hour and the last time it failed. with error code 80070643

Which might have something to do with .net framework but unsure how to resolve.

When i goto exchange management i can not go onto the on-premises bit. I get initialization fail.

Any pointers? owa dosen't work either which i would expect
0
Comment
Question by:FalklandsIT
  • 13
  • 5
  • 2
  • +2
22 Comments
 
LVL 9

Expert Comment

by:TazDevil1674
ID: 38737071
I had this on SBS2008 (Exch 2007).  I ended up uninstalling .NET3.5 and reinstalling, rebooted server and all is working again...
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38737133
I have no .net3.5 on the server I do have .net4 will remove that instead
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38737198
Ok

Was doing another install of the update and it appears to have installed, but the exchange server services are off, restarting again and seeing if the services will come back up. If they don't i can start manually i guess but is this a sign of something else gone wrong?
0
 
LVL 13

Expert Comment

by:Yagya Shree
ID: 38737250
Please have a look into below post

Exchange 2010 KB2756496 error 80070643
http://theyouri.blogspot.com/2012/12/exchange-2010.html
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 38737272
Skip the rollup and go straight to Exchange 2010 SP2 instead. That will reinstall Exchange and should correct most problems.
Although do ensure that you didn't have the new management framework installed:

http://blogs.technet.com/b/exchange/archive/2012/12/14/windows-management-framework-3-0-on-exchange-2007-and-exchange-2010.aspx

Simon.
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38737286
OK can not Acces exchange am starting to dispear. No way to roll back before this happened any ideas??

I've seen these errors in the logs but unsure where to start.

Active Directory Certificate Services could not publish a Delta CRL for key 0 to the following location: ldap:///CN=fortuna-FORTUNA2012-CA,CN=FORTUNA2012,CN=CDP,CN=Public Key Services,CN=Services,CN=Configuration,DC=fortuna,DC=local.  Operation aborted 0x80004004 (-2147467260).

Log Name:      Application
Source:        Microsoft-SharePoint Products-SharePoint Foundation Search
Date:          02/01/2013 14:38:17
Event ID:      70
Task Category: Gatherer
Level:         Error
Keywords:      
User:          FORTUNA\spsearch
Computer:      FORTUNA2012.fortuna.local
Description:
The mount operation for the gatherer application 77a29b2a-da86-4339-8f2d-092e24c88cd3 has failed because the schema version of the search administration database is less than the minimum backwards compatibility schema version supported for this gatherer application. The database might not have been upgraded.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation Search" Guid="{1C415899-58B3-4BFC-9236-105E7FD38719}" />
    <EventID>70</EventID>
    <Version>14</Version>
    <Level>2</Level>
    <Task>174</Task>
    <Opcode>0</Opcode>
    <Keywords>0x2000000000000000</Keywords>
    <TimeCreated SystemTime="2013-01-02T18:38:17.499449800Z" />
    <EventRecordID>203426</EventRecordID>
    <Correlation />
    <Execution ProcessID="3908" ThreadID="3636" />
    <Channel>Application</Channel>
    <Computer>FORTUNA2012.fortuna.local</Computer>
    <Security UserID="S-1-5-21-2015368437-3143113729-601430884-2662" />
  </System>
  <EventData>
    <Data Name="string0">77a29b2a-da86-4339-8f2d-092e24c88cd3</Data>
  </EventData>
</Event>


Log Name:      System
Source:        Service Control Manager
Date:          02/01/2013 14:40:11
Event ID:      7000
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      FORTUNA2012.fortuna.local
Description:
The Diagnostic Service Host service failed to start due to the following error:
A privilege that the service requires to function properly does not exist in the service account configuration. You may use the Services Microsoft Management Console (MMC) snap-in (services.msc) and the Local Security Settings MMC snap-in (secpol.msc) to view the service configuration and the account configuration.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7000</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2013-01-02T18:40:11.008942200Z" />
    <EventRecordID>337644</EventRecordID>
    <Correlation />
    <Execution ProcessID="768" ThreadID="4880" />
    <Channel>System</Channel>
    <Computer>FORTUNA2012.fortuna.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">Diagnostic Service Host</Data>
    <Data Name="param2">%%1297</Data>
  </EventData>
</Event>
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38737320
Currently downloading sp2 not sure if it will resolve but anything is worth a go, However due to the small bandwidth avliable here it will take a while (2hrs at least) any other ideas while I'm here sitting doing nothing.
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 38737805
Please download the SBS BPA and run it to get an insight of most common issues.
Download and install first:
http://www.microsoft.com/en-us/download/details.aspx?id=16475
Download / install both files:
http://www.microsoft.com/en-us/download/details.aspx?id=15556
You need at least version 1.3
Usage:
http://technet.microsoft.com/en-us/library/gg508357.aspx
Hope that helps,
Olaf
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38738021
Many thanks olafdc have downloaded and installed the BPA and it's found three warning issues which I'm going to rectify. But none of them look like they would cause an issue with exchange.

Will let you know

Also SP2 has now finished downloading will install that is the warnings generated by BPA don't work.
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38738188
BPA has no faults shown but still not working.

However I've noticed a couple of things.
1) on the server I'm seeing the network icon with a red cross but I can surf the internet no problem.
2) on a windows 7 machine I'm also getting the icon saying no internet but when I goto IE I can get on.

Will look at installing SP2 but this might not ultimately be the problem. more of a network connection issue, what are your views?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 38738489
If you can connect to the internet etc then it just means there is probably an issue with WMI which is used for querying the network status. Surprised the BPA didn't flag that though.

Simon.
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 38738525
Please try running the fix my network in the SBS console.
If that does not work disable Nic and reenable it. Run the connect to the internet wizard again, followed by the set your internet address wizard.
If still no go:
Also post Ipconfig /all of server and workstation?
Olaf
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38738545
sembee2 sorry to sound niave but what is WMI

IPconfig info
C:\Users\jasontheadmin>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : FORTUNA2012
   Primary Dns Suffix  . . . . . . . : fortuna.local
   Node Type . . . . . . . . . . . . : Broadcast
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : fortuna.local

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
   Physical Address. . . . . . . . . : 2C-41-38-7D-62-68
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::380f:92e7:24e9:fbcf%11(Preferred)
   Link-local IPv6 Address . . . . . : fe80::463d:72cc:a9c1:ae34%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.200(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.254
   DHCPv6 IAID . . . . . . . . . . . : 237781304
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-6C-67-ED-2C-41-38-7D-62-68

   DNS Servers . . . . . . . . . . . : fe80::463d:72cc:a9c1:ae34%11
                                       192.168.1.200
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{7727B5B0-2876-481D-A7A2-B8850A060DC6}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38738575
olsfdc,

When I trieds repair your network it came up with:
and error accessing the exchange server and couldn't repair, it skipped it.

When i did set internet address wizard got:
windows sbs din't prperly configure your email.
and setting up internet address fails saying your need to configure the internet using the wizard.
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38738578
When i try and connect on the exchange server i get this

the attempt to connect to fortuna2012.fortuna.local using keberos authentication failed connecting to remote server failed with the following message: the client cannot connect to the destination specifed in the request. verify that the service is running and accepting requests.
0
 
LVL 22

Accepted Solution

by:
Olaf De Ceuster earned 500 total points
ID: 38738582
Is there two network cards on this server?
What AV are you running?
Olaf
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 38738592
See if this applies:
http://support.microsoft.com/kb/2501155
Then rerun the wizards.
Olaf
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38738596
two cards only one active,

AVG with the firewall off for now
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38738604
I should say two ports one active.

Domain admin is part of group.
0
 
LVL 1

Author Comment

by:FalklandsIT
ID: 38738644
Looking at the CITW log this is what we get
[8708] 130102.214702.6246: CoreNet: Retrieving DHCPConfigureSkipped flag from registry
[8708] 130102.214702.6256: CoreNet: End ChangeIP task
[8708] 130102.214702.6256: CoreNet: Run RebindConnectorsTask
[8708] 130102.214702.6436: CoreNet: Start RebindConnectorsTask
[8708] 130102.214702.6446: AdminTME: AdminDataLink Running Task: MessagingTasks.TaskRebindSMTPConnectors
[8708] 130102.214702.6646: Messaging: Begin Microsoft.WindowsServerSolutions.Messaging.Tasks.RebindConnectorsTask.Run
[8708] 130102.214702.6766: Messaging: Begin Microsoft.WindowsServerSolutions.Messaging.Management.MessagingTasks.Initialize
[8708] 130102.214702.6906: Messaging: Begin Microsoft.WindowsServerSolutions.Messaging.Management.MessagingRunspace.Initialize
[8708] 130102.214807.6551: Messaging: Openning remote runspace failed due to the error: Connecting to remote server failed with the following error message : The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.. Retry...
[8708] 130102.214807.6551: Messaging: Recycling Exchange PowerShell application pool.
[8708] 130102.214922.5776: Messaging: Openning remote runspace failed due to the error: Connecting to remote server failed with the following error message : The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.. Retry...
[8708] 130102.214922.5776: Messaging: Recycling Exchange PowerShell application pool.
[8708] 130102.215037.5821: Messaging: MessagingTaskException: Unexpected failure creating runspace -- Error# (800001)
[8708] 130102.215037.5821: Messaging: Inner exception: Connecting to remote server failed with the following error message : The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.
[8708] 130102.215037.5831: Messaging: Stack Trace:
[8708] 130102.215037.5851: Messaging:    at System.Management.Automation.Runspaces.Internal.RunspacePoolInternal.EndOpen(IAsyncResult asyncResult)
   at System.Management.Automation.Runspaces.RunspacePool.Open()
   at System.Management.Automation.RemoteRunspace.Open()
   at Microsoft.WindowsServerSolutions.Messaging.Management.MessagingRunspace.Initialize()
[8708] 130102.215037.6021: CoreNet: Exception Microsoft.WindowsServerSolutions.TaskManagement.Admin.TaskExecutionException:

[8708] 130102.215037.6181: Exception:
---------------------------------------
An exception of type 'Type: Microsoft.WindowsServerSolutions.TaskManagement.Admin.TaskExecutionException, AdminWizardFramework, Version=6.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' has occurred.
Timestamp: 01/02/2013 21:50:37
Message: MessagingManagement
Stack:    at Microsoft.WindowsServerSolutions.Messaging.Tasks.RebindConnectorsTask.Run(ITaskDataLink dl)
         at Microsoft.WindowsServerSolutions.TaskManagement.Admin.AdminDataLink.Run(TaskId taskId, IAssemblyTask task)
         at Microsoft.WindowsServerSolutions.Networking.TaskAgent.Run(TaskId id, IAssemblyTask task, InfoXml runtimeData)
         at Microsoft.WindowsServerSolutions.Networking.Wizards.CTIWizard.NetOperation.RunRebindConnectorsTask()
---------------------------------------
An exception of type 'Type: Microsoft.WindowsServerSolutions.Messaging.Management.MessagingTaskException, MessagingManagement, Version=6.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' has occurred.
Timestamp: 01/02/2013 21:50:37
Message: Unexpected failure creating runspace
Stack:    at Microsoft.WindowsServerSolutions.Messaging.Management.MessagingRunspace.Initialize()
         at Microsoft.WindowsServerSolutions.Messaging.Management.MessagingTasks.Initialize(Boolean InitializeWebServices, ProgressChangedHandler progressHandler)
         at Microsoft.WindowsServerSolutions.Messaging.Management.MessagingTasks..ctor()
         at Microsoft.WindowsServerSolutions.Messaging.Tasks.RebindConnectorsTask.Run(ITaskDataLink dl)
---------------------------------------
An exception of type 'Type: System.Management.Automation.Remoting.PSRemotingTransportException, System.Management.Automation, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' has occurred.
Timestamp: 01/02/2013 21:50:37
Message: Connecting to remote server failed with the following error message : The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.
Stack:    at System.Management.Automation.Runspaces.Internal.RunspacePoolInternal.EndOpen(IAsyncResult asyncResult)
         at System.Management.Automation.Runspaces.RunspacePool.Open()
         at System.Management.Automation.RemoteRunspace.Open()
         at Microsoft.WindowsServerSolutions.Messaging.Management.MessagingRunspace.Initialize()

[8708] 130102.215037.6181: CoreNet: RebindConnectorsTask task failed
[8328] 130102.215037.6271: CoreNet: Exception caught in network detection/configuration with a specific router IP: Task: MessagingTasks.TaskRebindSMTPConnectors failed: Microsoft.WindowsServerSolutions.TaskManagement.Admin.TaskExecutionException: Windows SBS did not properly configure your e-mail. To correct this, re-run this wizard.
   at Microsoft.WindowsServerSolutions.Networking.Wizards.CTIWizard.NetOperation.RunRebindConnectorsTask()
   at Microsoft.WindowsServerSolutions.Networking.Wizards.CTIWizard.LocateRouterPagePresenter.m_detectWorker_DoWork(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
[8328] 130102.215037.6291: WizardChainEngine Next Clicked: Going to page {0}.: finish
0
 
LVL 1

Author Closing Comment

by:FalklandsIT
ID: 38738724
olafdc, some would say you are a genius!

Ok you didn't come right out with it but you mentioned antivirus, so I decided to remove it to see what happens and guess what it works now, there is still an issue with clients and the server icons giving wroing info about their connection state but that is a problem for tomorrow for me it's 23:00hrs ish and I'm tired.com

It was a difficult not obvious problem but pure perseverance got us there in the end.
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 38738787
For workstations: Especially if windows 7 : Disable and re-enable the network card.
Fixes most issues.
Glad it's working.
Thanks,
Olaf
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now