Solved

Autocomplete in Outlook 2011 doesn't work following migration to new Macbook Pro

Posted on 2013-01-02
18
3,610 Views
Last Modified: 2013-02-02
I have a customer who just migrated to a new Macbook Pro. He performed a system migration over the network which was supposed to move all programs, files, data, etc.

Everything seemed to go well, but now the Autocomplete feature in Outlook 2011 doesn't function. The user is forced to enter the entire email address manually.

It's not just that autocomplete is empty--the system no longer remembers email addresses at all. If the user enters an address manually, and then later starts entering the same address again, he has the type in the entire address--the system doesn't auto-populate based on the previous entry.

I have found several people online who have encountered this same problem--but no one who knows how to fix it.

Has anyone here encountered and resolved this problem? Any insight would be appreciated.
0
Comment
Question by:peraspera
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 6
18 Comments
 
LVL 53

Expert Comment

by:strung
ID: 38737367
Possibly the file where the autocomplete entries are stored has the wrong permissions.

Try opening disk utility ( /Applications/Utilities/Disk Utility ) and run Repair Permissions.
0
 
LVL 53

Expert Comment

by:strung
ID: 38737371
0
Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

 
LVL 53

Expert Comment

by:strung
ID: 38737395
0
 

Author Comment

by:peraspera
ID: 38740076
Thanks, everyone, for your feedback. Regrettably, I have already reviewed the three links posted so far.

@strung--the two links you posted actually refer to a different autocomplete problem (invalid addresses in the autocomplete list.) My problem is that autocomplete provides no addresses at all.

@lomaree, I have checked permissions on the "Recent Addresses" folder, and they are set correctly.

I'm hoping there is someone here who has run into this problem recently, and can share the fix that worked for them...

I appreciate your help.
0
 
LVL 53

Expert Comment

by:strung
ID: 38740092
Have you used Disk Utility to Repair Permissions?
0
 
LVL 53

Expert Comment

by:strung
ID: 38740115
Also, as per lomaree's link, have you re-indexed the spotlight index?

Also, check in the Spotlight prefs under the Privacy Tab to make sure there are no exclusions which could possible affect Spotlight's ability to index e-mail addresses, and check all the checkboxes in the results tab.
0
 
LVL 53

Expert Comment

by:strung
ID: 38740120
The problem could very well be caused by a faulty or corrupted Spotlight index or a Spotlight setting.
0
 

Author Comment

by:peraspera
ID: 38742678
@strung, I didn't run the Disk Repair Utility, since it seemed that was only recommended if the permissions were incorrect. The permissions on this user's Recent Addresses folder are set correctly. Do you think I should run the Disk Repair Utility anyway?

I missed the fact that the Spotlight indexing was recommended if the permissions are correct. I will re-index and see if that helps.

Thank you for your insight on this.
0
 
LVL 53

Expert Comment

by:strung
ID: 38742682
Run Repair Permissions as well. This repairs permissions globally. There may be a file elsewhere with the wrong permissions.
0
 
LVL 53

Expert Comment

by:strung
ID: 38742684
Also check the Spotlight preferences as noted above.
0
 

Author Comment

by:peraspera
ID: 38758849
Here are the results of the latest efforts to fix this problem, following suggestions posted on this thread:

Permissions have been repaired.
There are no locations which Spotlight has been prevented from searching in the Privacy screen of Spotlight.
All categories in the Search Results screen for Spotlight have been checked.
Spotlight has been reindexed.

None of these steps has resolved the issue.

Does anyone have additional suggestions on how to restore Autocomplete functionality in Outlook 2011 for this system?

Your help is greatly appreciated.
0
 
LVL 53

Expert Comment

by:strung
ID: 38758872
What are the permissions for

~/Documents/Microsoft User Data/Office 2011 Identities/New Main Identity/Data Records/Recent Addresses

Can you post a screen shot of the GetInfo window?

Also, is the folder empty?
0
 
LVL 53

Expert Comment

by:strung
ID: 38758900
This article http://www.question-defense.com/2012/03/28/mac-outlook-nk2-file

suggests some autocomplete information is store in:

~/Documents/Microsoft\ User\ Data/Office\ 2011\ Identities/Main\ Identity/Data\ Records/Contacts/

You might check the permissions on that folder and see if it is empty.

If it is not empty, the contents may be corrupted and you might try moving them to the desktop and restart Outlook as suggested in the article (which you should read carefully first).
0
 

Author Comment

by:peraspera
ID: 38767582
Hi @strung:

The user doesn't actually have a folder called "New Main Identity," just "Main Identity."

The permissions for that folder are as follows:

bertc (the user) : Read & Write
staff: Read Only
everyone: Read Only

A screen-shot is attached.

Also--there has been a new development since the last post on this thread. The user has discovered that when he pairs an external keyboard with his Mac, autocomplete works. When he goes back to using the keyboard on the Mac, it doesn't work.

Does that make any sense?
0
 
LVL 53

Expert Comment

by:strung
ID: 38767726
That is really weird. Will have to give that some thought.
0
 

Accepted Solution

by:
peraspera earned 0 total points
ID: 38828620
The resolution for this ended up being to upgrade to Service Pack 2. I was unaware that the Microsoft Office 2011 installation was a base install.

Upgrading to SP1 did not help, but upgrading to SP2 fixed the problem.

I don't know that the solution actually had anything to do with SP2 as such. Outlook 2011 worked fine with a base install on the previous MacBook. The SP2 installation is a monster download, akin to reinstalling the entire program. I believe a reinstallation of the base program may have had the same result (and this was the next step, if patching the installation didn't work.)
0
 

Author Closing Comment

by:peraspera
ID: 38846413
Upgrading the the lasted patches and service packs is a best practice--one which should have been followed before this problem became an issue.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Changing a few Outlook Options can help keep you organized!
Article by: Justin
In light of the WannaCry ransomware attack that affected millions of Windows machines, you might wonder if your Mac needs protecting. Yes, it does and here is how to do it.
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

687 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question