XP login screen takes about 2 minutes before it comes up

I rolled out (imaged) around 60 computers last year all on the domain. Model HP Compaq 6200 pro SFF. I'm slowly getting the odd one now that after the XP splash screen the screen goes black with signal still to the lcd and after ~2 minutes it brings up the login screen and then functions normally During this black screen the hdd light flashes once every second. The OS is XP with SP3 fully patched on all computers. Things I have tried are as follows:
1. Safe mode does the same thing. Stops at MUP.SYS for ~2 minutes then proceeds with login
2. Diagnostic mode does the same as Safe Mode
3. Cleared all events in System and Application and tried it. No warnings or errors.
4. Updated the video driver from HP's website. No change.
5. Unplugged the network cable before turning on. No change. Still 2 minute wait.

About 6 computers do this and I'll probably get another in a few weeks. These computers are all the same so why some do it and some don't I'm not sure. I'm stumped.

Any suggestions?

Thanks,
KB5
LVL 4
Kennyboy5IT Support AnalystAsked:
Who is Participating?
 
flubbsterConnect With a Mentor Commented:
ok....

Go into your services:
start>run
services.msc

Scroll down the list looking for a service that has an automatic startup type but shows as Not Started. Pay particular attention to RPC (not rpc locator). Many services have retries and timeouts associated with them. They will try to start so many times, with a timeout delay between each attempt. They will quit trying to start after a set amount of attempts. I have seen this happen with rpc service many times.
0
 
pjamCommented:
for cleaning house on XP computers I like to use ATF cleaner at http://www.atribune.org.
try cleaning all once, reboot and see if that helps.  Have the hard drives been defragged lately?
How about page Defrag from sysinternals?  http://technet.microsoft.com/en-us/sysinternals/bb897426
0
 
Kennyboy5IT Support AnalystAuthor Commented:
These rolled out computers have been working fine for over 8 months. Sorry I forgot to mention that. Then about one a month starts to have this issue. When I run defrag it says they don't need to be defragged. Less than 10% fragmented.

Thanks pjam
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
pjamCommented:
Should have mentioned ATF cleaner is a temp cleaner, not malware.
pagedefrag works well if the pagefile is in several pieces which it often is.
0
 
flubbsterCommented:
A couple of things you can try. Download and run Sysinternals Load Order. It will display the order that drivers are being loaded and executed on the system. Look for the one after mup.sys, since that is the last one to display in safe mode before the delay.

http://technet.microsoft.com/en-us/sysinternals/bb897416

It may give you an indication of what is causing the delay.

Another thing you can try is to turn on Verbose status messages. This little known switch displays an information box during startup, shutdown, logon, and logoff. It displays each item as it is being loaded and/or executed. It adds very little time to the boot and can really help. You want to look for an item remaining on the screen for a long time during the delay. That will be the cause and will hopefully point you in the right direction. Verbose logging can be turned on for a single system or domain wide. I would suggest just activating it on a test system for now to see if it gives the info you need.

http://support.microsoft.com/kb/325376
0
 
Kennyboy5IT Support AnalystAuthor Commented:
@flubbster:
Sysinternals - mup.sys is the last boot service/driver. After that it starts loading the system stuff and the first one is 'system bus extender'. I don't think it would be that so I'm really not knowing how far down the boot order it's getting before it gets hung. I do know that when you start a xp machine in safe mode it always pauses on that mup.sys before going in. Good little tool that one is.

Verbose mode:
The verbose mode didn't actually start showing anything until after I logged in so I was unable to see anything before that.

Thanks for the great suggestions.
I'm still stuck :(

KB5
0
 
Kennyboy5IT Support AnalystAuthor Commented:
There was only one service that wasn't started under Automatic. Security Center (wscsvc) and it did have a dependancy on RPC. As for the actions if it failed to load, they were all set to take no action. I disabled it anyway and tried another reboot and it didn't fix it.
I thought you were on to something there. Nice call on that.

This is absolutely baffling. I really appreciate the help

KB5
0
 
Kennyboy5IT Support AnalystAuthor Commented:
Got it!! Found the answer 13 pages buried in a google search.
here

I followed the instructions and rebooted and went right to the login screen. I'll give you the points as your suggestions helped me out a lot.

Thanks again,
KB5
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.