Solved

Send as a public folder in owa exchange 2010

Posted on 2013-01-02
13
409 Views
Last Modified: 2013-01-09
Hi,

We have an exchange 2010 server. We want some users to send as mail enabled public folders. We have granted the send as permissions for that users on the public folder, but still it doesn't work.

Some details about the configuration.
- The users have a custom global addresslist.
- The public folder is only shown in the default global address list, but not in the custom address list of the users.

I think the problem is that the public folder isnt shown in the custom global address list of the users.

The custom global address list should include all email addresse which have a certain value in the customattribute1 of the object. We have put this value in the customattribute1 of the public folder but it's still not shown.

All help is very welcome.

Regards,
0
Comment
Question by:PramoIT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 3
13 Comments
 
LVL 37

Accepted Solution

by:
ArneLovius earned 500 total points
ID: 38739539
The EMC custom address lists types do not include pubic folders.

You will need to manually create the address list using something like the below in the EMS

New-AddressList -name 'Custom Address List' -displayname 'Custom Address List' -RecipientFilter{(((recipienttype -eq 'usermailbox') -and (customattribute1 -eq 'certain_value ')) -or ((recipienttype -eq 'publicfolder') -and (customattribute1 -eq 'certain_value')))}

Open in new window

0
 

Author Comment

by:PramoIT
ID: 38739631
Wel I already have an all-users address list which I have modified so that publicfolder should be shown. But that's not the case. See attached file for the address list specifications:
tekst.txt
0
 

Author Comment

by:PramoIT
ID: 38739640
Is the change effective immediately or not?
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 
LVL 37

Expert Comment

by:ArneLovius
ID: 38739643
Your filter is not the same...

I would suggest trying it with the same syntax as per my example.
0
 

Author Comment

by:PramoIT
ID: 38739672
I have done that, but still no public folder in that address list. See attached file for address list specs.
tekst2.txt
0
 
LVL 37

Expert Comment

by:ArneLovius
ID: 38739699
I would try forcing a rebuild of the offline address list.
0
 

Author Comment

by:PramoIT
ID: 38739708
I that also necessary when they only use outlook web access? They dont use outlook.
0
 
LVL 27

Expert Comment

by:Steve
ID: 38739719
the offline address book is not used for OWA.

Do you get an error or bounceback when you try to send as the public folder?
Have you tried typing the 'from' address in manually to see what it does?
Can you create a user/mailbox that uses the default address book so you can test it. that will confirm if the address book is the cause or not.
0
 
LVL 37

Assisted Solution

by:ArneLovius
ArneLovius earned 500 total points
ID: 38739721
forcing a rebuild of the offline list also triggers a rebuild of the address list, to just do the address list run the below in the EMS

Update-GlobalAddressList -Identity 2674xxxx

Open in new window


then monitor the server application event log for completeion
0
 

Author Comment

by:PramoIT
ID: 38739745
Hi Totallyonto,

Yes, we get an error stating we do not have permission to send as that user.
Yes, we have typed in the address in the from field.
Yes, we have tested with a user that uses the default global address book, and for him it works when give him the send as permissions for the public folder.

@ Arnelovius,

I have run the command and wait for the result.
0
 
LVL 27

Expert Comment

by:Steve
ID: 38741752
Thanks PramoIT. always checking we're on the right lines...

Let us know what happens when you have rebuilt the address book.
0
 

Author Comment

by:PramoIT
ID: 38745187
It seems to work! But there's no logic in it. Because I added a public folder later, and that one was added automtically to the addresslist. And today added one other public folder, and this one is still not visible???

I think it will be visible later on, otherwise i will have to do an other global address book update.

Thanks!
0
 
LVL 27

Expert Comment

by:Steve
ID: 38745398
interesting. check the event logs around the time you created the new email address and also when you rebuilt the address book to see if any errors were thrown.
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question