Solved

IPSEC Tunnel Site to Site ASA no egress interface

Posted on 2013-01-02
13
5,433 Views
Last Modified: 2013-01-07
Hello Experts,

we're currently trying to setup an IPSEC VPN connection site to site between our ASA and our pfsense router.
On the pfsense all VPNs are working properly.
I've also tried it with a ASA 5505 to our ASA. The same result
The tunnel is established but there is no traffic like ping or https.
In the log this message appears:

6      Jan 03 2013      01:37:05            192.168.30.9      56456                  Failed to locate egress interface for TCP from outside:192.168.30.9/56456 to 192.168.247.1/443

: Saved
:
ASA Version 9.1(1) 
!
hostname asa1
domain-name customer.local
enable password wewrwrDuyjDtr encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd 2KFQnbNEwdI.2rr2 encrypted
names
!
interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address 87.200.202.130 255.255.255.240 
!
interface GigabitEthernet0/1
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/2
 description Switch Routing network
 nameif inside
 security-level 100
 ip address 192.168.247.1 255.255.255.0 
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 nameif DMZ
 security-level 50
 ip address 192.168.233.1 255.255.255.0 
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 0
 ip address 192.168.246.1 255.255.255.0 
!
boot system disk0:/asa911-smp-k8.bin
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 87.200.203.3
 name-server 87.200.204.3
 domain-name customer.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network WAN
 range 87.200.202.131 87.200.202.142
object network Insideout
 subnet 192.168.247.0 255.255.255.0
object network insideout
 subnet 192.168.247.0 255.255.255.0
object network Switch1_ge1_1_4_IP
 host 192.168.247.2
object network Management_Segment
 subnet 192.168.253.0 255.255.255.0
object network Data_Segment
 subnet 192.168.254.0 255.255.255.0
object network NETWORK_OBJ_192.168.247.0_24
 subnet 192.168.247.0 255.255.255.0
object network NETWORK_OBJ_192.168.5.0_24
 subnet 192.168.5.0 255.255.255.0
object network outside-ip-132
 host 87.200.202.132
object network dc01.customer.local
 host 192.168.254.10
object network egress.canit.ca
 fqdn v4 egress.canit.ca
object network NETWORK_OBJ_10.252.150.0_24
 subnet 10.252.150.0 255.255.255.0
object network VPN_LAN
 subnet 192.168.30.0 255.255.255.0
object service ssl
 service tcp destination eq https 
object network Portal
 host 192.168.247.1
object network outside-ip-133
 host 87.200.202.133
object network outside-ip-134
 host 87.200.202.134
object network mail01.customer.local
 host 192.168.254.20
object network mail01-smtp.customer.local
 host 192.168.254.20
object network outside-ip-130
 host 87.200.202.130
object network portal
 host 192.168.233.1
object service rdp
 service tcp destination eq 3389 
object service ASA_MGMT_HTTPSALT
 service tcp destination eq 4433 
object network Management
 host 192.168.247.1
 description mgmtxs
object network HTTPSExtern
 host 192.168.247.1
object network test
 host 192.168.247.1
object network mangmt
 subnet 192.168.253.0 255.255.255.0
object network mgmtsegment
 subnet 192.168.253.0 255.255.255.0
object network test2
 subnet 192.168.253.0 255.255.255.0
object network datasegmt
 subnet 192.168.254.0 255.255.255.0
object network inside-net
 subnet 192.168.247.0 255.255.255.0
object network vpn-subnets
 host 192.168.1.0
object network man01
 host 192.168.253.20
object network mansegmnt
 host 192.168.253.0
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network 1
 host 192.168.1.1
object network RDP_MAN01
 host 192.168.253.20
 description MAN01 RDP XS
object network Man01rdp
 host 192.168.253.20
object network 192.168.30.0
 subnet 192.168.30.0 255.255.255.0
 description VPN_LAN
object-group network DM_INLINE_NETWORK_1
 network-object object Data_Segment
 network-object object Management_Segment
object-group service mail01-group tcp
 port-object eq https
 port-object eq smtp
object-group service DM_INLINE_TCP_1 tcp
 port-object eq https
 port-object eq smtp
object-group service DM_INLINE_TCP_3 tcp
 port-object eq www
 port-object eq https
object-group service DM_INLINE_TCP_2 tcp
 port-object eq https
 port-object eq smtp
object-group network DM_INLINE_NETWORK_3
 network-object object ALG_Segment
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object icmp
 protocol-object icmp6
object-group network DM_INLINE_NETWORK_2
 network-object 192.168.247.0 255.255.255.0
 network-object object mangmt
access-list outside_cryptomap extended permit ip 192.168.247.0 255.255.255.0 192.168.5.0 255.255.255.0 
access-list outside_access_in extended permit tcp object egress.canit.ca object dc01.customer.local eq ldap 
access-list outside_access_in extended permit tcp object egress.canit.ca object mail01.customer.local object-group DM_INLINE_TCP_1 
access-list outside_access_in extended permit tcp any object mail01.customer.local object-group DM_INLINE_TCP_2 
access-list outside_access_in extended permit object rdp object 82.29.110.117 object man01 
access-list outside_cryptomap_1 extended permit ip 192.168.247.0 255.255.255.0 192.168.5.0 255.255.255.0 
access-list outside_cryptomap_2 extended permit ip 192.168.247.0 255.255.255.0 192.168.5.0 255.255.255.0 
access-list outside_cryptomap_3 extended permit ip 192.168.247.0 255.255.255.0 192.168.5.0 255.255.255.0 
access-list outside_cryptomap_4 extended permit ip 192.168.247.0 255.255.255.0 object Wolfgang_Private 
access-list inside_access_in extended deny tcp object-group DM_INLINE_NETWORK_3 any object-group DM_INLINE_TCP_3 
access-list inside_access_in extended permit ip any any 
access-list inside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 any any 
access-list outside_cryptomap_5 extended permit ip object-group DM_INLINE_NETWORK_2 object 192.168.30.0 
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu DMZ 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-711.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static inside-net inside-net destination static vpn-subnets vpn-subnets
nat (inside,outside) source static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2 destination static 192.168.30.0 192.168.30.0 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
object network Man01rdp
 nat (outside,inside) static outside-ip-132 service tcp 3389 3389 
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 87.200.202.129 1
route inside 192.168.249.0 255.255.255.0 192.168.247.2 1
route inside 192.168.250.0 255.255.255.0 192.168.247.2 1
route inside 192.168.251.0 255.255.255.0 192.168.247.2 1
route inside 192.168.252.0 255.255.255.0 192.168.247.2 1
route inside 192.168.253.0 255.255.255.0 192.168.247.2 1
route inside 192.168.254.0 255.255.255.0 192.168.247.2 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable 4433
http 192.168.248.0 255.255.255.0 inside
http 192.168.246.0 255.255.255.0 management
http 192.168.0.0 255.255.0.0 inside
http 82.29.110.117 255.255.255.255 outside
http redirect inside 80
http redirect outside 80
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
sysopt noproxyarp outside
sysopt noproxyarp DMZ
sysopt noproxyarp management
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto map outside_map 1 match address outside_cryptomap_4
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer 82.29.110.117 
crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA
crypto map outside_map 1 set nat-t-disable
crypto map outside_map 2 match address outside_cryptomap_5
crypto map outside_map 2 set pfs 
crypto map outside_map 2 set peer 90.64.79.243 
crypto map outside_map 2 set ikev1 transform-set ESP-AES-128-SHA
crypto map outside_map interface outside
crypto ca trustpool policy
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 192.168.248.0 255.255.255.0 inside
ssh 192.168.0.0 255.255.0.0 inside
ssh 192.168.1.0 255.255.255.0 management
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
 enable inside
 enable DMZ
 tunnel-group-list enable
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
group-policy GroupPolicy_82.29.110.117 internal
group-policy GroupPolicy_82.29.110.117 attributes
 vpn-tunnel-protocol ikev1 
group-policy GroupPolicy_90.64.79.243 internal
group-policy GroupPolicy_90.64.79.243 attributes
 vpn-tunnel-protocol ikev1 
username test password 71BvR7vkjFka7tcA encrypted
username test attributes
 service-type remote-access
tunnel-group DefaultWEBVPNGroup webvpn-attributes
 group-alias testvpn enable
tunnel-group 82.29.110.117 type ipsec-l2l
tunnel-group 82.29.110.117 general-attributes
 default-group-policy GroupPolicy_82.29.110.117
tunnel-group 82.29.110.117 ipsec-attributes
 ikev1 pre-shared-key *****
 peer-id-validate nocheck
tunnel-group 90.64.79.243 type ipsec-l2l
tunnel-group 90.64.79.243 general-attributes
 default-group-policy GroupPolicy_90.64.79.243
tunnel-group 90.64.79.243 ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect ip-options 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny  
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip  
  inspect xdmcp 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly 22
  subscribe-to-alert-group configuration periodic monthly 22
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:aaa164dc6123a6d1b8454ff32ca17cfc
: end
asdm image disk0:/asdm-711.bin
no asdm history enable

Open in new window

0
Comment
Question by:penthese
  • 7
  • 6
13 Comments
 
LVL 15

Expert Comment

by:max_the_king
Comment Utility
Hi,
it's been hard to read your configuration, mainly because it has been probably written by asdm ... and this is why i hate that gui interface. It just messes things up.

Anyway, you may want tot try the following:

no nat (inside,outside) source static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2 destination static 192.168.30.0 192.168.30.0 no-proxy-arp route-lookup

nat (inside,outside) source static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2 destination static VPN_LAN VPN_LAN no-proxy-arp route-lookup

clear xlate

those are in fact two different objects for ASA, and one of them had been previously natted, that's why it didn't find egress interface

hope this helps
max
0
 

Author Comment

by:penthese
Comment Utility
Hello,

thanks for your response max.

I've tried these commands, no errors returned but it's still the same error message stating that it cannot locate the egress interface.
Do you have any more ideas?
Thanks in advance!
0
 
LVL 15

Expert Comment

by:max_the_king
Comment Utility
Hi,
please try and delete the "route lookup" instruction:

no nat (inside,outside) source static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2 destination static 192.168.30.0 192.168.30.0 no-proxy-arp route-lookup

nat (inside,outside) source static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2 destination static VPN_LAN VPN_LAN no-proxy-arp

clear xlate

hope this helps
max
0
 
LVL 15

Accepted Solution

by:
max_the_king earned 500 total points
Comment Utility
If that still doesn't work, please try and remove the no-proxy-arp instruction as well, because i'm not sure you need it (keep in mind that if the ASA cannot proxy arp requests, it must relies on routing, which is what it is failing in your scenario):

nat (inside,outside) source static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2 destination static VPN_LAN VPN_LAN

max
0
 

Author Comment

by:penthese
Comment Utility
Hello Max,

thank you very much thats working like a charm!!

One other issue persists which you might know. As you can see we have a public routed subnet.
I did create a nat rule from outside to inside listening on ip .132 instead of the asa original .130 ip.
But even in the log nothing comes in to .132 when connecting.
Did i do something wrong regarding the setup?
Thanks in advance.
0
 
LVL 15

Expert Comment

by:max_the_king
Comment Utility
Hi,

you should revert order in your nat statement:

object network Man01rdp
 nat (inside,outside) static outside-ip-132 service tcp 3389 3389

indtead of

object network Man01rdp
 nat (outside,inside) static outside-ip-132 service tcp 3389 3389

max
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:penthese
Comment Utility
Hello,

thanks once again, it's only working if i'm using the outside interface, so the public interfaces ip the .130.
Not if i'm using any other ip of the subnet.
Do you have any suggestions?
Thanks !
0
 
LVL 15

Expert Comment

by:max_the_king
Comment Utility
Hi,
i'm afraid you have the wrong access-list:
please try this:

no access-list outside_access_in extended permit object rdp object 82.29.110.117 object man01

access-list outside_access_in extended permit tcp any host 82.29.110.117 host object man01 eq rdp

this will allow the only external ip 82.29.110.117 to access server man01 (on its natted public ip) to only port 3389

after the above 2 commands you should digit a "clear xlate" on tha ASA

max
0
 

Author Comment

by:penthese
Comment Utility
Hi,

thanks again.

The command is giving an syntaxis error:
access-list outside_access_in extended permit tcp any host 82.29.110.117 host object man01 eq rdp

i've tried it with:
access-list outside_access_in line 5 extended permit tcp any eq 3389 object man01  but thats also giving me no response and no logging entries when trying to reach it using the outside .132 address.
0
 
LVL 15

Expert Comment

by:max_the_king
Comment Utility
access-list outside_access_in line 5 extended permit tcp any host 192.168.253.20 eq 3389

max
0
 

Author Comment

by:penthese
Comment Utility
Hello,

thank you i've tried it but nothing seems to happen when accessing the ip 87.200.202.132

The whole logging states nothing about it.

Am i doing something wrong?
Thanks.
0
 
LVL 15

Expert Comment

by:max_the_king
Comment Utility
hi,
this is what you need:

object network Man01rdp
 host 192.168.253.20
 nat (inside,outside) static outside-ip-132 service tcp 3389 3389

access-list outside_access_in line 5 extended permit tcp any host 192.168.253.20 eq 3389

if you don't see hitcount increment it means that the static pat is not working
it might be because of obj_any which may already nat that address:
in that case you could try and remove obj_any from your config but then you must nat the subnets you need, e.g. (after removing obj_any):

object network NETWORK_OBJ_192.168.247.0_24
 nat (inside,outside) dynamic interface

and do the same for each subnet you want to nat

but this is a problem that is going far away from your initial request

max
0
 

Author Comment

by:penthese
Comment Utility
Thank you very much for your support.
You've helped u miles further!
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now