• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1090
  • Last Modified:

SBS-E 2011 - Can't Remote Access just one Computer Name

I have a just implemented an SBS Essentials 2011 network with 12 PCs (mix of XP and W7). Remote access is working OK except for just one PC.

Computer "XXXXWS001" won't proceed past the "Initiating remote connection..."
and eventually gives the error message
    "Remote desktop can't find the computer "XXXXWS001" This might mean
     that "XXXXWS001" does not belong to the specified network..........
The SBS-E Dashboard sees the computer OK and I have added the computer access to the appropriate users.

In desperation I removed the computer from the network, changed its ID to "XXXXWS013" and re-connected it to the network using the connect wizard.
This time remote access worked fine!

Unfortunately I need to get "XXXXWS001" working as a software app is using preset PC IDs as a licence check.

I thought, just a hipcup with the first experience so I disconnected "XXXXWS013" and renamed the computer back to "XXXXWS001" and connected it again using the wizard.
Remote access did not work!!!!

So, "XXXXWS013" does work but  "XXXXWS001" refuses to work.
(I have 11 other PCs working fine)

I have looked for a loose end both local and at the server but I'm lost ... any thoughts where to look and what to look for?

Thanks
0
Benview
Asked:
Benview
  • 3
  • 3
  • 2
  • +1
3 Solutions
 
epohlCommented:
Can you connect to XXXXWS001 using RDP from another machine on the LAN? I would check DNS and make sure the entries for XXXXWS001 are correct.
0
 
Olaf De CeusterCommented:
Run (in admin mode) on server:
ipconfig /flushdns

On the 001 workstation:
In Admin mode:
Rub following:
Ipconfig /release
Ipconfig /renew
Ipconfig /flushdns
ipconfig /registerdns
net stop netlogon
net start netlogon.

If windows 7 over and above: EDisable and re-enable the network card.
Hope that helps,
Olaf
0
 
BenviewAuthor Commented:
Thanks epohlolafdc for the quick response:

I found that I can connect to XXXXWS001 using RDP but, only using its local IP  not using its computer name.

I checked the router, the IP is within scope.
I have run the commands suggested by olafdc.... they all seemed to process OK but the result is still the same .... cannot remote access XXXXWS001 using the computer name.

My router and SBS-E do not see eye-to-eye on UPnP but as 11 other PCs do remote access OK I did not see this as an issue. When I Disabled the network card it tried to tell me it couldn't because of UPnP but it did disconnect and re-enabled OK. (Broadcom NetExtreme 57xx)

Any other ideas?
0
2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

 
Olaf De CeusterCommented:
Issue is defenitely DNS.
Can you make a manual A record?
Olaf
0
 
thomasclmCommented:
As suggested by "olafdc" it seems like a DNS issue, can you try the command "NSLOOKUP XXXXWS001" and make sure it resolves to the correct IP, else please correct it.

Regards,
Thomas
0
 
BenviewAuthor Commented:
OK thomasclm we're getting warmer.......

C:\>nslookup XXXXWS001
Server:   UnKnown
Address:  192.168.1.200                    (This is the server)
Name:    XXXXWS001.DOMAIN.Local
Address:  192.168.0.24                      (This is incorrect it should be 192.168.1.150)

I tried the other computer names and the correct IPs were returned.

I recognise the incorrect address... it comes from the router environment where the SBS Essentials server was set up with a test PC before moving to live. I thought I removed all traces of that DHCP.

As olafdc suggested above I have done a ipconfig /flushdns at the server but without success.... I have looked everywhere but just cannot find 192.168.0.24 within the server.... there must be somewhere yet to look.....or other commands to run at the server!

Suggestions
0
 
thomasclmCommented:
Login to  XXXXWS001 and make sure its pointing to your correct DNS server as preferred DNS Server and go to command prompt and execute  "ipconfig /registerdns".
Try "nslookup XXXXWS001" to ensure its resolving to correct IP.

Else you can manually edit the HOST (A) record in dns server with the correct IP.
0
 
BenviewAuthor Commented:
SUCCESS

I found an old reference to XXXXWS001 - 192.168.0.24 in the server ForestDnsZone....once I cleaned this out and made sure nslookup XXXXWS001 at the computer was returning the correct IP - 192.168.1.150 then Remote Access using the computer name was successful.

I've learnt some!!!!

Thanks to all for your help today .. everyone was pointing me toward a DNS solution
0
 
Olaf De CeusterCommented:
If you can't make a maunual A record you  can uninstall the nic or nics (if you have wireless too) and restart the computer.
The N
Nic will automatically reinstall but all cache will be deleted.
This will tell you if issue is with workstation or server.
Olaf
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 3
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now