Avatar of detox1978
detox1978
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Throughput drops MPIO is enabled

Hi All,

I recently bought a Dell EqualLogic and am currently in the process of setting it up.

I've installed the Dell Microsoft HIT and enabled MPIO (or at least I think I have!).

Using Crystal DiskMark the read/writes went from 108MB/s to 57MB/s


Any ideas why?
StorageWindows Server 2008VirtualizationDell

Avatar of undefined
Last Comment
detox1978

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
detox1978

ASKER
Thanks for the screen shots.  I think this has highlighted part of the issue.  Two of the NICs arent active.

I can confirm this by copying 1GB of data to the SAN and viewing task manager NIC usage.

Any ideas how I activate them all?
MPIO.png
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

check MPIO settings, and Include or Exclude Adaptors for use.

e.g. Click the MPIO button, on that screenshot, and then select MPIO Settings, and check the Included/Excluded NICs.

also make sure all nics are connected, enabled, with IP Addresses.
detox1978

ASKER
Ok, after a lot of blindly pressing buttons I finally worked out the issue was.

Two of the NICs have the same MAC address.

I've manually changed NIC1, which has resolved the issue.


many thanks
Your help has saved me hundreds of hours of internet surfing.
fblack61
detox1978

ASKER
I may have jumped the gun thinking this was sorted.

Two of the NIC's are showing as

There are no active sessions on this adapter.

They are listed in the Dell software.

MPIO issue
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

but how have you defined access to your LUNs, because you have got two LUNs in use

ambackup
vss-control

are you sure, they have the correct chap settings, or IP Address have been allowed access

there are no sessions, because those NICs are no connected to the SAN.

check access on the SAN
detox1978

ASKER
The volume "ambackup" has unrestricted access.  I'm not sure what "vss-control", I think it was created when I setup VSS using the HIT wizard.  There isnt a volume with that name.

Any suggestions on what to check?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

check, access logs on SAN, another thing I noticed, that you should be connecting to the PS IP Address e.g. 192.168.1.1

and your controllers should have two IP Addresses, e.g. 192.168.1.2 and 192.168.1.3

and you will find you also get connections to thos eas well.

check all networking, check those nics can connect to the SAN, you may need to disable all the others, and use ping etc
detox1978

ASKER
Here are my IP settings;

SAN Settings
  Group Name:            SAN
  Group IP:             192.168.1.1
  Group Subnet:      255.255.255.0

  Member Name:      SAN1
    eth0:            192.168.1.2
    eth1:            192.168.1.3
    eth2:            10.10.1.35                  (from our internal LAN)


iSCSI Switch
  Master IP            192.168.1.10
  Management IP      10.10.1.37            (from our internal LAN)


I dont know what you mean by, you should be connected to 192.168.1.1


I can connect a laptop on the iSCSI subnet and PING all NICs, also if i swap the RJ45 cables around, the same two IP's work regardless of which switch or port they are in.
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

192.168.1.1 should be the IP Address used as the target

those nics are not connecting to the SAN

disable the others and test
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
detox1978

ASKER
If i remove everything from within iSCSI initiator and connect to the target 192.168.1.1 it only returns the iSCSI target by name (not IP), which when selected adds the IP addresses 192.168.1.2 and 192.168.1.3 to the MPIO tab.

Is there something I've setup incorrectly in the SAN Admin Console?


Are you sure it should be the single IP address as all the images on Google appear to be using the eth0 and eth1 IP's

See image at the bottom
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

Our understanding is that you must connect to the Primary Address, so failover works to the other controller correctly.

the primary address is a sort of load balancer.
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

also see here

http://mikefrobbins.com/2011/04/14/multipath-io-on-server-core-with-the-equallogic-hit-kit/

it also states

Enter the group IP address of your SAN in the discovery portal section on the discovery
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
detox1978

ASKER
His instruction say to add the SAN IP into the discovery tab.  Which I did.  But still get the same results.


http://mikefrobbins.com/2010/08/19/iscsi-initiator-configuration-on-windows-2008-r2-server-core/
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

yes, group IP Address. (which is different from the two controller IP addresses)

I'll experiment with NICs and IP addresses here, see if I can reproduce your issues.
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

okay, I've just given another two nics, in our test server IP addresses 10.10.1.225 and 10.10.1.226, these are currently not connected to the switches.

we already have two nics with IP Addresses 10.10.1.223, and 224, and although we have used the PS Group IP Address 10.10.1.1, connections are being made to 10.10.1.2 and 10.10.1.3, so we currently have four paths as follows:-

MPIO-iSCSI3
these do not appear in my list yet, because they have no physical connection.

Just going to plug them in to the switch.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

after connecting them to the switch, I get no Active connections for 225 and 226, and that's because I've not given those IP Addresses Access to the Volume, Access Tab on the Volumes.

and you can also use the Connections Tab on the Volume to check the Connection.

So I would check access to the Volumes, and also check your preferred Failover Policy.

I've also found out today, HiT 4.5 has finally been released.
detox1978

ASKER
I left the access as unrestricted.

If you add them do they become active?
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

Yes, we add the IP Address that are required to access each volume.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
detox1978

ASKER
But if you add 225 and 226 they become active?
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

yes.
detox1978

ASKER
Is there a way to increase the number of connections?

If I manually add another two via "> Targets > Properties", they appear in the MPIO tab assigned to .32 and .33 (which are already in use).  30 and 31 always stay inactive.

After around 5 minutes the two new connection disappear and are removed from the  "> Targets > Properties"
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

it's based on the MPIO Policy, and how active your LUNs are!
detox1978

ASKER
I've tried everything and can't get all four connections active.

In your screen shot you appear to have two NICs, 223 & 224.  Can you try adding four?
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)

I have added four, and the paths are multipathed across all four, when you load up your LUNs!

the screenshot provided was before I configured the other NICs!

if you have connections our of the four connected, multipath is functuioning, also make sure you have multipath ticked and connected to the LUN as well.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
detox1978

ASKER
I raised a ticket with Dell support and they said the Equal Logic is limited to two connections per physical SAN - as it only has two active NICs.  They ran a few test and confirmed everything was working ok.

Many thanks for your time and persistence.