Solved

Throughput drops MPIO is enabled

Posted on 2013-01-03
26
1,164 Views
Last Modified: 2016-11-23
Hi All,

I recently bought a Dell EqualLogic and am currently in the process of setting it up.

I've installed the Dell Microsoft HIT and enabled MPIO (or at least I think I have!).

Using Crystal DiskMark the read/writes went from 108MB/s to 57MB/s


Any ideas why?
0
Comment
Question by:detox1978
  • 14
  • 12
26 Comments
 
LVL 117

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE) earned 500 total points
Comment Utility
are both paths in use?

check iSCSI Initiator Properties in Control Panel, Dell Equallogic MPIO Tab

We've not seen this, just tested, and it does not make any difference on our setups.

see images

 

 MPIO-iSCSI1
MPIO iSCSI2
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
Thanks for the screen shots.  I think this has highlighted part of the issue.  Two of the NICs arent active.

I can confirm this by copying 1GB of data to the SAN and viewing task manager NIC usage.

Any ideas how I activate them all?
MPIO.png
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
check MPIO settings, and Include or Exclude Adaptors for use.

e.g. Click the MPIO button, on that screenshot, and then select MPIO Settings, and check the Included/Excluded NICs.

also make sure all nics are connected, enabled, with IP Addresses.
0
 
LVL 2

Author Closing Comment

by:detox1978
Comment Utility
Ok, after a lot of blindly pressing buttons I finally worked out the issue was.

Two of the NICs have the same MAC address.

I've manually changed NIC1, which has resolved the issue.


many thanks
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
I may have jumped the gun thinking this was sorted.

Two of the NIC's are showing as

There are no active sessions on this adapter.

They are listed in the Dell software.

MPIO issue
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
but how have you defined access to your LUNs, because you have got two LUNs in use

ambackup
vss-control

are you sure, they have the correct chap settings, or IP Address have been allowed access

there are no sessions, because those NICs are no connected to the SAN.

check access on the SAN
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
The volume "ambackup" has unrestricted access.  I'm not sure what "vss-control", I think it was created when I setup VSS using the HIT wizard.  There isnt a volume with that name.

Any suggestions on what to check?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
check, access logs on SAN, another thing I noticed, that you should be connecting to the PS IP Address e.g. 192.168.1.1

and your controllers should have two IP Addresses, e.g. 192.168.1.2 and 192.168.1.3

and you will find you also get connections to thos eas well.

check all networking, check those nics can connect to the SAN, you may need to disable all the others, and use ping etc
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
Here are my IP settings;

SAN Settings
  Group Name:            SAN
  Group IP:             192.168.1.1
  Group Subnet:      255.255.255.0

  Member Name:      SAN1
    eth0:            192.168.1.2
    eth1:            192.168.1.3
    eth2:            10.10.1.35                  (from our internal LAN)


iSCSI Switch
  Master IP            192.168.1.10
  Management IP      10.10.1.37            (from our internal LAN)


I dont know what you mean by, you should be connected to 192.168.1.1


I can connect a laptop on the iSCSI subnet and PING all NICs, also if i swap the RJ45 cables around, the same two IP's work regardless of which switch or port they are in.
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
192.168.1.1 should be the IP Address used as the target

those nics are not connecting to the SAN

disable the others and test
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
If i remove everything from within iSCSI initiator and connect to the target 192.168.1.1 it only returns the iSCSI target by name (not IP), which when selected adds the IP addresses 192.168.1.2 and 192.168.1.3 to the MPIO tab.

Is there something I've setup incorrectly in the SAN Admin Console?


Are you sure it should be the single IP address as all the images on Google appear to be using the eth0 and eth1 IP's

See image at the bottom
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
Our understanding is that you must connect to the Primary Address, so failover works to the other controller correctly.

the primary address is a sort of load balancer.
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
also see here

http://mikefrobbins.com/2011/04/14/multipath-io-on-server-core-with-the-equallogic-hit-kit/

it also states

Enter the group IP address of your SAN in the discovery portal section on the discovery
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 2

Author Comment

by:detox1978
Comment Utility
His instruction say to add the SAN IP into the discovery tab.  Which I did.  But still get the same results.


http://mikefrobbins.com/2010/08/19/iscsi-initiator-configuration-on-windows-2008-r2-server-core/
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
yes, group IP Address. (which is different from the two controller IP addresses)

I'll experiment with NICs and IP addresses here, see if I can reproduce your issues.
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
okay, I've just given another two nics, in our test server IP addresses 10.10.1.225 and 10.10.1.226, these are currently not connected to the switches.

we already have two nics with IP Addresses 10.10.1.223, and 224, and although we have used the PS Group IP Address 10.10.1.1, connections are being made to 10.10.1.2 and 10.10.1.3, so we currently have four paths as follows:-

MPIO-iSCSI3
these do not appear in my list yet, because they have no physical connection.

Just going to plug them in to the switch.
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
after connecting them to the switch, I get no Active connections for 225 and 226, and that's because I've not given those IP Addresses Access to the Volume, Access Tab on the Volumes.

and you can also use the Connections Tab on the Volume to check the Connection.

So I would check access to the Volumes, and also check your preferred Failover Policy.

I've also found out today, HiT 4.5 has finally been released.
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
I left the access as unrestricted.

If you add them do they become active?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
Yes, we add the IP Address that are required to access each volume.
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
But if you add 225 and 226 they become active?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
yes.
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
Is there a way to increase the number of connections?

If I manually add another two via "> Targets > Properties", they appear in the MPIO tab assigned to .32 and .33 (which are already in use).  30 and 31 always stay inactive.

After around 5 minutes the two new connection disappear and are removed from the  "> Targets > Properties"
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
it's based on the MPIO Policy, and how active your LUNs are!
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
I've tried everything and can't get all four connections active.

In your screen shot you appear to have two NICs, 223 & 224.  Can you try adding four?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
I have added four, and the paths are multipathed across all four, when you load up your LUNs!

the screenshot provided was before I configured the other NICs!

if you have connections our of the four connected, multipath is functuioning, also make sure you have multipath ticked and connected to the LUN as well.
0
 
LVL 2

Author Comment

by:detox1978
Comment Utility
I raised a ticket with Dell support and they said the Equal Logic is limited to two connections per physical SAN - as it only has two active NICs.  They ran a few test and confirmed everything was working ok.

Many thanks for your time and persistence.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now