Avatar of avir
avir
 asked on

compatibility problem in ie8

Hi
I have a  curious ie8 problem with a "if you cannot see this email correctly..." link on an email that links to a wordpress site.  When clicking on the link, the site initially comes up in ie8 in a non-compatibility mode and the styles go crazy. Needless to say, I don't have this problem in ie9 or any other browsers. I've tried playing with the
<meta http-equiv="X-UA-Compatible" content="..." /> tag, but it doesn't seem to make any difference, although when I refresh the page, the problem disappears. Does anyone know of anything else I could try? Is there some way of forcing an initial refresh just for ie8 users?
Thanks,
AviR
Web BrowsersHTMLCSS

Avatar of undefined
Last Comment
avir

8/22/2022 - Mon
Kyle Hamilton

whats your doctype?
Kyle Hamilton

also, you beed to post a link to the site
avir

ASKER
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

The site is:
http://www.imj.org.il/youthwing/magazine
It's in Hebrew.

A copy of the newsletter that was sent can be found at:
http://www.imj.org.il/youthwing/magazine/send/01-13.html
Also in Hebrew, but it's the very top link.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
avir

ASKER
Screenshots
good.jpg
bad.jpg
avir

ASKER
I have another somewhat related problem with the same site. I don't know if I should post a separate question, but I will try including it here.
The same site appears in Chrome with a large uncalled for space between the header and the content. I can't figure out where it is coming from and it only appears in Chrome. Any ideas?
chrome.jpg
Mohammed Hamada

Looks like a browser issue, is the IE8 fully patched ?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Kyle Hamilton

I would recommend updating the site to HTML5 doctype:

<!DOCTYPE html>
<html  lang="he-IL" >
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
...

Open in new window


The gap in chrome is funky. I would suggest deleting that empty space from the source of the document to see if that helps. Sometimes you can get weird invisible characters that come from whatever editor you're using. (when I deleted the empty space in the chrome dev tools inspector, the gap went away)

Give all that a try.
SOLUTION
COBOLdinosaur

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
SOLUTION
jcimarron

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
avir

ASKER
Thanks for all the feedback.
I've been checking the site on different browsers on different machines in the office. I have no idea if ie8 on the different machines is fully patched.
Since the site is built on a preexisting wordpress theme I don't what kind of effect there will be if I change the doctype to html 5, but I can give it a try.
Regarding the Chrome gap, although the gap appears in the dev tool and it can be deleted there, I am unable to find it in the source code. That's why I can't figure out where it's coming from. My editor is Visual Studio.
Regarding cleaning up the code, well I guess I have my work cut out for me, although I don't know how much is my fault and how much is in the theme itself. In any case, I'll give it a try although it will probably take awhile.
Thanks,
ASKER CERTIFIED SOLUTION
jcimarron

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
avir

ASKER
I fixed most of the validation errors. Most of them were due to my sloppiness, a couple come from the theme code and a few come from external link parameters, which I can't do anything about. In any case, something worked, because the ie8 problem is fixed. Unfortunately, I still have that curious gap that appears only in Chrome.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy