Solved

CSS not working

Posted on 2013-01-03
10
435 Views
Last Modified: 2013-01-04
Hello Experts,

I have an ASP.NET web application running on ASP.NET 4.0 and using IIS7 on Windows Server 2008 R2.

The problem that I have is when I run my web application locally on my laptop it looks fine. But when I upload my website to my webserver it does not render the page correctly. Any ideas why? Is there something in IIS that is preventing my page from using my CSS?

.NET Authorization Rules:
  - Deny Anonymous Users
  - Allow All Users

Authentication:
  - Windows Authentication enabled
  - All other authenticatio methods are disabled

If I perform a "Test Connection" in IIS I get the following warning below.
  - Authorization: Cannont verify access to path (C:\inet\www\cmdb)

The other weird thing is that if I view the page using FireFox it's fine. Only issue is with IE9.
0
Comment
Question by:asp_net2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
10 Comments
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 38741790
it does not render the page correctly

Not much of a description of what it is doing.  So in the absence of code, link and description of the problem I guess the only answer must be there is an error somewhere

Cd&
0
 
LVL 4

Author Comment

by:asp_net2
ID: 38741827
It's not rendering the page correctly in IE9 (gridview colors, properties for TextBox, DropDownList, etc..) . It's fine using anything but IE9. I even tried to apply a stylesheet for IE9 but no luck there either.

No error messages when running the page either.

I cannot provide a link for viewing.
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 38741842
It sounds like the CSS is not being loaded by IE9 which indicates that there is some kind of privilege or authorization issue with the location on the server where the CSS is stored.  As it works in other browsers, it suggests the problem is with IE, not the server; probably the internet options setting are wrong.

Cd&
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 7

Expert Comment

by:armchang
ID: 38741860
Can you add "X-UA-Compatible" header or META to force full IE8 standards mode to your page? As Microsoft introduced different rendering modes for local and Internet servers.

You can look at this on how to insert the tag unto your page: X-UA-Compatible

Other than that, we need to get screenshots of your settings and pages to get some idea on how to fix it.
0
 
LVL 4

Author Comment

by:asp_net2
ID: 38741861
What do you think I need to change?
0
 
LVL 7

Expert Comment

by:armchang
ID: 38742050
Put the tag below inside your <head></head> part of your html/aspx/php page:

<meta http-equiv="X-UA-Compatible" content="IE=8">

See if it works.

A
0
 
LVL 4

Author Comment

by:asp_net2
ID: 38743567
@armchang,

That did not work :(
Please see my Markup below.

<head runat="server">
    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=9">

    <!-- Set the viewport width to device width for mobile -->
    <meta name="viewport" content="width=device-width" />
    <title>CMDB | Dashboard</title>

    <link rel="stylesheet" href="css/main.css">
    <link rel="stylesheet" href="css/app.css">

    <script src="Scripts/WebForms/modernizr.foundation.js"></script>
</head>
0
 
LVL 4

Author Comment

by:asp_net2
ID: 38743569
@COBOLdinosaur,

Your information is not specific enough. Thanks for your help though.
0
 
LVL 7

Accepted Solution

by:
armchang earned 500 total points
ID: 38743654
Thanks for the reply.

I see. Would you try turning on/off the Compatibility View for the IE9. It may need to use it as this is a browser issue.

armchang
0
 
LVL 4

Author Closing Comment

by:asp_net2
ID: 38743750
Thank you very much. The browser was using compatibility mode for intranet websites.
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OfficeMate Freezes on login or does not load after login credentials are input.
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question