• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 383
  • Last Modified:

Internal IIS and DNS

I have a Windows 7 x64 Pro PC running IIS 7.0. The PC has a static IP address. IIS is configured and has an operational test site. The PC is joined to a domain.

The PC is part of a domain, it has an A record in the localdomain Forward Lookup Zones within DNS. It points to the static IP address of the PC.

Since the PC now has IIS setup I assumed that I would be able to open a browser and browse to the IP of the PC and get the test site. Didn't work.

I have created another A record within my .com forward lookup zones and it points to the static IP. that also did not work.

What I want to be able to do is access the test site by going to a URL from a separate, internal PC. Any input would be helpful. Thanks.
0
dguillen
Asked:
dguillen
  • 3
  • 2
1 Solution
 
Russ SuterCommented:
DNS operates on port 53. You might want to check your firewall rules.

Also, I've found that when browsing to a local site you can't just type in the IP address. It must be preceded by "http://"

Finally, make sure your IIS site is working by going to the machine on which IIS is configured and typing "localhost" in the address bar of a browser. If IIS is working you should see the website.
0
 
dguillenAuthor Commented:
Firewall is disabled.

I was using http:// and https:// (IIS is configured for both).

localhost did not work but the url did as well as the browse website feature within IIS on the local PC.
0
 
Dave BaldwinFixer of ProblemsCommented:
Also make sure that port 80 is open for external connections in your firewall.  There is also a place in the IIS manager that defines both the IP/port for the site and what external IPs are allowed to access the site.  But I can't find a page for it at the moment.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
dguillenAuthor Commented:
turns out that the firewall on the local pc was not disabled. disabled it and everything worked.
0
 
Russ SuterCommented:
The first thing I suggested was firewall rules and it turns out that was the problem.
0
 
dguillenAuthor Commented:
user error.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now