Solved

please help me fix the NIC in my hyper-v virtualized instance of SBS 2011

Posted on 2013-01-03
10
441 Views
Last Modified: 2014-11-12
First off, Im an idiot. Im in the midst of a job change, and in the flurry to wrap things up Ive done just about everything wrong that I could have. Heres where I am

I have 4 vhds that represent four hard drives in a virtualized 2011 SBS server. The host is 2008 R2 Std. One NIC on the host is for the host (192.168.0.253) and one NIC on the host is suppose to be an exclusive NIC for the guest (192.168.0.7)

Theres a long drawn out story about how we got here, but Im not sure it matters. Heres what I want to accomplish

1) clean out all references to old NICs from my bazillion "quick attempts" to fix this problem over the last 24 hours

2) create a virtual NIC and assign the original IP address to it

Theres lots of links on the web about how to make hidden NICs appear and uninstall them, but that alone isnt getting the job done. Who can help out?
0
Comment
Question by:Eric_Price
  • 7
  • 2
10 Comments
 
LVL 1

Author Comment

by:Eric_Price
Comment Utility
This link here is very much like the issue I am having.

http://www.mail-archive.com/ntsysadmin@lyris.sunbelt-software.com/msg113402.html
0
 
LVL 13

Expert Comment

by:Sandy
Comment Utility
please check with legacy network adapter.
0
 
LVL 1

Author Comment

by:Eric_Price
Comment Utility
I was just considering that Sandeep, mostly because im getting pretty desperate. Just hated to, knowing that once upon a time it worked with the normal driver.

Ill go ahead and throw out that Ive pretty well done these steps

•      Shut down the VM
•      removed the virtual NICs using the Hyper-V management console
•      started the VM
•      cleaned up some old phantom adapters
•      shut down the VM
•      re-added the virtual NICs in the management console
•      Started teh VM and configured its networking.

Also, for getting rid of the old adapters

1.      Open a command prompt with administrative privlidges (right-click, Run as administrator)
2.      In the command prompt enter the following two commands in order:
•      SET DEVMGR_SHOW_NONPRESENT_DEVICES=1
•      START DEVMGMT.MSC
3.      The second command is very important, because if you don't start the Device Manager session from inside the elevated command prompt you just opened, you won't have the proper settings.
4.      Once Device Manager is open, go to "View" and select "Show hidden devices"
5.      Expand "Network Adapters" and you should see any VM NICs that have been removed (they will be greyed out).  Select them, right-click and choose "Uninstall"

Original Article

This last time (which I just finished) I tried using a new IP (same subnet obviously) and I only added the vmware nic back in after a) reinstalling the integration software and b) removing any registry references to "Local Area Connection" in the HKLM\SYSTEM\ControlSet001\Control\Network section of the registry. I didnt find any articles telling me to do it per se, but Ive had trouble with server remembering my IP, and it seemed reasonable with the name (LAC) that they were left overs.

With that, I find that my IP address now "sticks" to the adapter in a way that it didnt before, and yet I still cant ping anything else on the network (which I can from the host). The error is either Destination host unreachable from the IP of the virtual guest or Request Timed Out. I can ping my own IP (now 192.168.0.251)

When I boot to safe mode with networking the result is the same - can ping self, but not network.

The firewall on both the host and guest are off at the present time.
0
 
LVL 1

Author Comment

by:Eric_Price
Comment Utility
Sandeep - It would not let me install a legacy driver. It knew it was the intel card, but said the device was configured incorrectly.
0
 
LVL 13

Assisted Solution

by:Sandy
Sandy earned 350 total points
Comment Utility
Eric, Please try following

1. Let the host machine as it is now just remove the virtual adapter from VM and under add new hardware please use legacy network adapter.

2. Ensure VLAN ID or trunk is configured (If applicable).

3. Configure VM Legacy network adapter with network configuration.

4. Also check any IPSEC policy is not in enforced condition.

Meanwhile i am also searching as how can i help out (if i can)
0
Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

 
LVL 1

Author Comment

by:Eric_Price
Comment Utility
That pretty well describes what I did, unless its late enough here that Im misinterpreting. I took the virtual down, removed the regular driver, booted up, went through the manual uninstall process, took the virtual back down, added the legacy, booted up. It intiially didnt have a driver for the legacy device (but did show it). When I asked it to scan for a suitable driver it indicated it knew it was the Intel card, but said it wasnt configured properly. Moreover, several of the things Ive read this evening suggest a) that the legacy card performs worse and b) more importantly, didnt support 64 bit versions of 2003 / xp. dont know if that changed moving forward or not.

I have since taken that card out and put the regular driver back in and once again have something that looks ok, until I actually need to ping something beyond my own virtual self.
0
 
LVL 1

Author Comment

by:Eric_Price
Comment Utility
So, if I do a

netsh interface ip show neighbors I get several entries. Here are some relevant ones

Internet Address                                 Physical Address                 Type
192.168.0.1                                         00-21-55-75-c3-16               Incomplete
192.168.0.9                                         Unreachable                        Unreachable
192.168.0.201                                     40-61-86-85-16-ee              Stale
224.0.0.22                                           01-00-5e-00-00-16               Permanent

Now 192.168.0.1 is saying its type is Probe
0
 
LVL 23

Assisted Solution

by:Mohammed Hamada
Mohammed Hamada earned 150 total points
Comment Utility
Maybe you should consider something like Treexy Driver cleaner to clean up drivers and their registry remnants as well.
0
 
LVL 1

Accepted Solution

by:
Eric_Price earned 0 total points
Comment Utility
So... thanks for the ideas guys. In the end, I ended up using a tool to programmatically clean out the registry and settings of all my old network information.

nvspscrub

It allowed me to do what I apparently could do manually. Or maybe I just got lucky. I linked to the tool though in case someone else comes along with the same problem.

Almost makes me pine for the old days of real network cards.

Almost.

Thanks again!
0
 
LVL 1

Author Closing Comment

by:Eric_Price
Comment Utility
The link I provided was the thing that ultimately fixed my phantom NIC issue and allowed me to start from scratch on rebuilding NICs and getting IPs assigned.
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Why should I virtualize?  It’s a question that’s asked often enough.  My response is usually “Why SHOULDN’T you virtualize?”
This is an issue that we can get adding / removing permissions in the vCSA 6.0. We can also have issues searching for users / groups in the AD (using your identify sources). This is how one of the ways to handle this issues and fix it.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
In this video tutorial I show you the main steps to install and configure  a VMware ESXi6.0 server. The video has my comments as text on the screen and you can pause anytime when needed. Hope this will be helpful. Verify that your hardware and BIO…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now