Solved

DHCP Requests not crossing switches when DHCP Server on another VLAN

Posted on 2013-01-04
15
1,073 Views
Last Modified: 2016-11-23
Hello Everyone

I am trying to get PCs on one VLAN to get a DHCP address from a server on VLAN 1. I was successful if I have the PC and server in same switch and PC port on VLAN 2. If I move the PC down a switch it no longer receives an address. Using Wireshark to monitor DHCP requests on the server there are none making it there. I have attached the layout and basic settings for the design. I am using 2 Dell Powerconnect 6224 L3 switch connect through a 10GB Stacking Ports.

Any help would be great.

Thanks
Ed
DHCP.pdf
0
Comment
Question by:flagshipcredit
  • 7
  • 4
  • 2
  • +2
15 Comments
 
LVL 17

Assisted Solution

by:jburgaard
jburgaard earned 100 total points
Comment Utility
There must be some sort of IP routing set up for packets from one vlan to reach other vlan. This is not mentioned. Missing?
0
 
LVL 18

Expert Comment

by:Akinsd
Comment Utility
Looks like you are using layer 3 switches.
If there is no router in your network, an L3 switch can be used to route packets
You need to create and define sub interfaces

eg
int f0/1
no switchport
int f0/1.1
encapsulation dot1q 1
ip add 192.168.70.1 255.255.255.0 (This makes 192.168.70.1 the gateway address for  vlan 1)

int f0/1
no switchport
int f0/1.2
encapsulation dot1q 2
ip add 192.168.72.1 255.255.255.0  (This makes 192.168.72.1 the gateway address for that vlan 2)

In global config mode
turn on routing
ip routing

IP Helper has to be configured on the gateway interfaces, eg F0/1.1 and F0/1.2

I am assuming you have created 2 DHCP scopes on your server for both networks
0
 
LVL 2

Assisted Solution

by:MaxEL_UA
MaxEL_UA earned 100 total points
Comment Utility
Hi,
according to yo problem - you have no L2 connectivity to DHCP Server.
You must have:
1. DHCP helper on your L2 segment
2. DHCP helper must send correct requests to DHCP Sercer (IP subnet must be dfined ob DHCP Server)
0
 
LVL 16

Assisted Solution

by:vivigatt
vivigatt earned 200 total points
Comment Utility
You need to set up a dhcp relay (named ip helper in the cisco world). Your dhcp discover packets (sent to broadcast address) will then be forwarded to the address specified (in another lan). This is a setting of the routing device (switch or router).
0
 

Author Comment

by:flagshipcredit
Comment Utility
Thank you for your replies....but still haven't figured it out. I have tried various combinations from your suggestions.

(1) Powerconnect 6224 as Gateway
(1) Powerconnect 6224 as L2 Switch with PC plugged into it on VLAN 2
If I plug PC into GW it gets IP address for the scope for VLAN 2
If I plug PC into L2 Switch it gets no IP
Below are my current configs.


Gateway
----------------
!Current Configuration:
!System Description "PowerConnect 6224, 3.3.4.1, VxWorks 6.5"
!System Software Version 3.3.4.1
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 2-3,666,999
vlan routing 1 1
vlan routing 3 2
vlan routing 2 3
vlan routing 999 4
exit
hostname "C1GW1"
sntp broadcast client enable
sntp client poll timer 1024
sntp server 192.168.30.8
clock summer-time recurring USA zone "EDT"
clock timezone -5 minutes 0 zone "EST"
stack
member 1 1
exit
ip address 10.52.0.2 255.255.255.0
ip default-gateway 10.52.0.254
ip address vlan 666
ip domain-name flagship.local
ip name-server 192.168.40.1
ip name-server 192.168.30.7
ip name-server 192.168.40.2
ip name-server 192.168.30.30
ip name-server 192.168.70.7
logging buffered debug
ip routing
arp dynamicrenew
router rip
no enable
distance rip 105
auto-summary
default-information originate
redistribute connected metric 1
redistribute static metric 1
exit
interface vlan 1
routing
ip address 192.168.70.251 255.255.255.0
ip ospf area 0.0.0.1
ip ospf cost 64
ip ospf priority 0
exit
interface vlan 2
routing
ip address 192.168.73.251 255.255.254.0
ip helper-address 192.168.70.7 dhcp
ip ospf area 0.0.0.1
ip ospf cost 64
ip ospf priority 0
exit
interface vlan 3
routing
ip address 192.168.75.251 255.255.254.0
ip ospf area 0.0.0.1
ip ospf cost 64
ip ospf priority 0
exit
interface vlan 999
routing
ip address 192.168.0.1 255.255.255.248
ip ospf area 0.0.0.0
ip ospf cost 128
exit
username "admin" password e07e3428d3d416beacafeb8c623ec979 level 15 encrypted
snmp-server enable traps dvmrp
snmp-server enable traps pim
snmp-server enable traps captive-portal client-auth-failure
snmp-server enable traps captive-portal client-connect
snmp-server enable traps captive-portal client-db-full
snmp-server enable traps captive-portal client-disconnect
snmp-server enable traps ospf all
snmp-server enable traps ospfv3 all
router ospf
router-id 0.0.0.70
no 1583compatibility
network 192.168.70.0 0.0.0.255 area 0.0.0.1
network 192.168.72.0 0.0.254.255 area 0.0.0.1
network 192.168.74.0 0.0.254.255 area 0.0.0.1
network 192.168.0.0 0.0.0.7 area 0.0.0.0
network 10.52.10.0 0.0.0.255 area 0.0.0.2
network 10.52.11.0 0.0.0.255 area 0.0.0.1
nsf
default-information originate always
redistribute connected subnets
redistribute static subnets
exit
sflow 1 destination owner 1 timeout 4291959797
sflow 1 destination 192.168.30.12 560
dhcp l2relay
ip arp inspection validate src-mac dst-mac ip
dos-control firstfrag
dos-control icmp
!
interface ethernet 1/g1
gvrp enable
switchport mode general
switchport general allowed vlan add 2-3,999 tagged
switchport general allowed vlan add 1 tagged
exit
!
interface ethernet 1/xg1
switchport mode trunk
switchport trunk allowed vlan add 1-3
exit
!
interface ethernet 1/xg2
switchport mode trunk
switchport trunk allowed vlan add 1-3
exit
snmp-server community public ro ipaddress 192.168.30.12
exit


Switch
--------------------
!Current Configuration:
!System Description "PowerConnect 6224, 3.3.4.1, VxWorks 6.5"
!System Software Version 3.3.4.1
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 2-3
vlan routing 2 1
exit
stack
member 1 1
exit
ip address dhcp
dhcp l2relay
!
interface ethernet 1/g1
dhcp l2relay
switchport access vlan 2
exit
!
interface ethernet 1/xg1
switchport mode trunk
switchport trunk allowed vlan add 1-3
exit
!
interface ethernet 1/xg2
switchport mode trunk
switchport trunk allowed vlan add 1-3
exit
exit
0
 
LVL 18

Assisted Solution

by:Akinsd
Akinsd earned 100 total points
Comment Utility
Post the results of these 2 commands on "C1GW1"

show ip interface brief
show ip route
0
 

Author Comment

by:flagshipcredit
Comment Utility
There isn't a "brief" option on the Powerconnect but here is the ip interface results

C1GW1#show ip interface

Management Interface:

IP Address..................................... 10.52.0.2
Subnet Mask.................................... 255.255.255.0
Default Gateway................................ 10.52.0.254
Burned In MAC Address.......................... D067.E58A.81F9
Network Configuration Protocol Current......... None
Management VLAN ID............................. 666

Routing Interfaces:
                                                    Netdir   Multi
Interface    State  IP Address      IP Mask         Bcast    CastFwd
----------   -----  --------------- --------------- -------- --------
vlan 1       Up     192.168.70.251  255.255.255.0   Disable  Disable
vlan 3       Up     192.168.75.251  255.255.254.0   Disable  Disable
vlan 2       Up     192.168.73.251  255.255.254.0   Disable  Disable
vlan 999     Up     192.168.0.1     255.255.255.248 Disable  Disable

C1GW1#

Show IP Route
-------------------------

C1GW1#show ip route

Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, S - Static
       B - BGP Derived, IA - OSPF Inter Area
       E1 - OSPF External Type 1, E2 - OSPF External Type 2
       N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2

O E2   0.0.0.0/0 [110/10] via 192.168.70.254,   vlan 1
O E2   10.52.0.0/24 [110/20] via 192.168.0.2,   vlan 999
O      23.24.49.48/28 [110/74] via 192.168.70.254,   vlan 1
O E2   172.16.2.0/24 [110/20] via 192.168.0.2,   vlan 999
C      192.168.0.0/29 [0/1] directly connected,   vlan 999
O IA   192.168.30.0/24 [110/192] via 192.168.0.2,   vlan 999
O IA   192.168.40.0/24 [110/192] via 192.168.0.2,   vlan 999
O IA   192.168.50.0/24 [110/192] via 192.168.0.2,   vlan 999
C      192.168.70.0/24 [0/1] directly connected,   vlan 1
C      192.168.72.0/23 [0/1] directly connected,   vlan 2
C      192.168.74.0/23 [0/1] directly connected,   vlan 3
O E2   207.106.4.240/29 [110/20] via 192.168.0.2,   vlan 999

C1GW1#
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 16

Accepted Solution

by:
vivigatt earned 200 total points
Comment Utility
Check this thread:
http://www.experts-exchange.com/Networking/Misc/Q_24975488.html

it seems that you need to enter the following commands on your switches:

bootpdhcprelay enable
bootpdhcprelay serverip DHCP-SERVER-ip-address
0
 

Author Comment

by:flagshipcredit
Comment Utility
on both switches?
0
 
LVL 18

Expert Comment

by:Akinsd
Comment Utility
Good
Looks like the interfaces are up and the vlans show up in the route table

Run the following On both switches

show vlan
show vtp status




.....
I looked up the thread vivgat pointed to and it looks like the person had the same switch and issues as you.

Apply the same solution

All the best
0
 

Author Comment

by:flagshipcredit
Comment Utility
No VTP Option available

C1GW1#show vlan

VLAN       Name                         Ports          Type      Authorization
-----  ---------------                  -------------  -----     -------------
1      Default                          ch1-48,        Default   Required
                                        1/g1-1/xg4
2                                       1/g1,          Static    Required
                                        1/xg1-1/xg2
3                                       1/g1,          Static    Required
                                        1/xg1-1/xg2
666                                                    Static    Required
999                                     1/g1           Static    Required

C1GW1#
0
 

Author Comment

by:flagshipcredit
Comment Utility
The bootpdhcprelay doesn't offer these options anymore.
0
 
LVL 18

Expert Comment

by:Akinsd
Comment Utility
Ok
Didn't know what I was thinking - VTP is a cisco proprietary protocol. The other thread made me realized we're working with a Dell switch - same general switching concepts applies though

Run the show vlan on the 2nd switch.
I want to see if the vlan information reaches it
0
 

Author Comment

by:flagshipcredit
Comment Utility
console#show vlan

VLAN       Name                         Ports          Type      Authorization
-----  ---------------                  -------------  -----     -------------
1      Default                          ch1-48,        Default   Required
                                        1/g1-1/xg4
2                                       1/xg1-1/xg2    Static    Required
3                                       1/xg1-1/xg2    Static    Required
0
 

Author Comment

by:flagshipcredit
Comment Utility
Thank you are your help!

Got it figured out

Just need IP Helper-Address ip address DHCP
Trunk Mode on uplink allowing your VLANs
Also, a convenience setting set your ports to Spanning-Tree PortFast


The issue I found was I was at home and the laptop plugged into the switch kept going to sleep and I didn't know it. The nic stayed on which made me think it was powered up because of the interface status saying UP

Again thanks for the help.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I was supporting a handful of Windows 2008 (non-R2) 2 node clusters with shared quorum disks. Some had SQL 2008 installed and some were just a vendor application that we supported. For the purposes of this article it doesn’t really matter which so w…
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now