Link to home
Start Free TrialLog in
Avatar of Amirsys
Amirsys

asked on

Juniper EX2200-48t-4g to Cisco SF302-08P Trunk and VLAN config

I will start out by saying I'm not strong in this area. I'm working with a Juniper ex2200 and connecting to a Cisco SF302. I'm accessing the Juniper via Junos visual control panel and the OS is 11.4R2.14. The Cisco I'm also accessing it via the visual control panel and Firmware 1.2.7.76.

I'm trying to allows access from the Cisco device on vlans I have setup on the Juniper device (as a note the Juniper is sharing the same vlan information with other Juniper devices and working without problems). I have the port on the Juniper tagged as a trunk, the native vlan is 1, and all of the vlans I want to share are added to the port. On the Cisco I have the GE1 port tagged as a trunk, native vlan is 1 and I have also added the vlan's I want shared added to the Cisco (so not waiting for the vlans to be shared from the Juniper device).

The problem I'm having is that no information is being shared and anything connected to the Cisco device will not receive an IP (via dhcp) or any vlan information. I have tried turning on GRVP (no change), spanning tree is turn off on both sides, but nothing works.

This should be so simple, but yet I am not able to get it to work. Thanks in advance for the time and any help you can give.

As a note, I have already look at the following article with no luck.

https://supportforums.cisco.com/thread/2136719
Avatar of ArneLovius
ArneLovius
Flag of United Kingdom of Great Britain and Northern Ireland image

what other devices are you connecting to the Cisco switch to access the other VLANs ?

have you set the other ports on the Cisco switch as access ports on the VLANS that you want to use ?
Avatar of Amirsys
Amirsys

ASKER

I have computers and POE VOIP phone, yes I have set those ports with the Tagged and also tried Untagging the VLAN but nothing has worked.
an access port needs to be untagged

is VLAN1 also untagged on the Juniper end of the trunk ?

It would be useful if you can post the relevant configs
Avatar of Amirsys

ASKER

If I have VLAN 71 as the voice, when I setup an access port on the cisco for a phone to connect, should that port have the native (default port) and the voice vlan or just the voice?


I will look at the Juniper and vlan 1 and get back to you.
Avatar of Amirsys

ASKER

I have looked on the Juniper and I'm not sure how to set a vlan as tagged or untagged when adding it to a port.
Avatar of Amirsys

ASKER

I've requested that this question be deleted for the following reason:

This question has been up for over a week and no one is providing any information or help. I will be moving on to Juniper directly for help.

Thanks
Dustin Baker
You appear to be asking a secondary question from your original question.
I requested copies of configs on the 6th...
Avatar of Amirsys

ASKER

I have attached the Juniper config side..I only included information about port 24. That is the port the Cisco SF 302 is connected to.

I will get the Ciscso Side in a few minutes.
Juniper-Switch-Config.txt
From the Juniper config

You have VLAN 1 as a native Untagged) and VLAN name "old-voice" which is VLAN 17 as a tagged VLAN, there are no other VLANS on the port.

From the Cisco config, you have no specific onfiguration on port Ge/1 (there is for Ge/2), so it would only have VLAN1 on the port.

With this configuration, VLAN 2 should go between the switches, but there is no L2 path for VLAN 17


if you are actually using Ge/2, then it has VLAN 17, 20 and 90 tagged, I am not sure from the config whether VKAN1 is on the port as a tagged VLAN, or not at all, in any event there is no L2 path for VLAN1, only for VLAN17 as 20 and 90 are not configured on the Juniper.

Which VLANS do you want to have on the Cisco ?

It is usually beter to do a "show run" rather than a "show start", just in case you have made changes and not done "wri mem".
Avatar of Amirsys

ASKER

I need to have VLAN 17, 20, and 90 go from the Juniter on port 24 to the Cisco on GE-2
ASKER CERTIFIED SOLUTION
Avatar of ArneLovius
ArneLovius
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Amirsys

ASKER

Thanks for the info. I was able to get things working but not really sure what did it.

no switchport trunk allowed vlan add 17,20,90
no switchport default-vlan tagged
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,17,20,90

The above commands didn't work but when I tagged the trunk on the cisco side with 1U, 17T, 20T, 90T and then each port that I wanted with 20U and 17U and things are working.

Thanks again
Avatar of Amirsys

ASKER

Stop the deletion
Avatar of Amirsys

ASKER

Things are working, not sure why or how, but they are working