Solved

Linksys/Cisco SRW224G4 Firmware upgrade process unclear

Posted on 2013-01-04
19
2,632 Views
Last Modified: 2013-01-07
I have an SRW224G4 v1.1 switch.
It is running:
Boot ver. 1.0.2 dated: 8/17/2006
SW ver. 1.2.2.b dated: 3/20/2007
HW ver. 00.03.00

I downloaded SW ver. 1.2.3.0 dated 2010 SRWxxxG4_FW_1.2.3.0.ros
It appears that I was able to tftp this file into the device using the serial console interface and an ethernet connection.  That is, the transfer seemed to work.
I used both filename x.ros and, later, SRWxxxG4_FW_1.2.3.0.ros

But the device keeps coming up with the original SW listed above: 1.2.2.b.

I really want to get the new firmware running but suspect that either I don't know how to download it properly or that I don't know how to thereafter instantiate it properly.
I've reset and rebooted the machine to no avail.

The Serial Console and telnet menus under File Management show this:

Source File:  [     ]
Destination File: [   ]
File Name: [   ]
IP address: [   ]

The last two are free form.  The first two only have toggle selections:
startup-config
image
boot
tftp

As I recall, I downloaded the file using
Source File: tftp
and
Destination File: image

So, if one is supposed to "load" the new software after having tftp'd it into the box then this must be the place to do it.  But just about any combination of Source File and Destination file yields that it's a bad combination.

So, I'm stuck.

The real problem with this box is that the GUI interface isn't working and I hope the new firmware would fix that.
I have read that using a user name of the default "admin" will cause the GUI interface to not work.  So, I've changed the user name.  But that didn't help.

So, at this stage, how *IS* one supposed to upgrade the firmware and make it "stick"?
0
Comment
Question by:Fred Marshall
  • 10
  • 9
19 Comments
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
I had (a long time ago) a Netopia Router that needed to be upgraded by TFTP. I used Solar Winds TFTP. It was free and it worked. You do need a TFTP tool as far as I know, so try Solar Winds to start.

.... Thinkpads_User
0
 
LVL 25

Author Comment

by:Fred Marshall
Comment Utility
thinkpads_user:
Yes.  I'm using TFTPD32 from Philippe Joudin.
That's not likely the problem unless my procedure described above is faulty.
The transfer seemed to work just fine.

So, if the file transfer works then why isn't the firmware changed in the end?
Or, is there some next step I've not taken?
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
I looked at a couple of threads and could not get a clear idea.

One reason may be that your Switch is a different hardware version than the new update you are trying to install. That will stop the update. This was true for my Cisco Linksys RV042 Router.

Can you do a hardware reset on the Switch and then use the GUI to work with it?

... Thinkpads_User
0
 
LVL 25

Author Comment

by:Fred Marshall
Comment Utility
Yes.  The RV042 changed hardware versions and the firmware releases are separate for each.
According to the downloads, the new firmware is for the same switch hardware version here.

I can do a software reset to factory defaults but that doesn't help.

It appears there is no reset button on this device.

The manual says to do a reset after downloading the new firmware.  That's it...
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Try a different browser (say Mozilla) if you can. Some firmware (Cisco, Juniper, etc) had issues with IE9.

Short of that and no reset, I cannot see anything else to do.

Is is feasible to contact Cisco Support?  They may have an undocumented way to reset the box or get the GUI working.

.... Thinkpads_User
0
 
LVL 25

Author Comment

by:Fred Marshall
Comment Utility
The one thing that folks may be able to help with:
I found the interface terminology more than a little cryptic.
How should I interpret this:

The Serial Console and telnet menus under File Management show this:

Source File:  [     ]
Destination File: [   ]
File Name: [   ]
IP address: [   ]

The last two are free form.  The first two only have toggle selections:
startup-config
image
boot
tftp

Here is what I imagine:
startup-config: we are referring to a configuration file
image: we are referring to a firmware software file
boot: we are referring to a boot software file
tftp: we are referring to a file that will be obtained or sent via tftp.

Here are combinations I can then imagine for downloading into the box:

Source File:         tftp
Destination File: startup-config | boot | image
File Name:          [name of file on server AND it doesn't matter on the box]
IP address:          [IP address of the server]

Here are combinations I can then imagine for uploading from the box:

Source File:        startup-config | boot | image
Destination File: tftp
File Name:          [name of file that will go to the server]
IP address:          [IP address of the server]

And, there is *no* mechanism here for things like:
Load mirror into boot
Load config into mirror
etc.
(although resetting may do one or the other of these.....)

Do these interpretations make sense to you?
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
I cannot tell because I do not have this switch.

Have you tried downloading the firmware to your computer?  Is it anywhere near the same size as the firmware you are trying to upload?

.. Thinkpads_User
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
@fmarshall

I looked in the manual, and it says this:

After you download a new image file, the device should
be rebooted. If you are downloading a new boot image,
please follow these steps:
1. Download the new boot code. DO NOT RESET THE DEVICE!
2. Download the new software image.
3. Reset the device now.

You said above you downloaded new firmware. Did you get new boot code as well? Apparently you need both.

.... Thinkpads_User
0
 
LVL 25

Author Comment

by:Fred Marshall
Comment Utility
It appears that the boot code is the latest version.
The firmware file size is identical to the nearest kB.
The firmware on the machine is 1.2.2b with a 2007 date.
The firmware I downloaded is 1.2.3 with a 2010 date as I recall.  Anyway, that part is different.  
I'm wondering if it isn't just a documentation error in view of the file sizes.

Yeah, I did read the manual carefully.
Did you agree with my interpretations?
0
Free camera licenses with purchase of My Cloud NAS

Milestone Arcus software is compatible with thousands of industry-leading cameras for added flexibility. Upon installation on your My Cloud NAS, you will receive two (2) camera licenses already enabled in the software. And for a limited time, get additional camera licenses FREE.

 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
I agree as much as I can (given what I know) with your interpretations.

You probably should contact Cisco Support, because there may be a possibility your box does not support the newer firmware. That would cause it not to load.

... Thinkpads_User
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
You could be right about the file size.

I have a Cisco RV220W wireless router. I downloaded firmware dated in June, 2012 with the same version number that I see in the router dated in January, 2012. I applied the firmware and it said it went, but the date did not change. It still says January. The versions were the same in any event.

None of this helps you if you have the correct firmware because you say the GUI does not work.

So you really do need Cisco Support at this point.

.... Thinkpads_User
0
 
LVL 25

Author Comment

by:Fred Marshall
Comment Utility
Do you agree with my interpretations re: how the File Management interface works?
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Your posts look ok to me. So long as the boot code response and the firmware response are in the right spots provided, it should be ok.

What I am not clear about is that you are always to provide boot code and I am not clear above if boot code has been provided.

Other than that clarification, the procedure you followed should install the firmware.
... Thinkpads_User
0
 
LVL 25

Author Comment

by:Fred Marshall
Comment Utility
As I get it, you aren't required to provide boot code.  It's the same as if you are replacing the firmware.

What would you do if you did?
Load the boot code first?
Then load the firmware next?

There must be someone who has done it.
0
 
LVL 90

Accepted Solution

by:
John Hurst earned 500 total points
Comment Utility
The instructions seem clear here:

1. Download the new boot code. DO NOT RESET THE DEVICE!  

This implies to me that you must do step 1 to start the process. Boot code appears to be different than firmware.

2. Download the new software image.

This is the second step  which is to load the firmware.

3. Reset the device now.

I have not done this Switch (but I have put firmware on Cisco, Linksys and Juniper devices). The ones I have done dont use / need boot code. But your Switch seems to.

So the answers to your questions are: 1. described above; 2. Yes; 3. Yes
... Thinkpads_User
0
 
LVL 25

Author Comment

by:Fred Marshall
Comment Utility
Well, that worked after a fashion.
It appears that these Linksys>Cisco switches need boot code.
And, it appears that downloads of boot code are unavailable nowadays.

So, I downloaded the boot code from the switch.
Now I have boot code and firmware.
Then I followed the process you described where the boot code goesin first and the firmware goes in "on top" of it.
Then you reboot / which is the same as "reset".

I now have the newest firmware installed!  Thanks.
Unfortunately it doesn't work any better than the old firmware.
I figure this box is broken.
0
 
LVL 25

Author Closing Comment

by:Fred Marshall
Comment Utility
Thanks thinkpads_user!!
0
 
LVL 25

Author Comment

by:Fred Marshall
Comment Utility
I might mention that the interface I tried to get straight described above was "interesting" in that I'm sure I must have overwritten the firmware file on my computer.

In order to GET files from the box the source is boot or image or ....
and the destination is tftp.

In order to SEND files to the box the source is tftp and the destination is boot or image or...

Switch those around and a SEND becomes a GET.
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
@fmarshall - Thank you for the update. I am glad you got the firmware updated, but that it did not fix the problem is not happy. Good luck getting it fixed. I was certainly pleased to work with you on this. .... Thinkpads_User
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Suggested Solutions

What is IRC? IRC (Internet Relay Chat) is a form of communication between multiple users. It is available freely to anyone with inernet access. IRC is a great way to communicate with others e.g. There is an IRC channel for Ubuntu Linux, which is fo…
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now