Cannot join Domain

I have a test server (SBS 2003) and a single client (Windows 7).  They are both on the same network using a router (D-Link) to get to the internet.  I've made the IP addresses on both static:

Server
192.168.1.2 (IP)
255.255.255.0 (Subnet Mask)
192.168.1.254 (Default Gateway)
192.168.1.2 (Preferred DNS)
24.25.5.61 (Alternate DNS)

Client
192.168.1.10
255.255.255.0 (Subnet Mask)
192.168.1.254 (Default Gateway)
192.168.1.2 (Preferred DNS)
24.25.5.61 (Alternate DNS)

The client is unable to join the domain.  I'm getting an error of:

The following error occurred attempting to join the domain:
Network path was not found

The router configuration is:

Static IP information given to me by ISP
7x.6x.2xx.1xx (IP Address)
255.255.255.248 (Subnet Mask )
7x.6x.2xx.12x (Default Gateway)
2x.2x.x.6x (Preferred DNS)
2x.2x.x.6x (Alternate DNS)

192.168.1.254 (Router IP address)
255.255.255.0 (Subnet Mask)
Enable DNS Relay is checked
Enable DHCP Server is Checked (Range from 100 to 199)

Both computers can get to the internet and I don't understand why they cannot see each other.  Can an expert help me on this?
lordzackAsked:
Who is Participating?
 
PerarduaadastraConnect With a Mentor Commented:
I suggest that you set up the networking and internet connection again on your SBS server, from scratch, using the relevant wizards. Resist the temptation to do anything manually if there is a wizard available to do it.

Make sure that the server's internal FQDN doesn't end in an internet TLD suffix. The default is .local, which isn't a recognised internet TLD and so prevents confusion between internal and external domain names.
0
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Start by removing DHCP from your Router and enabling and using DHCP on SBS 2003. It may already be enabled and then conflicting. You only need one DHCP server and that should be SBS 2003

Also look at this Microsoft article and see if you need the patch.

http://support.microsoft.com/kb/926505

.... Thinkpads_User
0
 
davorinCommented:
And I would also remove alternate DNS server entries from both machines.
SBS server has DNS server which resolves external addresses using DNS root servers (or forwarders).
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
stari_atCommented:
I agree with removing the external DNS from both machines. In your single-domain-controller environment you should use 127.0.0.1 as DNS for your server and configure the public DNS as forwarding IP in the DNS-server configuration on your SBS...

Also try to ping your domains FQDN (eg. mycompany.internal) - you have to get the IP of your server (192.168.1.2).

Next step would be to check the AD services using dcdiag...
0
 
Tony GiangrecoCommented:
I agree with the suggestiuons above, remove the dns, flushdns, verify you can ping back and forth from both boxes then join the domain.
0
 
lordzackAuthor Commented:
I have changed the server DNS to 127.0.0.1, Removed the Alternate DNS on client with the Preferred at 192.168.1.2 (server IP), Flushed DNS on both machines and even rebooted both machines.  The server can now see the client on the WORKGROUP but the Client cannot see the server and also unable to join the domain.  Still getting the error message of "The Network Path Was Not Found".

I'm still stumped. Any other ideas?
0
 
JohnBusiness Consultant (Owner)Commented:
What about using DHCP on the server?  You may have two DHCP servers and need to research this. That may be why you get Network Path Not Found.

... Thinkads_User
0
 
Tony GiangrecoCommented:
Try this:

1. Put a static IP on the server 192.168.1.10
2. Make sure the Pc is on the same switch as the server
3. Make sure the switch is not managed
4. Put a static P on the Pc 92.168.1.20
5. Use dymanic dns on the pc, flush dns, ping the server.
6. Open system properties on the server, verify the domain name you are trying to join.

Post screen shots of everything you can that is mentioned here.
0
 
lordzackAuthor Commented:
TG-TIS - I will do the things you mentioned but I think I have another clue.  I can ping the IP address of the server but when I ping the name of the server it fails.  Could this be my problem?
0
 
JohnBusiness Consultant (Owner)Commented:
That you can ping by IP and not by name says DNS is still not right in the server. Use your Server for all DHCP and DNS and you should get closer to a solution,
... Thinkpads_User
0
 
Neil RussellTechnical Development LeadCommented:
Has anyone mentioned FIREWALLS?

Do you have windows firewall turned on on EITHER server OR PC? DISABLE BOTH
Do you have any AV Software installed that has a built in firewall?  DISABLE on BOTH
0
 
lordzackAuthor Commented:
The IP address that comes up when I ping the server by name is very different from 192.168.1.2  

Also, when I attempt to put in an IP address (192.168.1.20) on the client AND a Dynamic DNS it will not allow it.  I MUST put in at least a preferred DNS.  (unless there is some trick I'm not aware of)
0
 
lordzackAuthor Commented:
No firewalls are up.  Antivirus has been disabled
0
 
PerarduaadastraCommented:
I agree that using the SBS DHCP server is a good way to go, as SBS expects to be providing the network's DHCP. EE has numerous articles featuring the difficulties caused on SBS networks through using a router or other third party DHCP server instead of the server one. Of course, the server itself has to have a static IP address if it's providing network services, and likewise the router.

Another possibility is firewall problems. There are potentially two involved here; the server and the Windows 7 client. Try turning them off temporarily, and then see if you can join the Windows 7 computer to the domain.

The patch referred to by thinkpads_user is essential to get Vista and Windows 7 machines to properly join an SBS 2003 domain. Prequisites and other information are listed at the link he provided, and I know from my own experience that the patch makes the difference between success and failure.
 
Are you using the SBS Connectcomputer method, or trying to join the client manually? If the latter, use the former; if you don't, quite a lot of things don't work a). properly, or b). at all.

I assume from the information that you've already provided that your SBS box is using a single NIC configuration, so that rules out any difficulties between two adapters.
0
 
PerarduaadastraCommented:
If pinging the server by name returns the wrong IP address, that might explain why the network isn't found...

What address is returned? Is it private or public?

This is another reason why using the SBS DHCP server service is a good idea.
0
 
Neil RussellTechnical Development LeadCommented:
No, you can NOT have automatic DNS if a static IP
0
 
lordzackAuthor Commented:
The IP address that returns when pinging the server name looks to be a public address (198.105.251.xx).  There is nothing on my network that would support that number (that I'm aware of).

I do have 2 nics but only use one.  This server does not broadcast anything online.  I have tried the same settings on both but only one nic (Network Connection) works to get the server online (for google).
0
 
JohnBusiness Consultant (Owner)Commented:
Disable one of the NIC's on the server for testing and temporarily forget about the server using the internet. The focus should be on getting the server to be a domain server.

Have you turned OFF DHCP on your router yet?

.... Thinkpads_User
0
 
lordzackAuthor Commented:
Have disabled one of the NIC's and yes the DHCP is turned off on the router.
0
 
JohnBusiness Consultant (Owner)Commented:
Try restarting the Server and then pinging it again. If you restart and then ping returns an external address, something has gone wrong in the server.

Look at this article from Microsoft for re-installing DHCP on SBS 2003

http://technet.microsoft.com/en-us/library/cc775476(v=ws.10).aspx

... Thinkpads_User
0
 
lordzackAuthor Commented:
I am attempting a repair of the OS.  If that doesn't work I will reinstall it and start from scratch.
0
 
Tony GiangrecoCommented:
Any update on the repair? A reinstall is ultimately the best bet!
0
 
hecgomrecCommented:
If a repair of the OS is undergoing or a full reinstall from scratch will be perform please consider the following:

Prior any attempt to connect Clients:

1. Update all your drivers.
2. Update you SBS 2003.
3. Make sure your DHCP Server is running:
     Scope Range should be 192.168.1.60 to 192.168.1.255
     Leave from 1 to 59 for network devices.
4. Make sure your DNS is enabled and running.
5. If you have more than one NIC please make sure both have a cable attached to a swith or router.
6. Assign each NIC an IP or team them up as needed.

On the Client Machine:

1. Make sure the Machine is setup to DHCP (No Static)
2. Make sure the machine is in a WORKGROUP.
3. Make sure the Machine has receive a correct IP inside your Scope.
4. Try to ping your server by Name or/and IP.
5. Joing the machine to the Domain.


Good Luck
0
 
lordzackAuthor Commented:
After a laborious repair, I attached both NIC's to the switch,

IP (Network Connection) 192.168.1.10
Sub. Mask                        255.255.255.0
Def. Gateway                   192.168.1.254
Preferred DNS                 127.0.0.1

IP (Server Local Area Connection)  192.168.1.1
Sub. Mask                                        255.255.255.0
Def. Gateway                                  192.168.1.254
Preferred DNS                                192.168.1.1

After doing all that, my client was immediately able to join the Domain (client is set to obtain IP automatically but Preferred DNS is set to 192.168.1.10).  However, it still cannot see the shared files.  I obviously have a wrong setting but (in my ignorance) the setting is not obvious to me.  Any suggestions?
0
 
JohnBusiness Consultant (Owner)Commented:
Try mapping a shared folder as follows:

NET USE Z: \\IPaddressofServer\FolderShare.    

If that works, it is a DNS issue, and if not, it is a different issue.

..... Thinkpads_User
0
 
lordzackAuthor Commented:
Must be a different issue.  The Command Prompt flashed and no drive was mapped.
0
 
JohnBusiness Consultant (Owner)Commented:
If it will not map by IP address, then it is a different issue.

Open a command prompt (instead to typing into the Run command). This will open a command prompt which will stay open.

Now:  NET USE Z: \\IPaddressofServer\FolderShare   (again).

What error do you get?

.... Thinkpads_User
0
 
lordzackAuthor Commented:
System Error 67 has occurred

The network name cannot be found
0
 
JohnBusiness Consultant (Owner)Commented:
Here is a Microsoft Support article for that error.

http://support.microsoft.com/kb/843156

Remember you need a patch (see much earlier here) installed on the SBS 2003 Server for Windows 7 clients to properly join a domain.

.... Thinkpads_User
0
 
hecgomrecCommented:
Does your user have rights to connect to the shared folders?

Double check and give full access for this test.
0
 
lordzackAuthor Commented:
Yes, my user has been appointed Administrator access.  I am updating the Service Packs now.
0
 
hecgomrecCommented:
Yes, your user seems to have Admin rights for login but does he has full rights in the shared folder.

You can leave and administrator out of a share if desired.

Also, check the permissions on the share you created, you should have Everyone with change and read permissions and in Security you should have the administrator with Full Control.

Good Luck!
0
 
hecgomrecCommented:
Sorry I forgot, In Win7 you won't be able to see your Network computers under the Network section on your "Computer".

To do so you will have to go to your windows firewall, allow a program or feature through
Windows Firewall, change settings and select File and Printer Sharing under Domain and Network Discovery under Domain.

Now you should see your Network section getting populated.
0
 
lordzackAuthor Commented:
The Firewalls are off.  I have even specifically put the user in NTFS permissions as Full Control.  Perhaps after I finish the Service Packs it will work.
0
 
lordzackAuthor Commented:
Your suggestions were very helpful in educating me on how to determine problems on my network.  Thank you all.  I will I could award more points.  I ended up doing a complete fresh reinstall and taking everything as default (with the exception of the IP address of the server) and everything fell into place rather quickly.
0
 
JohnBusiness Consultant (Owner)Commented:
I ended up doing a complete fresh reinstall and ...everything fell into place...

Thank you. I am pleased to know you got it working.  I know a complete re-install is always inconvenient, but it worked.

.... Thinkpads_User
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.