Solved

how to open port 3389 on DIR-655

Posted on 2013-01-05
10
889 Views
Last Modified: 2013-01-06
I try to RD my server from outside of my office by using DDNS service. The router that i use is Dlink DIR-655 model, i have already set port forwarding that is port 3389 to my IP server but when i checked the port at www.canyouseeme.org the result shown that; it could see the service on IP on port(3389). So how should i set up the router to make the web checking see the port?
                                                                              Thank you in advance for the answering
0
Comment
Question by:krissanon
  • 3
  • 2
  • 2
  • +3
10 Comments
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 38747233
0
 
LVL 30

Expert Comment

by:ded9
ID: 38747237
Follow the steps mentioned in this link
Just replace it your port number and application.

http://www.cctvcamerapros.com/D-Link-Port-Forwarding-s/286.htm






Ded9
0
 
LVL 17

Expert Comment

by:lruiz52
ID: 38747278
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38747461
It sounds like you already have it setup correctly.
i.e. that site *should* say
Success: I can see your service on
your.ip.addr.ess on port (3389)
Your ISP is not blocking port 3389

If you mean how do you make it work, from the remote site when prompted for the machine you want to connect to in Remote Desktop, you enter
yourcustom.DDNS.domain
as the remote computer then click Connect...

To enable Remote Desktop inbound, click the 'start' orb, type in sysdm.cpl and click the one that appears at the top, under Programs (1).
Go to the Remote tab
Pro, Enterprise and Ultimate will look like Win7 Pro - Enable Remote Access InboundHome Premium, Home Basic and Starter versions will look like Win7 Home - Enable Remote Access InboundXP Pro looks like XP Pro - Enable Remote Access Inbound (Start->Run, sysdm.cpl [Enter]) - sorry, I don't have a copy of XP Home to get a screen shot.

When making those settings above with Windows Firewall enabled, it should automatically open TCP port 3389 in the firewall for you.e.g.Win7 - Firewall - Allow Remote Desktopor, in XP XP - Firewall - Remote Desktop
If Windows Firewall was disabled at the time it WON'T automatically make the opening... in that case, enable the firewall, disable remote access on the Remote tab, Apply/OK, then re-enable remote access on the Remote tab and it should make that opening on port 3389 for you in Windows Firewall.

If using a 3rd party firewall, consult its documentation for opening TCP 3389 inbound.

Note that you should be able to make a Remote Desktop Connection to any version of Windows like that, but to initiate a Remote Desktop Connection you must be on a Professional or higher (e.g. Enterprise or Ultimate) version of windows.

edit: Hmmmm - I always thought that last statement was true, but I was just able to make a connection *from* Win7 Home Premium to a remote XP Pro machine, and I don't remember doing anything special to enable that.
0
 
LVL 10

Accepted Solution

by:
cpmcomputers earned 500 total points
ID: 38748322
As an aside I would suggest you change the listening port from the standard 3389 to something non-standard  

Using the standard port you are at risk of concerted dictionary attacks

There is a Microsoft fixit to do this just google change listening port for relevant articles
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 

Author Comment

by:krissanon
ID: 38748495
Thank you for all of the answering but i still can't remote to the server by the DDNS name but i can remote it by IP Address, if i'm in the LAN Network.

The think that i have done from the previous comment is:
Fig.1.png
Fig.2.png
Fig.3.png
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 38748503
I think you should have distrubutd the point we all helped here
0
 
LVL 10

Expert Comment

by:cpmcomputers
ID: 38748561
Looking at the screenshots - I think you also need to enable the RDP port in the "firewall section settings of your router" -That is probably why it works on internal Ip but not externally?

ie. The port forwarding rule marks where to pass the traffic but the firewall is not allowing the inbound traffic on that port to be passed ?
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38748788
In fig2.png, you're forwarding TCP 3389 on the outside to UDP 3389 on the inside (should be TCP 3389 on the inside, too).

Since your router's port forwarding allows specifying different outside and inside ports (not all do), you don't *need* to change the port RDP listens on in the registry... just change the outside port on the router, to, say, TCP 33344, and the inside port to TCP 3389... then when you tell Remote Desktop where to connect, use

yourcustom.DDNS.domain:33344
and click Connect.
The router should then forward that to 192.168.0.44 TCP port 3389 on the inside.
Then you could forward a different outside port to a different inside IP address on port 3389.

The registry change to make RDP listen on a different port is to allow multiple windows computers to be accessed remotely on the routers that DON'T allow specifying different outside and inside ports in their Port Forwarding setups, not to make Remote Desktop more secure.
You make Remote Desktop secure by employing 7+character complex passwords that use mixed-case letters, numbers and symbols (like !@#$% et al). If you use a 10-character complex password, composed of the 94 characters allowed in passwords by windows, a hacker trying 5,000,000 combinations per second would take over 3 trillion millennia to go through every combination.
0
 
LVL 10

Expert Comment

by:cpmcomputers
ID: 38748921
Fully agree with the above
I was Just keeping it simple by changing the port on the server rather than port mapping on the router (you will note I did not have the benefit of the screenshots in my original post)

But as I have pointed out this still  needs the firewall to pass the packets however the forwarding is set up

(Your stats  assume the hacker does not get lucky first time or use social engineering to trick the user into revealing even the most complex password,etc)

Personally I use 8+ digit passwords with complex symbols and alpha numerics
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Remove Installed Application 1 43
How do I hook up a bluetooth speaker? 20 92
EaseUS Todo back-up doing multiple versions? 8 36
Data is not showing from images 15 37
Article by: Lee
Windows 7 Ultimate and Enterprise (and 2008 R2) introduced a new feature you may not be aware of - Boot from VHD.   Boot from VHD (or what Microsoft refers to asNative Boot allows you to install Windows to a VHD (Virtual Hard Disk) file that is t…
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
This Micro Tutorial will go in depth within Systems and Security in Windows 7 and will go into detail regarding Action Center, Windows Firewall, System, etc. This will be demonstrated using Windows 7 operating system.
This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now