Taking control of Exchange 2010 Public Folders

Need a step by step solution.
I moved from a 2003 Exchange Server and I used Exmerge to export all boxes out to include public folders. I then imported at the client level. I then mounted the public.pst from my outlook account (Full Admin + Exchange Servers) and copied one by one into the new public folders. I have done this many of times in the past on 2003 exchange. But now I can not right click any of the folders and see "permissions" tab. There is one folder that I have full control of and I have no clue how or why. I was reading on how to take ownership thru powershell, but for some reason - I am just not getting it. I can not delete them either.
So Again I need a Step by Step.

Thanks,
Lowell SwitzerCTO / Systems EngineerAsked:
Who is Participating?
 
SubsunCommented:
If you have exchange admin permission the you don't have to add owner permission to view permission tab.  "Permissions" Tab for Public Folder Management Console introduced with Exchange 2010 SP1.

So If you are running with Exchange 2010 SP1 or above then the in Public Folder Management Console.. Right click on a public folder and select properties and use "Permissions" Tab to manage client permissions.

You can also use “Manage Public Folder” wizard to perform bulk modifications..
Ref : http://www.msexchange.org/blogs/walther/news/manage-public-folders-using-the-new-manage-settings-wizard-in-exchange-2010-sp1-511.html

From EMS use Add-PublicFolderClientPermission as mentioned by Rancy or use AddUsersToPFRecursive.ps1 script. Refer the article for more details..
Ref : http://technet.microsoft.com/en-us/library/aa998834%28v=exchg.141%29.aspx
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Get-PublicFolder "\" -Recurse | Add-PublicFolderClientPermission -AccessRights Owner -User Domain\UserName

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_25361082.html

http://www.howexchangeworks.com/2010/06/public-folder-permissions-added-to.html

- Rancy
0
 
Lowell SwitzerCTO / Systems EngineerAuthor Commented:
This is what I am doing:

1: Open Powershell

Copy paste

PS C:\Users\Administrator> Get-PublicFolder "\pool" -Recurse | Add-PublicFolderClientPermission -AccessRights Owner -User ABC.com\Lowell

This is what I get:

The term 'Get-PublicFolder' is not recognized as the name of a cmdlet, function, script file, or operable program. Chec
k the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:17
0
 
SubsunCommented:
You need to use Exchange management Shell to run the commands..
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Can you please tell me what is the version of Exchange ?

Get-PublicFolder (This is surely a E2k10 command)
http://technet.microsoft.com/en-us/library/aa997615%28v=exchg.141%29.aspx

- Rancy
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.