• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3279
  • Last Modified:

Windows 2012 Terminal Server not accepting keyboard input

We have recently installed a Windows 2012 server with RDS (remote desktop services). All works fine using "Remote Desktop" from Win7. No problems.

Our thin-clients however, which work fine in Windows 2008R2, do not accept any keyboard and mouse input when logged into Windows 2012 RDS.
So, I can not login in the login screen, neither can they when I configure the thinclient to auto login (so when user is logged in, it also does not work).

Anything I need to do in Win2012 to allow extra keyboard permissions?

Thanks
Leslie
0
redworks
Asked:
redworks
  • 2
1 Solution
 
SvenIACommented:
0
 
redworksAuthor Commented:
Thank you for your input.
This file is for Win7 and/or Win2008R2, while my RDS is Windows 2012 (it WORKS on Win2008R2!) and the thin-client is not Win7 but a thinclient with some linux bootloader.
0
 
compdigit44Commented:
What type of thin clieny are you using? It's possible the version of RDP running on the thin client needs to be updated in order to work the Windows 2012 RDS.

http://blogs.msdn.com/b/rds/archive/2012/10/09/remote-desktop-protocol-8-0-update-for-windows-7-sp1-enabling-a-great-wan-user-experience-for-windows-7-sp1-virtual-desktops.aspx
0
 
redworksAuthor Commented:
This turned out to be it. Thinclient needs updated software.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now