Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Remote Administration High CPU

Posted on 2013-01-07
3
Medium Priority
?
1,343 Views
Last Modified: 2013-01-11
After installing the Remote Desktop Session Host role on a Windows Server 2008 R2 server, and applying the latest patches, whenever I remote into it with Remote Desktop Connection from my Windows 7 PC, the server jumps to 100% utilization with svchost.exe in control. (same thing happens when the user remotes into their application) I've searched for such issues and from MS website I saw hotfix 2750090 but the fix, applied to both the workstation and server, failed to resolve my issue (restarts were done on both ends and the patch was successfully installed).  There are no errors logged in the event viewer.  Best practices analyzer done on the server comes up clean.  Does anyone have any suggestions on how to resolve this (other than contacting Microsoft)?  (wish I knew more about RDS)
0
Comment
Question by:ejefferson213
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 16

Accepted Solution

by:
Michael Ortega earned 1500 total points
ID: 38750880
Have you tried to remove the session host role and test regular administrative RDP access? High CPU even without the role?

If not, try to reinstall the session host role just to determine there is a direct correlation between the high CPU and the role itself.

MO
0
 

Author Comment

by:ejefferson213
ID: 38764163
Thank you and good suggestions.  Because of the critical nature of this, Microsoft was called in to help.  If resolved in a reasonable time, I'll post the results that corrected this.
0
 

Author Closing Comment

by:ejefferson213
ID: 38768019
Thank you again for your suggestion.  Microsoft provided me with this solution:  http://blogs.technet.com/b/askperf/archive/2012/03/06/performance-issues-due-to-inactive-terminal-server-ports.aspx   which fixed my problem.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I was supporting a handful of Windows 2008 (non-R2) 2 node clusters with shared quorum disks. Some had SQL 2008 installed and some were just a vendor application that we supported. For the purposes of this article it doesn’t really matter which so w…
I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question