Solved

HELP!!! Web Server IIS 6.0 on Windows 2003 R2

Posted on 2013-01-07
11
627 Views
Last Modified: 2013-02-18
I am need of serious help!!!

I am not new to this I have worked with IIS 6.0 and IIS 7.0 many times. But I am completely stumped on this issue.

I believe has to be DNS?

I have 2 servers both Windows 2003 R2 behind ISA 2006 (which I have used many times) firewall.

I use Zone Edit for my external DNS hosting.  The records have been online for months so there updated.  

Firewall seems to be setup correctly?  

I tried taking one of the servers and hooking directly to the Comcast router and assigned it the appropriate IP address that is setup in zonedit.com.  Still get under construction.

Was trying to run out the firewall...  Server 1 has been reloaded and is setup from scratch with DNS, IIS etc... I setup the DNS "A" records, made sure the DNS forwarders were point at comcast DNS and also the firewall...  Setup a temp page for the web site which I have done many times..

If one server was doing I would think was the server but BOTH servers will not render and web page just says under construction...

The site on Server 1 is  www.computerteks.net and on Server 2 its Yourwebcloud.net

If both servers our doing it... It has to be a DNS issue which seems to be setup correctly???

I by passed the firewall and it still wouldn't render a web page... When I changed the IP and hooked to comcast router on server 1 - Server 2 yourwebcloud.net came up....

The web pages wont even come up on the server itself on both...

Like I said I am not new to this but I have tried everything I can think of... I please need help...
0
Comment
Question by:Clint Jones
  • 7
  • 4
11 Comments
 
LVL 33

Accepted Solution

by:
paulmacd earned 500 total points
ID: 38751486
Since the pages won't come up while browsing on the web server itself, it seems likely it's not a DNS issue.  

Are you sure the web site files are in place?  
Are you sure the web service (IUSR_whatever) has permissions to them?
Can you browse to a page other than the index page?  Maybe the index page(s) is/are missing.
Is it possible another server or service is using the IP address you're trying to access?
0
 

Author Comment

by:Clint Jones
ID: 38751745
Are you sure the web site files are in place?  
--Yes the path is correct and the document page is named correctly

Are you sure the web service (IUSR_whatever) has permissions to them?
--Yes and the service is running...

Can you browse to a page other than the index page?  Maybe the index page(s) is/are missing.
--no can not access any pages..

Is it possible another server or service is using the IP address you're trying to access?
--No that IP has always been assigned only to that server..

But its both servers.. The odds that both r not working... when I changed one of the server with external IP's I could access the 2nd server web page...

Its got to be something else????  What I hope to find out...
0
 

Author Comment

by:Clint Jones
ID: 38751929
Whats weird is exchange is on the server and the web based OWA works with Ip address... XXX.XXX.XXX.XXX/exchange
0
 
LVL 33

Expert Comment

by:paulmacd
ID: 38751938
I can get the placeholder page to come up at http://77.94.248.101/.  I get nothing at http://77.94.248.98.

Are you sure both sites point to the folders that contain their pages?  Have these sites ever worked under IIS7?  I'm guessing computerteks.net was set up first, which is why it shows the default placeholder.  Yourwebcloud.net was probably set up later.
0
 

Author Comment

by:Clint Jones
ID: 38752048
Both domains are on different servers but running Windows 2003 R2... Yes for sure the path on the site in IIS is correct and default page is right in document tab of that site...  the IP is actually 74.94.248.101...  I dont this its the firewall since I connected the server directly to comcast router with 74.94.248.101 IP of course changed the IP on the NIC, changed the DNS of the site and changed the IP in IIS to the external one for the moment... still no go from pagetest.com but it should on the server itself???  Unless i dont have the correct localhost setup but I am using setting... IP wise  and DNS...

Firewall as the default gateway.
Using the Firewall as DNS as well as the 2 comcast dns IP.
I been going over the path....

1) Zoneedit - DNS host
2) Directed at the firewall with rule to to allow port 80 to server.
3) DNS records setup in DNS on the server.
4) Domain setup in IIS...  Make sure path, correct IP assigned which is just one and XXXX.htm default document... All files show up in IIS when you click on the site...

But again, Its funny that OWA web exchange works...  local IP Address/Exchange but computerteks.net no????

and I setup another domain just to see if there is an issue with computerteks.net --  I used shareteamcloud.com on same server different default files still get the under construction page...

I have setup servers, IIS,times DNS etc many in the past and it worked I dont know what I am doing wrong but must be something???
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 33

Expert Comment

by:paulmacd
ID: 38752205
http://77.94.248.101/ shows me a default placeholder page, so an IIS7 server somewhere is serving up pages.  That means either 77.94.248.101 doesn't point to the right server or the right server is configured to serve up the wrong page(s).  

The IP address would work when the domain name did not if there were a DNS issue.  Having said that, there are at least two different problems going on here and you need to tackle them one at a time.  I'd start with getting the web servers to serve up the web sites properly.  And I'd start by triple-checking that the NICs, web server, web site, web pages, etc, etc, are all configured properly.  Make sure firewalls, anti-virus, etc are not an issue either.
0
 

Author Comment

by:Clint Jones
ID: 38752378
I do have another server running windows 2008 IIS7... I going to check everything again... I went ahead and hook the one server that has no data on it for hacking purposes to directly server of the Comcast router so it should be Zoneedit, Comcast to server...
0
 

Author Comment

by:Clint Jones
ID: 38752455
When I took the server 2008 down and had the server hooked directly to the router... It severed up the pages...  Also I had did the direct the router thing earlier with no go still but after the 2008 server was taken down then it came so I went back and it back up by hide the firewall but all correct internal IP back and restart IIS etc just in case and now back where I started.. This network is not that complex... Issues I am having is nuts... No going back over everything with a fine tooth comb....
0
 

Author Comment

by:Clint Jones
ID: 38753035
nothings working???
0
 

Author Comment

by:Clint Jones
ID: 38753079
no???  seriously... im not super expert but know how DNS, IIS works but not expressing myself just figuring out the issue...  Worked for moment till I changed back behind the FW... even though done before we talk last...  Host headers fine - simply direction is perfect
0
 
LVL 33

Expert Comment

by:paulmacd
ID: 38754674
If it works when you take the firewall out of the picture, then fails again when the firewall is put back in place, it seems likely the problem is in the firewall.  Does the firewall also NAT?
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

BIND is the most widely used Name Server. A Name Server is the one that translates a site name to it's IP address. There is a new bug in BIND (https://kb.isc.org/article/AA-01272), affecting all versions of BIND 9 from BIND 9.1.0 (inclusive) thro…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now