• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 206
  • Last Modified:

Disconnecting a Mapping on a virtual machine after the session ends.

I have a virtual machine called Virtual1 in Domain1, configured as Windows 7 64 bit. This is a shared virtual machine, and all my users connect to it with the same ID and Password.
 It’s configured to allow only one connection at a time. So only one user users that virtual machine at any given time.

I needed to have a shortcut setup in that VM, Virtual1 ,that points to a folder in Server2 (this server run windows 2008 R2). This server has a different domain with its own AD.
I have created the shortcut.

The question is: How do I manage to leave the shortcut at the desktop of Virtual1, and ALWAYS ask for credentials when double-clicked?
By ALWAYS, I mean that if the user closes the remote connection (without logging off) I don’t want the next user who logs onto the shared Virtual1 to INHERIT the credential that the previous user utilized.
Is there something like a timing trigger I can turn on at GP level?

PS.I recreated the ID’s from Domain1 onto the AD in Server2 already. And my users know they need to enter that ID and password when trying to doubleclick on the shortcut.
0
cgsolutions
Asked:
cgsolutions
  • 3
1 Solution
 
George KhairallahCTOCommented:
How are your users connecting to that machine? RDP? VDI? or actually using a console ? (i.e: the vSphere Client) ?
If it's either of the former two, you can setup timeouts for the session to log off automatically, upon log off, you can also opt to run a log off script, both of which are in GPO:
http://www.onlinehowto.net/remote-desktop-auto-disconnect-and-auto-logoff-idle-sessions/1428 

Does that help?
0
 
BlueComputeCommented:
The easiest way would simply be to automatically log off disconnected sessions - you could make it time-based (a scheduled task running "net use \\Server2\Share /delete" would do it) that would be irritating for the users I imagine.
You can control the timeout for disconnected sessions using Group Policy - Computer Config->Admin Templates->Windows Components->Terminal Services->Terminal Server->Session Time Limits
0
 
George KhairallahCTOCommented:
Another option I just thought of, and I'm not 100% whether this would work, but if this is the only authenticated share, and you stated that it's in a different domain... you can possibly run a klist purge command, and that may actually trigger the user to have to authenticate again.

Of course you'd have to add that to run on a regular interval, but I supposed this could become pretty annoying to the user if that command runs before the session is actually done working. So I still think the original recommendation may still be better.
0
 
cgsolutionsAuthor Commented:
UPDATE:
The VMs connect RDP
The VMs  are managed/hosted in HyperV, running in the Win2008r2 server
0
 
George KhairallahCTOCommented:
Here's another link that'll help with what you want to do, now that we know that you're using RDP :)
http://technet.microsoft.com/en-us/library/cc754272
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now