• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1389
  • Last Modified:

Junos 11.5 OS

HI All,

See this entry in Junos 11.5

routing-options {
    static {
        route next-hop [ ];

I'm trying to remove the but am having a tough time finding the solution.  Should be quick and easy right?

I tried the replace command but it didn't work so smooth it actually got me zero. I have no Juniper training so I have to admit, it's quite different, somewhat of a headache if you have no training.


  • 2
  • 2
2 Solutions
Phyo HTET AUNGNetwork Security AnalystCommented:
Go to Routing Options
#edit routing-options
#delete static route route next-hop

You should used Qualified Next Hops
here is link

Hope this help
rotarypwrAuthor Commented:

Thanks for your response, when attempting to perform the above I get the following:
root@switchname# commit
[edit vlans localnet l3-interface]
  'l3-interface vlan.1'
    Interface must already be defined under [edit interfaces]
error: commit failed: (statements constraint check failed)

or I get:

{master:0}[edit routing-options]
root@switchname-1# ....0.0 next-hop                  
warning: element not found

Thanks, like I said, I know zero about Juniper and it's a bit of a head scratcher!
Phyo HTET AUNGNetwork Security AnalystCommented:
How about trying below config, i have tested in mx series.

user@switch# delete routing–options static route next-hop
user@switch# commit

In the configuration mode, you can always use "?" to check your options.

If above post isn't working. Please try below if you only have console access to Ex series.
Console to EX series,

dser@switch# delete routing-options static route
dser@switch# commit
 that will delete both of and, then add back

user@switch# set routing–options static route next-hop
user@switch# commit

P.S : don't forget to commit

Hope this help,
rotarypwrAuthor Commented:
Hi and thanks for your help very much.  

The person I am working with that know Junos said to perform the same functions as were suggested earlier, but maybe I am / was doing something incorrectly?  

Long story short, I cheated and did the following since I am constrained by time:  

request system zeroize [clears everything from flash, factory reset pretty much ]
then connect console,
config mode
load replace terminal

Then I just copied my config over and ran the commit command.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now