Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

DHCP on Server 2011 Essentials not working

Posted on 2013-01-07
10
Medium Priority
?
574 Views
Last Modified: 2013-03-15
I am assisting someone who has a new installation of Windows Server 2011 Essentials.  He installed and configured the DHCP role but it is not working.  What I have observed is that if you run ipconfig /release && ipconfig /renew on a workstation (we have tried several different computers) it comes up with a 169. address.

I looked at the DHCP configuration on the server and all appears well.  It is active, it has a valid scope (I deleted the scope and recreated it as 192.168.3.50 to 192.168.3.99; server IP is 192.168.3.2), and I have restarted the service.  It is set to listen on all interfaces (there are two net cards, one is disabled).  I didn't see any restrictions (by MAC address, for example) on the DHCP server.  The only other potential DHCP server on the network is the router, but we have DHCP disabled there.

If you set a workstation up with a 192.168.3.x static IP address, it can ping and otherwise access the server properly.

The server has IPv6 set up to retrieve the address from a DHCP server, but IPv6 is not configured in DHCP so no IPv6 address is received.  I mention this for thoroughness, but presume that it should not be an issue.

I have set up DHCP numerous times on Windows servers without serious issue.  It seems pretty straightforward and logical.

Our workaround is to disable DHCP on the Windows Server and enable it on the router instead.  This is not the approach we'd like to use.

What should I be looking at to fix this?
0
Comment
Question by:CompProbSolv
  • 6
  • 3
10 Comments
 
LVL 23

Expert Comment

by:Suliman Abu Kharroub
ID: 38752871
Had you authorized the DHCP server on domain ?

right click on the server name node and click authorize server
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 38753560
I will doublecheck the authorization, but I believe that I confirmed that.

Another note that I should have added is that it did give out some addresses earlier.  There were about 8 addresses for RDP and a local laptop was given an address.  There are plenty left, though.
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 38760109
The DHCP server was authorized.

The real issue is access to the server, not just DHCP.  That was just one symptom.

It appears that the problem only occurs when RRAS is running.  I removed NPS and I thought that the issue was resolved, but it was not.

If RRAS is running, we are unable to ping the server.  If we stop RRAS, the server pings properly.  That is, if I run ping -t 192.168.3.2  (the server address) it gets replies when RRAS is stopped, does not get replies when it is running, and the replies return when RRAS is stopped again.

What should I be looking at in RRAS?  I uninstalled and reinstalled the role with minimal configuration.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 22

Author Comment

by:CompProbSolv
ID: 38760136
Interesting....  I un-checked Enable IP router manager in RRAS, IPv4, General.  According to Help, it "Specifies whether TCP/IP is enabled on this interface".  But.... VPNs are still working.  I would have guessed that this would stop TCP/IP traffic on the IPv4 interface.

Any insights?
0
 
LVL 23

Expert Comment

by:Suliman Abu Kharroub
ID: 38760155
Do you use RRAS only from VPN access or to use the server as a router ?
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 38760200
There is a single active network card (192.168.3.2) in the server (I believe that is all that SBS 2011 allows).  Whether static or DHCP, workstations have 192.168.3.2 as DNS and 192.168.3.1 (router) as Default Gateway.

Workstations connect with normal (non-VPN) connections when local.

To answer your question, unless I am mistaken, we only use RRAS when remotely connected through the VPN and the server is not used as a router.  I provided the details above in case I am mistaken.

It appears that all is well when the IP Router is disconnected.  My two concerns are that I don't understand this, especially based on what Help said (I should get better educated on this and then it might make sense), and that I am concerned that there may be unknown issues lingering.

For now, unless I get other advice here, we will see how this runs.
0
 
LVL 23

Accepted Solution

by:
Suliman Abu Kharroub earned 1000 total points
ID: 38760328
RRAS can be configured as a VPN server, router or both.

In your case I think it is configured as both... thats why I asked my question.

Now check if the firewall block DHCP traffic, try to disable windows firewall on SBS server and check .... if it works, create a rule to enable DHCP ports.
0
 
LVL 74

Assisted Solution

by:Jeffrey Kane - TechSoEasy
Jeffrey Kane - TechSoEasy earned 1000 total points
ID: 38769798
DHCP on an SBS 2011 Essentials can be a bit tricky as it is not designed to run that role.  However if you do choose to have this server run DHCP you need to follow the official blog article's instructions:
http://blogs.technet.com/b/sbs/archive/2011/09/22/running-dhcp-server-on-sbs-2011-essentials-with-a-static-ip.aspx

Especially the last part about stopping the Windows Server LAN Configuration service.

Jeff
TechSoEasy
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 38824848
Sorry for the extreme delay in responding.

I especially appreciate the link about SBS 2011.  I really do prefer DHCP and DNS on the server and a static IP address on the server.  Actually, I tend to do reservations for all of the workstations so that they have "quasi-static" IP addresses.

The Windows Server LAN Configuration service information was very instructive.  I'll make sure that it is disabled..
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 38989974
The client decided not to troubleshoot it further.  He just disabled RRAS and will move on with that.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The problem of the system drive in SBS 2003 getting full continues to be an issue, even though SBS 2008 and SBS 2011 are both in the market place.  There are several solutions to this, including adding additional drive space or using third party uti…
I've often see, or have been asked, the question about the difference between the Exchange 2010 SP1 version, available as part of Small Business Server (SBS) 2011, and the “normal” Exchange 2010 SP1 Standard. The answer to the question is relativ…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question