Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 255
  • Last Modified:

Authentication on Local Intranet issue

I've recently moved a local Intranet site from one server running IIS6 to another running IIS7.  Everything seems fine apart from on accessing the site I get challenged to "Connect to the localserver.localdomain.com.

On entering the local Admin and password I get full access, however the only username and password that does work is the local admin.  What I can't work out is what access I'm being challenged for.  I have made myself a member of the local admin group without any success, I have changed the permissions on the files so I have local admin rights on them without any success.

Any help would be great.  Picture attached.Authentication challenge
0
edwalters
Asked:
edwalters
  • 3
  • 3
2 Solutions
 
9l1vesCommented:
From the looks of it you have either basic or Integrated authentication running. Basic would be my guess.

To turn it to no authentication (Assuming you want this?):
Open IIS manager
Expand Sites
Select your Site
Double Click Authentication
Right click Anonymous and Select Enabled


If you dont want anonymous access then enable the access you want:
http://www.iis.net/learn/manage/configuring-security/understanding-iis-url-authorization#UsingDomain
0
 
edwaltersAuthor Commented:
I have Windows authentication and anonymous authentication enabled, if I disable the Windows authentication that pretty much stops everything and I get the

"401 - Unauthorized: Access is denied due to invalid credentials."

I have looked through the config file and can't find anything obvious in there.
0
 
9l1vesCommented:
if you right click and edit anonymous authentication what does it give you in there?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
edwaltersAuthor Commented:
The choice between

Specific User
Application Pool Identity

at the moment it is set to Application Pool Identity but it was originally Specific User.
0
 
9l1vesCommented:
That should be set to Specific user, Should be IUSR i believe.
Also make sure that the following accounts have  read permission to the folder :
Network Service
IUSR_(machine name)
IIS_WPG
IIS_IUSRS
0
 
edwaltersAuthor Commented:
I have all those permissions on the directory and this morning I did a Robocopy across from the working server so the permissions should be the same, but I get the same error.

As long as I enter the local admin username and password it works, it's frustration to say the least.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now