Solved

Help with Isolated FTP Access on Server 2008 R2

Posted on 2013-01-08
7
565 Views
Last Modified: 2013-01-08
Hi All,

Really need some urgent help with a problem please.

I've set up a virtual 2008 R2 Server for use by a number of different external clients to transfer files to my main client.  This is a system I've set up successfully twice before on a real server and recently on another virtual server so I thought I knew what I was doing.

My problem is I've set up the FTP Site in IIS and set up an FTP Folder on the local Disk C: in which I have created 16 individual folders named FTPUser01 - FTPUser16. The physical path to the folders is as follows: C:\FTP\DomainName\ and in there are the folders FTPUser01 e.t.c.

I've shared each FTPUser sub folder on the network and made sure I can open the share using the UNC name.  The share name is \\SERVERNAME\FTP\DOMAINNAME\FTPuser01 e.t.c.

I've created AD users named FTPUser01 - FTPUser16 and gone into the Attribute Editor in each user and set the msIIS-FTPDir to the appropriate subfolder name i.e. FTPUser01 and the msIIS-FTPRoot to \\SERVERNAME\FTP\DOMAINNAME

I've logged on to the FTP site from another computer and for testing purposes have entered username FTPuser01 and the appropriate password but each time I end up looking at the root folder (C:\FTP\DOMAINNAME) rather than the sub folder of C:\FTP\DOMAINNAME\FTPUser01 which is what I needed to happen.  

Can anyone please tell me where I may have gone wrong as it's driving me mad and it's urgent I get it working properly so that each username logs on to their own subfolder.

Many thanks

Adam
0
Comment
Question by:amlydiate
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 14

Expert Comment

by:BlueCompute
ID: 38755197
Have you actually enabled FTP User Isolation in IIS? The setting's described here:
http://www.orcsweb.com/blog/terri/how-to-set-up-ftp-access-for-multiple-users-with-user-isolation/
This will allow you to disable the global default ftp folder, and isolate the users to folders called <username>.
0
 

Author Comment

by:amlydiate
ID: 38755305
Ah thanks, that's a new one on me and have never had to select it in the past, however I've gone into IIS and selected Isolate Users - Restrict users to the following directory (username directory) as per the link in your post. Now unfortunately when I try to authenticate via FTP it won't accept the password and just asks for it again and again whereas before it would authenticate but take me to the wrong directory.  I'm sure we're close and would really appreciate a bit more help if possible..

Thanks very much

Adam
0
 
LVL 14

Accepted Solution

by:
BlueCompute earned 500 total points
ID: 38755338
Unless the site's pretty complex in layout, I'd be inclined to delete it and start again, as the IIS7 process is a bit different to IIS6.
Otherwise, I'd enable FTP logging (described half-way down this page.) and browse through those to see what's happening - the Windows Security log may well also be logging pertinent errors.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 

Author Comment

by:amlydiate
ID: 38755480
Ok I deleted the site and added it again, pointed it to the root directory and it automatically picked up all the FTPUser folders so I tested again. Didn't work same as before.

Checked the Windows Security logs and get the following event when I try to log on as FTPUser01 in FTP:

Event 4776: The computer attempted to validate the credentials for an account.

Authentication Package:      MICROSOFT_AUTHENTICATION_PACKAGE_V1_0
Logon Account:      FTPUser01
Source Workstation:      SCMAINFTP
Error Code:      0x0

I've also found an FTP log file which says:

2013-01-08 16:11:38 SERVERIPADDRESS - MYIPADDRESS ControlChannelOpened - - 0 0 2d3a484f-fe20-4a63-9a26-c2451cb17c13 -
2013-01-08 16:11:38 SERVERIPADDRESS- MYIPADDRESSUSER FTPUser01 331 0 0 2d3a484f-fe20-4a63-9a26-c2451cb17c13 -
2013-01-08 16:11:38 SERVERIPADDRESS DOMAINNAME\FTPUser01 SERVERIPADDRESS 21 PASS *** 530 3 3 2d3a484f-fe20-4a63-9a26-c2451cb17c13 /
2013-01-08 16:11:38 SERVERIPADDRESS- MYIPADDRESSControlChannelClosed - - 0 0 2d3a484f-fe20-4a63-9a26-c2451cb17c13 -

None of which means a thing to me!
0
 

Author Comment

by:amlydiate
ID: 38755643
OK. So I've started again from scratch and created a new FTP Site. I've created some new User folders and pointed the IIS Site to the root of that folder and it's picked up all of the subfolders o.k.  I've removed the msIIS-FTPDir and msIIS-FTPRoot settings in the Attribute Editor section of the username in ADUC (just in case this was causing a problem)

I've allowed all users Read/Write access to FTPUser01 Folder in IIS but NOT set FTP User Isolation.  When I connect via FTP to FTPUser01 it authenticates but sends me to the root directory.  

The moment I then enable FTP User Isolation and select User name directory (disable global virtual directories) I can no longer authenticate.

Does this help at all?

Thanks

Adam
0
 

Author Closing Comment

by:amlydiate
ID: 38755718
Fixed it!

O.K. Here's what I did.  I deleted the whole C:\FTP folder and started again.  I created C:\FTP then a subfolder named after the domain but this time I left off the domain extension (before I had the subfolder as domain.com) so now with the folder structure as C:\FTP\DOMAIN\FTPuser01 e.t.c. I can enable User Isolation in IIS and it works perfectly.

Thanks very much for your help, I think the problem all along was actually the domain subfolder incorrectly having the .com at the end and the FTPuser Isolation setting in IIS is probably the same as going into the attribute editor in ADUC and adding the FTP root folder and the user folder however i'm awarding you the points anyway as you've been really helpful and pointed me in the right direction
0
 
LVL 14

Expert Comment

by:BlueCompute
ID: 38756207
Glad you got it fixed, and you're probably 100% correct about the the isolation control just changing the relevant ADUC settings anyway, just going on the basis that with IIS perms being fairly awkward to fix once they're wrong, and creating sites with the right settings being so easy tearing it down and starting again's often the smart option.
Interesting about the folder extension though, I'll do a bit of testing with that if I get bored and find out what's going on...
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

761 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question