Solved

Unable to Exit AIX 6.1 Install Screen

Posted on 2013-01-08
36
1,000 Views
Last Modified: 2013-12-19
I'm trying to restore a AIX 6.1 test server using the AIX 6.1 DVD and mksysb tape image but need to exit the install screen.

ALso how can you tell when the install using a mksysb image is done???

I'm at the screen where you need to select your install language. I've tried typing in: 99, x ESC+3, CTRL+Z or X  and nothing is working

I know this is a stupid question but I'm still new to AIX
0
Comment
Question by:compdigit44
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 19
  • 15
36 Comments
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38755286
Once you reached the part where you're asked for the installation language you can no longer go back, because at that point you already have left the SMS  environment.

You can only reboot or continue the installation (or turn power off, for that matter).

An mksysb installation has finished when the final automatic reboot has completed.
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38755321
Ok, I will give that a try also since I have on VG the rootvg with only 3 filesystem that I created, will the mksysb image automatically restore these volumes as well. I tried to run the install previously and the install got stuck on the following screen when I have attached a screen shot of.
AIX-ScreenShot.png
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38755375
An mksysb image contains the whole rootvg, i.e. all volumes/filesystems therein, if you didn't specify an "exclude" list during mksysb creation ("-e" option).

So all your rootvg volumes will come back then.

As for your picture: It's hardly readable, but it looks just like an architectural or microcode incompatibility. What is the OS version, source machine type/model, target machine type/model?
Please be specific, otherwise I will not be able to help.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 20

Author Comment

by:compdigit44
ID: 38755419
OK, since I never created a mksysb image before I think I did select "exclusion" in smitty but I do not have an exclusion list which I created. I do recall seeing my custom filesystem scroll on screen during the mkysysb creation..

Anyway, my source server from which the mksysb image and remote server are use the exact same hardware which is the following:

IBM 9131-52A , Processor Version: PV_5_2??

Please bare with me I'm new to AIX and greatful for all your help since I need to get this remote server up and running ASAP
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38755430
And the OS version ("oslevel -s") and microcode level ("lsmcode")?
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38755921
Here is the information for the source server which is the same hardware the remote server is using.

osleve = 6100-07-03-1207
lsmcode = ibm 9131-52a
permanent firmware image = SF240_220
temp firmware image = SF240_403


Should I try to run the install using the tape again? Are there any options I should / select or not select in the install wizard?

Also, once you enter in the install wizard there is No way out without doing a reboot? This is a problem for me since I do not have access to the server and have to relie on others at a remote site to reboot the server :-(
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38755928
BTW, take one my our help desk staff member at the remote site now to reseat the hard drives since when I reboot into SMS none of the hard drive were listed for some reason.
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38756067
For some reason my 72GB hard drives are not longer being detected. I'm in the SMS boot console and do not see any of the hard drive listed as an option.. Maybe this could explain why my initial install did not work???
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38756126
Not really.

In order to be able to start the installation there must be a target drive, otherwise nothing will happen.

If OS and firmware levels are indeed identical on both sides you're OK with that.

And yes, once you leave the SMS  (the system warns you about that fact, don't you remember?) there is no way back besides a reboot.

As for the restore options - specify "Recover Devices yes" and "Import User Volume Groups no".

If your hardware is not 100 percent identical then this is the recommended method:

- Go to the source server and install all of devices.* there, first from the Base OS DVD, then by means of "update_all" from the latest TL/SP DVDs/images.
- Take a new mksysb. Don't "EXCLUDE" files, don't create "MAP" files, but "Disable software packing" (specify "yes").
- For the restore, specify "Recover Devices".
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38756228
I just kicked of the install again using the option you suggested.. it's running now slowly....

If this doesn't work my other option is to do a clean install, install IBM Tiviolo then restore everything from my sysback backup
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38757477
When I left work the install was still running and it showed that it restore 80% of the mksysb..

I'm confused though, how is it the install is running yet in the SMS console and do not see any of the SCSI hard drives listed??????

I'm hoping the install will complete 100% by tomorrow morning. I will keep you posted.
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38758775
I checked the remote console on the server this morning and found the server to be powered off and at the login prompt for the system firmware. When I powered on the server the SMS console is seeing my SCSI adapter but NOT seeing any of the hard drives as a possible boot device. Yet, when I ran the install it stated that is was going to install to hdisk0??? What is going on here????
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38758858
There's a difference between a disk suitable for OS installation and a disk useable for booting.

A hard disk is initially a mere candidate, and only when an OS installation has successfully finished this disk becomes a boot device.

So don't you see any hard disks at all (Select "List all devices") or don't you just see any boot device?

In the latter case your attempt to restore the mksysb has obviously failed, and in the former case you have a severe hardware issue.

I'd assume that there is a hardware issue, because even with lots of user data in rootvg an mksysb restore should not take longer than from ~ 40 minutes (pure OS) to several, but not tens of hours (big rootvg with user data).

Do you have a Diag CD? I'd really suggest booting from this CD and running system diagnostics.
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38759003
Thanks for you fast reply!!!

In SMS when I go to "List ALL Devices, I see my IDE CD-Rom drive, SCSI Tape drive and NIC cards, not not my SCSI hard drives. When I initially connected to the server though a couple of days ago they were listed not they are gone.

I have noticed that if I leave the SMS console screen open for a period of time then go back to the server I find the server powered off and at the firmware login prompt :-(

I do not have a diag CD....
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38759025
A server should never power off itself, except for severe failure situations.

Just leaving the SMS open is definitely no reason for the server to power off.

And the fact that you can see your hard drives only now and then lets one fear the worst.

Really, I think your box is broke and needs inspection by an IBM support person!

The images needed to create an IBM Diagnostic CD are here:

http://www-304.ibm.com/webapp/set2/sas/f/diags/download/home.html

Choose "CDlatest.iso", burn a CD then boot from this medium. Follow the instructions displayed on the console.
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38759049
In the event log of the system firmware I'm seeing the following error:

SubSystem: Fan (AmD)
Unrecoverable Error
Location Code: U787F.001.DPM01B4-A3
Lowest Priority replacement

Subsystem: Service Processor Firmware
Predictive Error
Priority: Mandatory , replace all withthis type unit
Part# FSPSP04
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38759164
FSPSP04 indicates a system firmware error.

You must upgrade your system's firmware.

SF240_417_382 is the newest version for your machine.

Get it from Fix Central, along with installation instructions.

The attached README file should contain all you need to know in order to perform a successful upgrade.
01SF240-417-382.readme.txt
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38759215
But my source server for which I create the mksysb image is running the same firmware version without any problem???
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38759231
Are you sure? Did you check the firmware level by yourself, or is this a hearsay?
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38759246
I check the firmware myself!!! :-(

Is it possible the firmware has become corrupted???
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38759254
BTW, I'm in the process of talking through on of our base level help desk personal on how to download the diag CD now...... ;-)
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38759267
Firmware corrupted? Maybe, or a hardware defect on the service processor board, or a follow-up problem due to overheating (the first error message indicates a fan problem, after all!).

Good luck with the Diagnostic CD!
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38761390
I got off the phone with IBM support and it appear the server has a thermal failure becuase both system fans died which may have nocked out one of my hard drives. A technician is schedule to be onsite tomorrow to replace the failed parts...

I hope this works!!!

I will keep everyone posted!!!!!!
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38763647
Thermal problem? I suspected that, see my previous comment #38759267 where I presumed "overheating".

Good luck, I really think you've found the issue!
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38764058
All parts have been replaced and the server is now booting!!! As a test the onsite tech ran a base install of Aix6.1 and it worked but was't able to boot from my mksysb tape..

If I were to recreate the file systems then, install IBM Tiviolo than restore everything from the / directory down then reboot, would this restore the server to the same OS patch level and everything as the source server????
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38764191
Probably not. You cannot restore files (shared object libraries, for example) containing a running program.

Besides that, TSM is organized in filespaces. So restoring down from / will just bring back the root filesystem. You must additionally restore everything down from /var, /usr, /opt, /home, /admin, /var/adm/ras/livedump, maybe /tmp and the mountpoints of your user filesystems.

So once you have a base OS running, why not upgrade it to the TL of your source server using the appropriate images and restore just your user  filesystems from TSM?

By the way, an mksysb tape must be bootable! Either the IBM CE made a mistake or your tape image is faulty. How about recreating the tape, using the options I recommended (above all "no software packing")?
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38764262
I have read that if you take  a mksysb during production hours you should disable software packing... I already kicked off another mksysb before you replied with the following option:

Verfiy tape readability - YES
Used /tmp if needed - YES
Disable software packing - YES
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38764275
That's OK. Good luck!
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38764290
BTW, what does Disable software packing do???
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38765329
"Disable software packing" does what the name suggests.

Packing files which are modified during the compression process can easily become corrupt. So if you're pulling the mksysb during hours of heavy system activity packing should be disabled.

Packing is enabled by default to make the resulting image consume less space on the backup medium.
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38767947
AIX ScreenShot2OK I booted from the AIX 6.1 DVD than selected my mksysb tape and let the install run. THe server reboot that ran through a ReConfig process so I beleive it worked

My console has been sitting at the following screen for a while now? Why is this? Is it ok to reboot.

If so, how can I reboot the server remotely since I do have a prompt to type in any commands.
0
 
LVL 68

Accepted Solution

by:
woolmilkporc earned 500 total points
ID: 38767990
These messages are all quite normal and OK, but you should have seen a shell prompt at the end.

Remote reboot without shell access is only possible over a serial connection, not over Ethernet.

Could it be that there are NFS mounts in /etc/filesystems which cannot work on the new server, either because the responsible NFS server is not present at the new location, or due to the new IP address?

You did change the IP address, didn't you?
0
 
LVL 20

Author Comment

by:compdigit44
ID: 38768010
This is my problem though, how can I reboot the server when it's not give me a prompt to type anything
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 38768017
You can't. See my comment. You will have to rely on human intervention at the remote location.
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question