[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Drupal asking for FTP info when installing module?

Posted on 2013-01-08
3
Medium Priority
?
1,046 Views
Last Modified: 2013-01-24
I recently installed a LAMP stack (Ubuntu Linux Server) to run Drupal 7.

When I attempt to install a module via the web interface, I get prompted for FTP information?  

I'm assuming this is related to some permissions issue?

How do I circumvent this FTP challenge so I follow through on updates and module installs?

See screen capture.
sc1.jpg
0
Comment
Question by:sandshakimi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 14

Accepted Solution

by:
Scott Madeira earned 668 total points
ID: 38755759
Have a look at this...  I think it addresses your problem.

http://drupal.org/node/956030

Also, take a look at DRUSH as a way to install modules in Drupal.  It is very nice.

http://groups.drupal.org/node/134369
0
 
LVL 12

Assisted Solution

by:junipllc
junipllc earned 668 total points
ID: 38756821
I use Ubuntu as well, and FTP is not installed by default. However, SSH is, which means you can use SFTP (SFTP is basically file transfer via SSH). If you have a login/pass for the server user account that owns the Drupal install, then you can most likely use it in that screen (change to SFTP, of course).

What Drupal is basically trying to do is log into the server and update the files for the module(s) that need updating. Before this feature, we had to SFTP (or FTP) into the server and upload the files manually.

If you do have shell access, which I imagine you are as the admin, I definitely second smadeira's sentiment about drush. Life is much easier with drush:

sudo apt-get install drush

Mike
0
 
LVL 13

Assisted Solution

by:Aaron Feledy
Aaron Feledy earned 664 total points
ID: 38757402
I just dealt with this the other day. The solution was to change ownership of my sites directory to apache so it could write in the proper directories.

Something along the lines of
chown -R apache sites/

Open in new window

0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
It is possible to boost certain documents at query time in Solr. Query time boosting can be a powerful resource for finding the most relevant and "best" content. Of course the more information you index, the more fields you will be able to use for y…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question