Link to home
Start Free TrialLog in
Avatar of J.R. Sitman
J.R. SitmanFlag for United States of America

asked on

How do I locate all DNS servers?

While adding a new 2008 R2 DC the message displayed during my DNS and Global Catalog choices that there were 2 DNS servers in our Domain.  However, that isn't the case.  The new DC that I'm building actually re-building was previously a DNS server, however it was properly demoted and removed from the domain before re-build.  

I ran a scan using WSPing Pro and it only shows 1 DNS server.

So is the Windows message and error or do I have a rogue DNS server?  How do I verify?
Avatar of costanos
costanos
Flag of United States of America image

What shows up when you run NSlookup in CMD?
Perhaps you can try doing it with nslookup?
nslookup
Set type=NS
contoso.com

Open in new window

Avatar of Mike Kline
You can use nslookup


nslookup
set type = NS
Your domain name

Look on the name servers tab in DNS and look for entries for the old box in DNS.

Thanks

Mike
Avatar of J.R. Sitman

ASKER

when I run NSlookup I get "default server unknown 172.17.1.30".  which was the old DNS server that was removed but has now been added back in with the same IP and it is now a DNS server again
if I run it from the new DNS server I get the same results but with the ip address of the other DNS server.
Is your DNS configuration of that server correct?
Have you verified that this DNS server is functioning?
What is your ipconfig on your workstation like? are you able to resolve (forward and reverse) the name/IP of that server from your workstation?
If you can't, then you need to address that issue to make sure that is working.
make sure you have setup DNS correctly in your env follow below best practices

Best practices for DNS client settings on DC and domain members.
http://abhijitw.wordpress.com/2012/03/03/best-practices-for-dns-client-settings-on-domain-controller/

Also run dcdiag /test:dns to check the DNS issue on the dc
DNS settings verified.
Yes DNs is working.  No problems
ipconfig from the workstation shows the proper DNS servers and DHCP server

So as far as I can tell there isn't a problem, that I can see
OK.  I'll post later.  Got to get to a meeting
when I run dcdiag /test:dns I get unrecognized command.  I get the same thing if I run ipconfig /flushdns
You get "unrecognized command" when you run ipconfig /flushdns?  If that's the case, something's gone very wrong.

Wait, you're not still in nslookup, are you?  If so, type exit and try again from the normal command prompt.
Also, when you're doing these commands, you might want to open the command prompt with elevated privileges.
ipconfig /flushdns will work with normal privilege, but, ipconfig /registerdns won't.
yep was still in nslookup.  Attached are the results.  It is trying to find a DNS server that has been gone at least 2 years spcala02
dnsfail.jpg
Open the DNS console on one of your DNS servers, right-click your domain's forward lookup zone, and select Properties.  What's listed in the Name Servers tab?  (Check any other forward lookup zones you've got too.)
There are 3 forward lookup zones.  see attached.  In all three the only DNS server listed is the one that was removed two weeks ago and then added back today.  I used the same server name and IP address when adding it back to the domain
dnsforward.jpg
I just did ipconfig /all from a workstation and it has all the correct servers. DNS/DHCP
ASKER CERTIFIED SOLUTION
Avatar of DrDave242
DrDave242
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
yep it was.  I'll rerun the test.
The initial rogue DNS server is gone but the other errors are still there.  I'll award the points for this and open a new case.  Please watch for it.  You obviously know what you're doing.

Thanks
thanks