Solved

Dell Latitude D820 w/ T2500 only running @ 1GHz

Posted on 2013-01-08
25
1,303 Views
Last Modified: 2016-11-23
I have a Dell Latitude with a fresh install of Windows 7 Pro x86 with the following specs:
CPU = T2500 (Core Duo) @ 2GHz
RAM = 4GB
HDD = 160GB Intel SSD

There aren't any Windows 7 drivers on the Dell website for this laptop but everything is recognized (know unknown devices in Device Manager).

It has the newest BIOS (A10) and I've looked through all of the BIOS settings but nothing is helping me figure out why the CPU is only running @ 1GHz.

Everything installs incredibly slow and it's driving me insane.

I've installed the Vista chipset driver for this laptop in hopes that would fix it but I don't think it helped.

I'm using CPU-Z to check the speed of the CPU.

It looks like if I reboot the laptop, it'll be running @ 2GHz but out of nowhere it just drops to 1GHz and never returns to 2GHz.

I have the power options in the Control Panel set to "high performance" but that doesn't seem to help.

I really feel like I've tried everything I could think of and could really use some help.

I don't want to put XP on it because of the SSD.  I know this laptop is more than capable of running W7 I just don't understand why the CPU speed keeps dropping to 1/2 what it should be...

For example, I rebooted the laptop and used CPU-Z to check the CPU speed.  It was @2GHz.  
2GHzI then started the installation of a program and it dropped down to 1GHz.
1GHzWhy would it drop to a LOWER speed when I'm installing software??
0
Comment
Question by:homerslmpson
  • 12
  • 7
  • 4
  • +1
25 Comments
 
LVL 2

Expert Comment

by:thombeck
Comment Utility
Hi,

one collegue of me had the same problem with a Dell d620.
The problem were the chipset driver.
Can you please update them with newer (vista) driver?
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
Can you send me a link to the EXACT driver?
I'm having a hard time finding the one needed.
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Open Task Manager and set the option to hide when minimized. Minimize it and leave it running. It is dark green when the CPU is idle (which is most of the time) and bright green when loaded. This will help you gauge whether the CPU is busy or not.

Now, CPU's generally run at half speed. That is completely normal. Also, software installs are often disk intensive.

So then the question is: Does the CPU ever go up (even for a short time)? It should. Or does it go down as you show and never go up?

.... Thinkpads_User
0
 
LVL 2

Expert Comment

by:thombeck
Comment Utility
Hi,

the dell driver download website has some problems, but this file (download on the page) should be the same:
http://dell.laptop-software.com/delldriver.php?chipset/R140623.EXE
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
Anything like simply opening "My Computer" causes the thing to spike for multiple seconds at 100%.
Go to install a program? 100% maxed out super slow can't do a damn thing.  
The install of whatever it is WILL eventually complete but it's super slow.
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
I already installed that driver.
That's the one that I think fixed the issue but it wasn't consistent.
It would be @ 2GHz upon startup but as soon as I try to install a program it would drop down to 1GHz and would never go back unless I restart.
I know chipset drivers are normally the first drivers you install when reinstalling an OS.
Maybe I need to reinstall Windows 7 again and install this driver first thing?
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Maybe I need to reinstall Windows 7 again and install this driver first thing?

If you are at that point (and maybe this is what is needed), try:

1. System File Checker. Run SFC /SCANNOW and allow to complete. Run again if errors remain uncorrected. Restart the computer.

2. Run a Repair Install. Back up first. See:

http://www.sevenforums.com/tutorials/3413-repair-install.html

See if these things help.

... Thinkpads_User
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
I don't want to run a repair as it doesn't remove drivers and the ones I installed may very well be the reason this thing isn't working properly.
I can't see the SFC command helping me at this point...
I'm going to try a clean install and install the chipset driver first thing.
I'll let you guys know the outcome tomorrow...
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
It's like a cruel joke I swear.
I reinstalled Windows 7 and installed the chipset driver.
The chipset driver installed "instantly" which makes me think it didn't actually INSTALL anything.
Regardless, I switched the power options to "high performance" or whatever and the CPU was running OK.
I then tried to install .NET 4.0 and as soon as the file extracts and I accept the license agreement BOOM it drops down to 1GHz.  At that point, I cancelled the install.
I then decided to try and run the Intel diag tool mentioned above.
...It needs to auto install Java, some other program and (what are the odds?)... .NET 4.0.
This is going to take a while...
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Please let us know the outcome. I never had any problems with Intel Chips and Speed Step technology (which is what changes the CPU speed). Speed Step (for me) has not depended upon .NET Framework or Java.

What it might depend upon is the Power Management Driver.  I have this Power Manager Driver for my Thinkpad. Look for a comparable one for your DELL.

Thinkpad-Power-Management
... Thinkpads_User
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
The Intel diag tool said the CPU "passed".  The output is below:
--- IPDT - rev  1.48.0.0 ---
--- Start Time: 01/09/2013 09:07:11---
--- Skipping Config ---
 --- Reading CPU Manufacturer --- 
Expected --> GenuineIntel
Detected --> GenuineIntel
Found --- Genuine Intel Processor ---
 --- Temperature Test --- 
Temperature Test Passed!!!
Temperature = 44 degrees C below maximum.
 --- Reading Brand String --- 
Detected Brand String:
Genuine Intel            T2500   2.00GHz
Brand String Test Passed!!!
 --- Reading CPU Frequency --- 
Expected CPU Frequency is --> 2.00
Detected CPU Frequency is --> 2.0212
CPU Frequency Test Passed!!!
 --- Reading FSB --- 
Expected FSB : --> 667
Detected) FSB : --> 667
CPU FSB Test Passed!!!
 --- Running Base Clock test --- 
---  This CPU does not support base clock test ---
 --- Running Floating Point test --- 
Million Floating Points per Second, MFLOPS --> 14.4
Floating Point Test Pass ---
 --- Running Prime Number Generation Test --- 
Operation Per Second--> 110763
Prime Number Generation Test Pass ---
 --- Reading Cache Size ---  
- Detected L1 Data Cache Size --> 2 x 32
- Detected L1 Inst Cache Size --> 2 x 32
- Detected L2 Cache Size --> 2048
- Detected L3 Cache Size --> Not Detected.
 Cache Size Test Passed!!!
 --- Determining MMX - SSE capabilities --- 
		 --- CPU FEATURES DETECTION FOR ---
	            ---        MMX SSE       ---
MMX		 - MMX Supported -->	Yes
SSE		 - SSE Supported -->	Yes
SSE2		 - SSE2 Supported -->	Yes
SSE3		 - SSE3 Supported -->	Yes
SSSE3		 - SSSE3 Supported -->	No 
SSE4.1		 - SSE4.1 Supported -->	No 
SSE4.2		 - SSE4.2 Supported -->	No 
		--- MMX SSE - capabilities check complete ---
MMX Test Result --- PASS
SSE Test Result --- PASS
SSE2 Test Result --- PASS
SSE3 Test Result --- PASS
SSSE3 Test Result --- Not Tested
SSE4.1 Test Result --- Not Tested
SSE4.2 Test Result --- Not Tested
MMX SSE Testing Passed !! 
 --- Determining AVX AES PCLMULQDQ capabilities --- 
		 --- CPU FEATURES DETECTION FOR ---
	           --- AVX/AES/PCLMULQDQ ---
AVX		 - Advanced Vector Extensions Supported -->	No 
AVX OS Support   - AVX Operating System Supported -->		No ---> No Test Required
AES		 - Advanced Encryption Standard Supported -->	No ---> No Test Required
PCLMULQDQ	 - Polys Carry-Less Multiply Supported -->	No ---> No Test Required
	--- AVX AES PCLMULQDQ capabilities check complete ---
AVX Compare Test Result --- Not Tested
AES Test Result --- Not Tested
PCLMULQDQ Test Result --- Not Tested
No AVX AES PCLMULQDQ Tests required 
 --- IMC NOT Supported on this Processor ---
..Platform Controller Hub Test not supported curent chipset..
..Skipping Platform Controller Hub Test..
Skipping Platform Controller Hub Test
..
..Query 5..
..
 --- Querying for Intel(R) Integrated Graphics Device (IGD) ---
..Intel(R) Integrated Graphics Device not supported on this processor..
..Skipping Intel(R) Integrated Graphics Device Presence Test..
..
 --- CPU Load --- 
 --- Load Level = 8
CPU Load Passed!!!
 --- Temperature Test --- 
Temperature Test Passed!!!
Temperature = 43 degrees C below maximum.
--- Test End Time: 01/09/2013 09:11:12---

Open in new window


I checked the device manager and I don't see any Dell PM devices or anything like that.
Keep in mind that Dell doesn't offer any W7 drivers for this laptop which is why this type of driver/program may be unavailable.
Device manager
I'm getting VERY close to installing Windows XP on this thing and being done with it.
I don't want to do that but it's getting very frustrating.

The chipset driver installing so quickly is leading me to believe that it's not actually installing at all.  This could definitely be part of the issue.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Keep in mind that Dell doesn't offer any W7 drivers for this laptop

You did not say otherwise above, so I concluded this model of DELL came with Windows 7. Apparently not, and so it may not be Windows 7 compliant. I cannot think of any other reason at this point.

So yes, maybe you are better to back to XP.

But then it cannot be a new machine and so maybe it is time to think new machine. If you do, get a good machine. ... Thinkpads_User
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
I mentioned there being no W7 drivers...
1
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
does the cpu show in device manager correct?
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
At this point I'm already in the process of installing XP on this thing.  I can't take it anymore.
W7 is no longer on it so I can't check.
I certainly hope once XP is back on it, the CPU is working the way it should.
I'll find out soon.
Keep in mind that with this issue, it would start up running @ 2GHz but once I would try to install software, it would drop to 1GHz.  It would then stay at 1GHz until the system was rebooted. Very strange issue.  I suspect it does have something to do with the chipset drivers but I'm not 100% sure and everything I tried was a fail.
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
When I would open the task manager, I'd see 2 cores show up but they would both spike to 100% super easily. I suspect this is because both cores were running at 1Ghz instead of 2GHz so even the simplest task would max out the CPU.
I mean, even an Atom CPU has over 1GHz...
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
coukld be a rare case of a bad cpu
we'll see what XP has to say
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
So I installed XP.
It took a lot longer than I was expecting.
I then installed all the necessary drivers.
It's still running @ 1GHz...
It runs "better" than it was when W7 was on it but obviously this problem is deeper than a chipset driver.
Speccy shows the CPU temp at 60 degrees celsius.
That doesn't seem TOO hot but it does seem a bit warm, no?
What could be the issue here?
0
 
LVL 90

Accepted Solution

by:
John Hurst earned 500 total points
Comment Utility
A normal CPU for me will run less than 50 degrees C when running normally and 40 or so degrees C when idling. I am using my ThinkpadT61p right now and CPU is at 38 degrees C. GPU is at 57 degrees C and it always runs hotter.

What could be the issue here?

Barring a hardware fault which would be difficult to pin down in a forum like this, it could have dried up thermal compound or a dirty and slow fan that is not evacuating heat well enough. You would have to get inside the laptop to determine these two things.

... Thinkpads_User
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
I took the laptop apart and reapplied the thermal compound.
When I was in there I used compressed air to get rid of some built up dust and such.
I noticed the main exhaust fan wouldn't spin when I blew a considerable amount of air into it.
I spun it manually and a small plastic/rubber cap of sorts fell out.
The fan then spun normally.
Now that I've reassembled it and powered it on, the CPU temp was 29 degrees.
I checked the CPU speed and it was @ 2GHz.
I then proceeded to run my "test" which is to simply install .NET 4.0.
It looks like the CPU speed is fluctuating between 1GHz and 2GHz quite a bit but at least it's hitting 2GHz now.
After the install of .NET 4.0 which completed quickly, the CPU got up to 60 degrees or so.
I'm wondering if the issue the entire time was the fan being blocked by that little cap...
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
I'm wondering if the issue the entire time was the fan being blocked by that little cap...

It is possible. Perhaps the Speed Step sensor was not working properly. It is hard to say. We can say, however, the hot CPU's and dirty fans do not help a laptop.

.... Thinkpads_User
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
you could reinstall W7 and check what happens
can you post a pic ture with dimension of the rubber cap?
it may be something you need
0
 
LVL 1

Author Comment

by:homerslmpson
Comment Utility
I reinstalled W7 on the laptop and everything appears to be working OK.
The CPU is staying in the 2GHz range now.
The cap was similar to this:
capI don't know what wire it protected as all of the ones I saw had the caps on them but I don't think it's anything to worry about.
I'm not going to lie, I reapplied the thermal compound pretty half-assed.  I think I'm going to reapply it again but this time do a better job as I don't like the way the CPU temp goes from 30 degrees to 60 degrees so easily.
That being said, I think the cap blocking the fan was the real issue here.
It's now running nice and quick and I didn't have to install ANY drivers at all (ie: Vista chipset driver) so I'm a happy camper...for now.
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Thank you. I was happy to help. The pictures look like connecting wires for a PCI mini card. One possibility is Wireless WAN upgradibility (set up for use but no card).

.... Thinkpads_User
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Suggested Solutions

If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now