Solved

MS Exchange Mail Flow

Posted on 2013-01-08
15
631 Views
Last Modified: 2013-02-23
Hi

I have an issue that has turned up randomly and not sure where the issue comes from.
This server has been operational with no issues for over 12 Months.

This morning I cannot send or recieve email from the server.

Microsft exchange transport service will not start and I have some odd permission errors happening.

Below is the error as viewed in the event log.

Any assistance in finding the fault here would be much appreciated.

Cheers
Paul

Microsoft Exchange couldn't start transport agents. The Microsoft Exchange Transport service will be stopped. Exception details: Failed to create type 'Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory' from assembly 'C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\agents\Hygiene\Microsoft.Exchange.Transport.Agent.Hygiene.dll' due to error 'Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))'. : Microsoft.Exchange.Data.ExchangeConfigurationException: Failed to create type 'Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory' from assembly 'C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\agents\Hygiene\Microsoft.Exchange.Transport.Agent.Hygiene.dll' due to error 'Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))'. ---> Microsoft.Exchange.Data.ExchangeConfigurationException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) ---> System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
   at Microsoft.Exchange.Data.Transport.Interop.UnsafeNativeMethods.CoCreateInstance(Guid rclsid, Object pUnkOuter, UInt32 dwClsContext, Guid riid)
   at Microsoft.Exchange.Data.Transport.Interop.ComProxy..ctor(Guid guidClass)
   at Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory.InitializeFilter()
   --- End of inner exception stack trace ---
   at Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory.InitializeFilter()
   at Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory.Configure(Boolean onStartup)
   at Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory..ctor()
   --- End of inner exception stack trace ---
   at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable.CreateAgentFactory(AgentInfo agentInfo)
   at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable..ctor(IEnumerable agents)
   at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.RuntimeSettings..ctor(MExConfiguration config, String agentGroup)
   at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.MExRuntime.Initialize(String configFile, String agentGroup, Boolean isBridgeHead, String installPath)
   at Microsoft.Exchange.Transport.Extensibility.AgentComponent.Load()
0
Comment
Question by:kennedypd1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 5
15 Comments
 
LVL 33

Expert Comment

by:Busbar
ID: 38757867
ok first, can you uninstall the spam filters and then reenabled them again.
0
 

Author Comment

by:kennedypd1
ID: 38757931
Thanks for your quick response.

Something I forgot to mention.
If I go into the services panel and change the logon for the transportation service to my administrators logon it starts just fine and I can see the queue but it cant deliver the mail as it has to be networkservice to access mailboxes as I understand it. This to me seems to mean I have an access issue error with my networkservice.

When you say spam filters you want me to uninstall AVG?

Cheers
Paul
0
 
LVL 33

Expert Comment

by:Busbar
ID: 38757937
don't change the services' accounts.
do you have a list of them, return them to the default, also make sure that no GPO applies that prevents local system and network service from logging into the server.
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:kennedypd1
ID: 38757979
Hi

I have returned the logon to network service.
I can see nothing in the GPO that would stop these accounts logging on.
0
 
LVL 33

Expert Comment

by:Busbar
ID: 38757993
i don't think that all of them run network service
0
 

Author Comment

by:kennedypd1
ID: 38758032
I only altered the microsoft exchange transportation service so have restored that one only
0
 
LVL 33

Expert Comment

by:Busbar
ID: 38758049
ok and you still getting the errors, have you rebooted the server since the change
0
 

Author Comment

by:kennedypd1
ID: 38758103
Have rebooted and error still the same. The error goes when I put my admin account info into the login but then the other things dont work so have it back at network service now. The reason I raised it is that you were suggesting uninstall of AVG and would that work if the service actually works with the other login. It appears to be a permissions error on the network service login.
0
 
LVL 33

Expert Comment

by:Busbar
ID: 38758110
hmm, it looks that you are not putting the network service account password.
0
 

Author Comment

by:kennedypd1
ID: 38758112
the network service does not have a password. They are setup this way by the operating system
0
 
LVL 19

Expert Comment

by:R--R
ID: 38758918
Give network service account permission on 'C:\Program Files\Microsoft\Exchange Server\V14
and subfolders.
0
 

Author Comment

by:kennedypd1
ID: 38760452
Hi

NetworkService does not come as a user that you can add to security. What I have done is given Network Service which is a group full access to this folder. I believe that this should cover it. I can drill down to the dll that the error message is complaining about and see that Network Service has full access to it.

Cheers
Paul
0
 

Author Comment

by:kennedypd1
ID: 38760612
Hi

Have noticed that the folders inside C:\Program Files\Microsoft\Exchange Server\V14 have a tick in the read only box. I remove this and it applies it to the sub folders but the tick just comes right back.

Any thoughts?
0
 

Accepted Solution

by:
kennedypd1 earned 0 total points
ID: 38903380
I had to do a full server reload to resolve this. Not an ideal situation but was going to be quicker that trying to resolve.
0
 

Author Closing Comment

by:kennedypd1
ID: 38920859
I did not find a solution to issue apart from reload of server
0

Featured Post

Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question