• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1289
  • Last Modified:

Veeam Backup Automount Issues with Replica job

Hi,

We use Veeam version 6.5 to provide DR between 2 sites running VMWare vCenter verision 4.1. We have several replica jobs configured to protect production VMs.

All but one of these jobs work fine - and it's a bit of a head-scratcher!

As you know, if your destination backup proxy is a VM on an ESXi registered host (with a direct connection to the target datastore) then the Virtual Appliance transport mode will be used for writing replica data to the target. Replica virtual disks are mounted on the target backup proxy and populated through the ESXi I/O stack.

The target backup proxy is running Windows 2008 R2. Automount is clearly disabled as the "NoAutoMount" DWORD under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MountMgr\ is set to "1" and we have manually run the diskpart automount disable command to make sure.

Just one of our replication jobs keeps automounting a disk on the backup proxy. It is presented as an 'N:' drive and asks if we would like to format it.

This is not causing any issues. It would just be a great idea to resolve the problem in case anybody came along and clicked "yes"!

The target backup proxy has been restarted several times.

Does anybody have any ideas?

Many thanks in advance,

Oliver

P.S Might running automount disable scrub help?

{Removes volume mount point directories and registry settings for volumes that are no longer in the system. This prevents volumes that were previously in the system from being automatically mounted and given their former volume mount point(s) when they are added back to the system}
0
ollygd
Asked:
ollygd
  • 2
1 Solution
 
noxchoCommented:
Hi Oliver, have you tried one trick - assign the N: drive letter to CD-ROM on this machine and then see if the automount feature automatically picks up the next drive letter?
0
 
MaximVeeamCommented:
Did you contact Veeam Support? http://www.veeam.com/support.html
0
 
ollygdAuthor Commented:
Hi -

Thanks to you both for responding. As it happens, I ran the following commands last night and they appear to have corrected the problem:

diskpart
automount disable
automount scrub

I'll let you know if it comes up again, but I'm quietly confident!

Olly
0
 
ollygdAuthor Commented:
Tried own solution.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now