Solved

500 The page cannot be displayed because an internal server error has occurred. iis7 on windows 7 when trying to hit an asp page

Posted on 2013-01-09
11
4,006 Views
Last Modified: 2013-01-11
Hi Guys,

I have a client using windows 7. IIS 7 I am trying to hit an asp page but getting the "500 The page cannot be displayed because an internal server error has occurred." I have gone through loads of guides and steps to get it past but no joy. I have added new app pool with .net framework v2.0.50727 and with no managed code. I have checked and triple checked the permissions on the site.

I can hit a html page that submits a request to an asp page and get a response but no response from the .asp page directly.

Here is the iis log. I have tried several different browsers so that's where your going to see the same error from different sources.

"
#Software: Microsoft Internet Information Services 7.5
#Version: 1.0
#Date: 2013-01-09 14:02:25
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2013-01-09 14:02:25 192.168.1.11 GET /CaptivaEposWebServices/CONFIRMORDER.asp |16|800a0400|Expected_statement 85 - 62.77.187.233 Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 500 0 0 556
2013-01-09 14:02:47 192.168.1.11 GET /IISSTART.HTM - 85 - xxx.xxx.xxx.xxx Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 200 0 0 261
2013-01-09 14:02:51 192.168.1.11 GET /welcome.png - 85 -xxx.xxx.xxx.xxx Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 200 0 0 3918
2013-01-09 14:03:49 192.168.1.11 GET /CaptivaEposWebServices/confirmsettings.asp - 85 - xxx.xxx.xxx.xxx Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 200 0 0 341
2013-01-09 14:03:57 192.168.1.11 GET /CaptivaEposWebServices/confirmORDER.ASP |16|800a0400|Expected_statement 85 - xxx.xxx.xxx.xxx Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 500 0 0 589
#Software: Microsoft Internet Information Services 7.5
#Version: 1.0
#Date: 2013-01-09 14:06:56
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2013-01-09 14:06:56 192.168.1.11 GET /CaptivaEposWebServices/CONFIRMOrder.asp |16|800a0400|Expected_statement 85 - xxx.xxx.xxx.xxx Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 500 0 0 549
#Software: Microsoft Internet Information Services 7.5
#Version: 1.0
#Date: 2013-01-09 14:15:10
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2013-01-09 14:15:10 192.168.1.11 GET /CaptivaEposWebServices/CONFIRMOrder.asp |16|800a0400|Expected_statement 85 - xxx.xxx.xxx.xxx Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 500 0 0 407
2013-01-09 14:15:16 192.168.1.11 GET /CaptivaEposWebServices/CONFIRMOrder.asp |16|800a0400|Expected_statement 85 - xxx.xxx.xxx.xxx Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 500 0 0 349
#Software: Microsoft Internet Information Services 7.5
#Version: 1.0
#Date: 2013-01-09 14:21:58
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2013-01-09 14:21:58 192.168.1.11 GET /CaptivaEposWebServices/CONFIRMOrder.asp |16|800a0400|Expected_statement 85 - xxx.xxx.xxx.xxx Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 500 0 0 465
#Software: Microsoft Internet Information Services 7.5
#Version: 1.0
#Date: 2013-01-09 14:29:12
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2013-01-09 14:29:12 192.168.1.11 GET /CaptivaEposWebServices/CONFIRMOrder.asp |16|800a0400|Expected_statement 85 - xxx.xxx.xxx.xxx Opera/9.80+(Windows+NT+6.1;+WOW64)+Presto/2.12.388+Version/12.12 500 0 0 735


I hope someone can help as I have spent a fair bit of time on this and I need it closed.

Many thanks
0
Comment
Question by:DerKav
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 50

Expert Comment

by:jcimarron
ID: 38759747
DerKav--500 errors usually are caused by a problem with the server at the website, not at the viewer's side
http://pcsupport.about.com/od/findbyerrormessage/a/500servererror.htm  See the section "HoHow To Fix the 500 Internal Server Error"

http://www.checkupdown.com/status/E500.html
Can you reach the site using another PC?
0
 

Author Comment

by:DerKav
ID: 38759796
Hi Jcimarron,

Thanks for your input, I had cleared cash and tried several different browsers as well as trying from different P.C's? I can only guess that it is how I have iis configured. Thanks
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 38759978
DerKav--I understand you to say that you could not reach the site using several browsers and PC's.  That only substantiates the thought that there is nothing you can do at your end.
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Author Comment

by:DerKav
ID: 38760001
Hi Jcimarron,

I know that there isn't anything wrong at my end, Its iis that I have made the error on. Just looking for some help on the config of that.

Thanks
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 38760111
DerKav--If you agree there is nothing wrong at your end, why do you think IIS7 (which I assume is at your end) is the problem?
0
 
LVL 82

Expert Comment

by:David Johnson, CD, MVP
ID: 38760641
try on iis changing the port that it runs on and see if the server will now run properly. if you have skype running on the iis server machine remember that it takes over port 80 (skype) unless you turn it off
0
 
LVL 31

Assisted Solution

by:Wayne Barron
Wayne Barron earned 500 total points
ID: 38761496
Check this out, and see if it will assist you in resolving your issue.
http://www.experts-exchange.com/A_3730.html

Carrzkiss
0
 

Author Comment

by:DerKav
ID: 38762728
Hi Jcimarron, IIS is at the client end and there fore needs to be running correctly in order that other clients can connect to the webserver. But I have got passed it thanks to Carrzkiss post.

@ve3ofa, Thanks for your input, but I had already ruled out the port as it operates on port 85.

@Carrzkiss, Now I have a permissions error.
"Microsoft VBScript runtime error '800a01ad'

ActiveX component can't create object

/WebServices/_common.asp, line 5 ."

I have had a look at the common.asp page and it is a call on a a dll which I have registered but still fails. I know its off point but any ideas?
0
 

Author Comment

by:DerKav
ID: 38762748
Also its win7 64bit os if that is any help.  I have registered the dll in the syswow64 folder.
0
 
LVL 31

Accepted Solution

by:
Wayne Barron earned 500 total points
ID: 38763239
Check this out, and see if it will assist.
ActiveX component can't create object, when creating a 32-COM object in a 64-bit machine

64Bit systems, are playing heck with the 32bit objects.
This is something that I am going to have to deal with, within the next year.
As I am getting ready to take all my sites inhouse, since it is getting so cheap to build super high powered server systems.

Carrzkiss
0
 

Author Comment

by:DerKav
ID: 38766840
Hi Carrzkiss,
You the man, I didn't get the ultimate solution till I found this post but you have sent me in the right direction. Many Thanks

http://exhibita.com/blog/post/2010/03/30/iis-75-on-x64-with-32bit-applications.aspx

Here is something you will need if running the 32bit dll's on a 64bit os via IIS 7.5.
0

Featured Post

Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
Assume you have an outside contractor who comes in seasonally or once a week to do some work in your office, but you only want to give him access to the programs and files he needs and keep all other documents and programs private. Can you do this o…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Suggested Courses

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question