Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

ESXI 5U1 - not able to pass-through any USB-devices attached to server

Posted on 2013-01-09
19
Medium Priority
?
5,142 Views
Last Modified: 2013-02-02
Hi experts.

First of all: the server looked perfectly healthy until now and runs on supported hardware.
It can passthrough devices attached to a windows client to the guest OS' using the vsphere client. It cannot passthrough usb tokens that are attached to the esxi server itself - vsphere does not see them. Server is esxi 5.0 update 1 and corresponding vsphere client.

So far I have
-tried different usb tokens
-looked at the events tab in vsphere client, several "USB configuration has changed" are logged whenever I attach a device to the server.
-stopped and restarted the usbarbitrator at the ESXI console
to no avail.

I also read hanccocka's article http://www.experts-exchange.com/Software/VMWare/A_9349-HOW-TO-Add-and-Connect-a-USB-Device-to-a-Virtual-Machine-hosted-on-VMware-vSphere-Hypervisor-ESX-4-1-ESXi-4-1-ESXi-5-0.html and I wonder what he could mean writing
if the USB Device (unavailable) shows in gray and unavailable, either a USB device is not connected to the server, or the USB device is incompatible. Some host servers do not support USB passthrough.
When are these conditions met? Tried many devices, not all can be incompatible. What host servers do not support passthrough and even if mine were one of them, would'n't that mean it should neither be able to passthrough usb tokens that are connected to my own client (which does work)?

Anything to try?
0
Comment
Question by:McKnife
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
  • 5
19 Comments
 
LVL 6

Expert Comment

by:traoher
ID: 38759349
What if you use vsphere client and put your usb through your desktop?

You will need to added USB Controller through vSphere to a vm hardware.  Once you do that, attached a USB to your desktop, console to the machine you added the usb controller, login and your usb should work.
0
 
LVL 123
ID: 38759369
Some USB devices or Hosts do not support USB Passthrough.

Some USB devices do not work or are not supported.

to diagnose issues with USB devices you need to get "under the covers" and look at the logs in /var/log

usb.log
vmkernel.log

when you insert a usb device into the host, it will be displayed in the log, this does not matter if it's connected to the VM.

no entry in the logs for the usb device the USB device or Controller on the Motherboard is not supported.

sometimes, we've seen when using a USB flash drive, or USB keyboard or mouse, connected to a server, all usb ports do not function.

have you tried ALL usb ports?
0
 
LVL 56

Author Comment

by:McKnife
ID: 38759615
@traoher: as I wrote, if I connect it to my own computer, I can pass it through.
@hanccocka: let me quote vmkernel.log... I don't understand what's going on. Fact is, although it finally says "available for passthrough" in the log, it is not.
------
2013-01-09T16:30:48.582Z cpu7:2663)<6>usb 1-1.6: new high speed USB device using ehci_hcd and address 11
2013-01-09T16:30:48.700Z cpu1:2663)<6>usb 1-1.6: New USB device found, idVendor=0ea0, idProduct=2168
2013-01-09T16:30:48.700Z cpu1:2663)<6>usb 1-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
2013-01-09T16:30:48.700Z cpu1:2663)<6>usb 1-1.6: Product: Flash Disk      
2013-01-09T16:30:48.700Z cpu1:2663)<6>usb 1-1.6: Manufacturer: USB     
2013-01-09T16:30:48.700Z cpu1:2663)<6>usb 1-1.6: SerialNumber: 611041FAD53B004B
2013-01-09T16:30:48.700Z cpu0:2663)<6>usb 1-1.6: Vendor: 0x0ea0, Product: 0x2168, Revision: 0x0200
2013-01-09T16:30:48.700Z cpu0:2663)<6>usb 1-1.6: Interface Subclass: 0x06, Protocol: 0x50
2013-01-09T16:30:48.701Z cpu0:2663)WARNING: LinScsiLLD: scsi_add_host:599:vmkAdapter (usb-storage) sgMaxEntries rounded to 255. Reported size was 255
2013-01-09T16:30:48.701Z cpu0:2663)DMA: 524: DMA Engine 'vmhba38' created.
2013-01-09T16:30:48.701Z cpu0:2663)<6>usb-storage 1-1.6:1.0: interface is claimed by usb-storage
2013-01-09T16:30:48.701Z cpu0:2663)<6>usb 1-1.6: device is not available for passthrough
2013-01-09T16:30:48.701Z cpu0:2663)<6>usb 1-1.6: usbfs: registered usb010b
2013-01-09T16:30:48.712Z cpu1:2080)ScsiNpiv: 1525: GetInfo for adapter vmhba38, [0x4100080e9e40], max_vports=0, vports_inuse=0, linktype=0, state=0, failreason=0, rv=-1, sts=bad0020
2013-01-09T16:30:49.704Z cpu5:8922007)usb-storage: detected SCSI revision number 2 on vmhba38
2013-01-09T16:30:49.704Z cpu5:8922007)usb-storage: setting peripheral qualifier to 'not connected' on vmhba38
2013-01-09T16:30:49.704Z cpu0:2651)<6>usb-storage 1-1.6:1.0: unclaiming vmhba38
2013-01-09T16:30:49.704Z cpu0:2651)LinScsiLLD: scsi_remove_host:857: Removed Host Adapter vmhba38
2013-01-09T16:30:49.704Z cpu6:2651)<6>usb 1-1.6: device is available for passthrough
2013-01-09T16:30:49.705Z cpu6:2651)ScsiAdapter: 2228: Unregistering adapter vmhba38
2013-01-09T16:30:49.705Z cpu6:2651)DMA: 569: DMA Engine 'vmhba38' destroyed.

Open in new window

--------
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
LVL 6

Expert Comment

by:traoher
ID: 38759637
Try enable or load the local drive for your usb on the ESXi hosts.
0
 
LVL 123
ID: 38759660
okay, the device is being detected by the hypervisor, you can see it in the logs.

you've added the usb controller, and a device?
0
 
LVL 56

Author Comment

by:McKnife
ID: 38759696
> Try enable or load the local drive for your usb on the ESXi hosts.
I don't follow...what do you mean?
> okay, the device is being detected by the hypervisor, you can see it in the logs.
I know...
> you've added the usb controller, and a device?
Of course. But no usb token there to add.
0
 
LVL 123
ID: 38759743
is this a security device (token), because we've seen these not passed through.

e.g. we've had issues with the http://www.deskey.co.uk/
0
 
LVL 6

Expert Comment

by:traoher
ID: 38759752
If you plugin an external USB drive to the esxi host, do you see it from your esxi host command line?

If not, you must enable usb within your host BIOS.
0
 
LVL 123
ID: 38760028
@traoher, if you look at the logs posted, you can see the Host ESXi server detects the USB device!
0
 
LVL 6

Expert Comment

by:traoher
ID: 38760101
i am sorry, i should have read through the logs.

Have you tried this link?

http://www.vm-help.com/esx40i/VMDirectPath/USB_Setup.php
0
 
LVL 56

Author Comment

by:McKnife
ID: 38760717
@h.
> is this a security device (token)
Yes and no. We connected several usb thumb drives, amongst those a HASP token. But the normal ones don't work, either.
> have you tried ALL usb ports?
Yes.
@t.
> Have you tried this link?...
Will do tomorrow and feedback.
0
 
LVL 123
ID: 38760842
the link supplied is a different process completely, it's not USB Passthrough, it presents the real hosts PCI device (e.g. USB Controller) to the VM. Only one PCI device can be presented a VM.

It's called VM Direct Path I/O.

It may work for you as a workaround, but it's a different technology and process.

Also it has it's limitations, but if you are happy with a workaround.
0
 
LVL 123
ID: 38760848
if you server is on the Hardware Compatibility List and certified with VMware ESXi 5.0, I would escalate to Vendor and VMware.

We have seen strange issues with certain AHCI BIOS and USB BIOS settings which have caused issues with USB passthrough, with HP and Dell servers.

Do you have USB mouse or keyboard, USB flash drive in use for ESXi?
0
 
LVL 56

Author Comment

by:McKnife
ID: 38762071
Ok, I am willing to use the workaround, but this won't be possible before weekend because this configuration change will not apply without a host-restart, esxi says.

Hanccocka, we run the free esxi, how good is the support we are entitled to use? I believe it's only forum support?

Edit:
> Do you have USB mouse or keyboard, USB flash drive in use for ESXi?
No, nothing.
0
 
LVL 123
ID: 38762249
you are *NOT* entitled to any support.

other than what you find here, of through any forum.
0
 
LVL 56

Author Comment

by:McKnife
ID: 38764805
Ok, that's what I thought.

Tried the workaround today because I was in the office till very late. No change after setting it and rebooting the host. We'll have to live with it or try VMware forums. Will keep you updated.
0
 
LVL 6

Expert Comment

by:traoher
ID: 38764857
we tried!
0
 
LVL 56

Accepted Solution

by:
McKnife earned 0 total points
ID: 38827027
I would like to close this question.
No progress was made and from what I read in the vmware forums, this seems to be a bug in 5.1 that is seen on some systems. Hopefully, this will be fixed someday.
0
 
LVL 56

Author Closing Comment

by:McKnife
ID: 38846379
See comment
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
Ransomware is a malware that is again in the list of security  concerns. Not only for companies, but also for Government security and  even at personal use. IT departments should be aware and have the right  knowledge to how to fight it.
Teach the user how to configure vSphere Replication and how to protect and recover VMs Open vSphere Web Client: Verify vsphere Replication is enabled: Enable vSphere Replication for a virtual machine: Verify replicated VM is created: Recover replica…
This Micro Tutorial walks you through using a remote console to access a server and install ESXi 5.1. This example is showing remote access and installation using a Dell server. The hypervisor is the very first component of your virtual infrastructu…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question