IE will not open Hotmail, MSN.COM or even microsoft.com

Ok, I've been round and round with this, plus it may have been caused by a virus - TrojanhorseDropper.Generic7.agyg.

The virus has been removed, but the antivirus program did not clean up the damage.

IE will time-out when attempting to load Hotmail, msn.com, microsoft.com or login.live.com.  All other sites will load normally.  This only happens on one machine. (VISTA).  There were similar questions on this site, but limited details.

This problem appears to be a security issue, but I can not for the life of me locate where the issue is located.  I even TEMPORARILY shut off the firewall, to no avail.  Nothing in the eventviewer log is of use.  I even created a different user account on that machine, with the same results.  I am sure that the virus made some registry entries to create this issue but can't locate them.

My last resort it to re-install Windows.  Before I do this, I thought I'd ask if anyone has some feedback.
tburg2010Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
tburg2010Connect With a Mentor Author Commented:
PROBLEM SOLVED!

None of the posted suggestions helped. None of the utilities suggested helped.
I was a nano-second from running a complete restore when I happened on some old RESTORE POINTS.

One of the restore points was old enough to exists before the virus attack.  It worked and none of the programs or data files were effected.

I still do not know exactly what the real fix would have been, but at least the machine is running normally!
0
 
Neil RussellTechnical Development LeadCommented:
See http://forum.lowyat.net/topic/1083887/all  For a full breakdown of how to cure.

Step by step guide.
0
 
sambiggsCommented:
Have you checked your Hosts file?

There is one entry per line. Check that there are no lines mentioning any of the sites you have trouble with. If you do find anything, you can safely delete it.

By default, if you try to modify your hosts file in Vista, it will not let you save it.  It tells you that you don't have permission.  To successfully modify the hosts file, run notepad.exe as an administrator and open the file.

1)  Browse to Start -> All Programs -> Accessories
2)  Right click "Notepad" and select "Run as administrator"
3)  Click "Continue" on the UAC prompt
4)  Click File -> Open
5)  Browse to "C:\Windows\System32\Drivers\etc"
6)  Change the file filter drop down box from "Text Documents (*.txt)" to "All Files (*.*)"
7)  Select "hosts" and click "Open"
8)  Make the needed changes and close Notepad.  Save when prompted.
0
 
Neil RussellTechnical Development LeadCommented:
As this is a normal problem caused by a series of viruses then I very much doubt that the host file is an issue.  Virus writters have gotten a little bit cleverer than that now!
0
 
tburg2010Author Commented:
I had already checked the HOST file and there were no unusual entries.  There was something ::1 on one line and I disabled it by placing a # ahead of it, but made no difference.

The other suggestion of using THE COMEDIAN.exe was explored, but the executalbe seems to have been removed.  It appears that it was taken out of circulation.  Will the Anti-Malware work alright without running THE COMEDIAN.EXE first?
0
All Courses

From novice to tech pro — start learning today.