Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3593
  • Last Modified:

IE8 Freezes When Opening Office Documents

Hi all -

I recently got a new office laptop. Windows 7, with Office 2007 and IE8.

We have a SharePoint 2007 site. When I go to the site and try and edit an Excel or Word document, IE freezes.
This is the last thing I see:
Last thing I see
It's a very odd kind of freeze. I can't interact with the window. But I can right-click on the taskbar icon and open a new tab. But I can't do anything with that tab, as the IE interface is locked.

It's almost as if there is a Dialog Box that is open... but said dialog box is hidden somehow.

Our IT folks are stumped. I've repaired the Office installation several times. I've cleared every cache known to man. I've tried using my local draft folder. I've tried unchecking the local drafts box and using the web server drafts.

I should note... if I copy the document path, and go to File - Open in Excel and paste in the URL... the file opens no problem. I can check it out, etc. So I know it's not a connection or permissions error. No one else has any issues on their computers. I did not have any issues on my old computer.

The issue used to be intermittent. It is now pretty much all of the time.

I'm thinking the issue might have something to do with the SharePoint to Office connector thing. But I know nothing about that, so that's just a theory.

Any ideas?

Thanks!
0
Castaway78
Asked:
Castaway78
  • 10
  • 10
1 Solution
 
zackmccrackenCommented:
might it be a 64 bit windows machine and you use a 64 bit explorer ? if thats the case, please try the 32 bit version
0
 
Castaway78Author Commented:
I verified that I am using the 32 bit version of IE. (Office is 32 bit as well)
0
 
zackmccrackenCommented:
is the file sitting in My Documents\SharePoint Drafts or any other docs in there ?
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
Castaway78Author Commented:
I hadn't thought to check there.

I just checked, and yes... when I go to open the file, and the Use Local Drafts box is checked, the file does show up in the SharePoint Drafts folder. So it is downloading the file just fine.
0
 
zackmccrackenCommented:
I suppose its no problem to open the file directly from that location?
So we can assume the office integration in IE is acting up.

ok, could you try :

find the extension mapping for the .docx or whatever it is you're trying to open
and disable the browse in same window

or

download the filetypesman from http://www.nirsoft.net/utils/file_types_manager.html
which gives you a bit more info then the options above.
doubleclick the extension of the file which you're trying to open and disable browser integration by checking the box at the 'Don’t open inside a Web browser window' option.
0
 
Castaway78Author Commented:
Correct... I can open the file directly from the drafts folder. Additionally, I can copy the file's original URL, and paste it into the File-Open dialog box and open the file that way just fine.  So yes, I agree, it has to be something with the IE/SharePoint/Office integration.

I tried the FileTypesMan program, and the "Don't open inside a web browser" option was already checked.
0
 
zackmccrackenCommented:
maybe thats the issue, perhaps you need to uncheck that option
0
 
Castaway78Author Commented:
I tried unchecking it, didn't work either.

So, I've tried a few other things as well. One thing I noticed is that when IE freezes, it's almost as if there's an application modal dialog box, but without that box. And I know that SharePoint will pop up with the "some files can harm your computer" dialog box immediately after the Check Out box. So I was thinking maybe that dialog box was at fault, and was not showing properly.

So I tweaked my Trusted Sites settings to eliminate that dialog box. Unfortunately, IE still freezes.

I'm thinking it might have something to do with the SharePoint OpenDocuments Class ActiveX control. So, I renamed the file .OLD and ran the Repair Installation, hoping that if the file was corrupted, it would be replaced with a good version. Much to my dismay, that did not work either.

I also tried unregistering and then reregistering the dll. Nada.
0
 
zackmccrackenCommented:
did you have a different office version installed previously?
0
 
Castaway78Author Commented:
Office 2007 exclusively.
0
 
zackmccrackenCommented:
perhaps because of some tooling you might want to check if you have multiple copies of OWSSUPP.dll in your office subfolders
0
 
Castaway78Author Commented:
I checked that, and there is only one copy, in the Office 12 folder.
0
 
zackmccrackenCommented:
could you check if you have an addin in your IE called Sharepoint Open Documents or something like that? please disable it for testing purposes.
0
 
Castaway78Author Commented:
Yes, I do have that add-in. I had tried disabling it last night, and it removes the ability to edit documents. It just presents the Open/Save/Cancel dialog box, and then does open the document.
0
 
zackmccrackenCommented:
0
 
Castaway78Author Commented:
I had my hopes up for this one. I tried it, and it wouldn't install.
Error
I think it's because that hotfix is for a 2003/2007 incompatibility issue.

I also tried deleting the NAME.DLL and running the Repair function to replace it, in case it was corrupted. Didn't work either.
0
 
zackmccrackenCommented:
could you try resetting the IE settings to default ?

(workaround) use a different browser..
0
 
Castaway78Author Commented:
Resetting back to default was one of the first things my IT dept tried.

I would love to use another browser, but alas we're stuck with IE8.

Could be worse. We have done departments who are still forced to use IE6. Ick.
0
 
zackmccrackenCommented:
could you check if the webclient service is working properly?
It might help to set it up as automatic
0
 
Castaway78Author Commented:
zackmccracken - Thank you for your assistance... it was greatly appreciated.

Sorry for the delay, was out on vacation. At this point, I'm just too busy to spend a lot of time trying to solve the issue... I'm just going to continue with my workarounds, and then maybe have my department re-image my computer.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 10
  • 10
Tackle projects and never again get stuck behind a technical roadblock.
Join Now