Solved

Scripted printer install only appears after restarting the spooler

Posted on 2013-01-10
7
387 Views
Last Modified: 2013-01-23
Win2008 sp2 x32 print server x1
Win7 sp1 x32 clients x 500

I install my printers using a script:
rundll32 printui.dll,PrintUIEntry /ga /n\\server\Printer Name /j"LanMan Print Services"

I have an erratic problem on random computers where someone will log in and it will say 'no printers installed' in word, excel, notepad etc (anything). I restart the print spooler and the printers appear.

Windows patched, various printer hotfixes applied. Nothing in event log. How can I fix\troubleshoot this please?

(I have tried other methods of printer deployment and failed, this is what I need to fix, I don't want suggestions of a new method please.)
0
Comment
Question by:Pete
  • 5
  • 2
7 Comments
 
LVL 14

Expert Comment

by:BlueCompute
ID: 38762488
Presumably you could just add a line to the script to restart the spooler after installing the printers?
0
 
LVL 1

Author Comment

by:Pete
ID: 38762492
no the script is run once by an administrator, the /ga switch means to globally add it to any user. the printer then gets installed at login for anyone.
0
 
LVL 14

Expert Comment

by:BlueCompute
ID: 38762498
You could still add a line to the user login script to restart the spooler, if that is what fixes it?
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 1

Author Comment

by:Pete
ID: 38762509
I am concerned I will interrupt the printer being installed, not sure of the timings, when the login script runs, when the printer install script runs....
0
 
LVL 1

Author Comment

by:Pete
ID: 38769113
I actually put the script to restart the spooler 10secs after login (event vwr shows the spooler is definitely restarting) but sporadic users are still finding 'no printers installed', if the support call is raised and I remotely restart the spooler the printer appears. obviously many minutes after login.
what to do.....I'm at a loss.
0
 
LVL 1

Accepted Solution

by:
Pete earned 0 total points
ID: 38795080
imaging computers proved only fix
0
 
LVL 1

Author Closing Comment

by:Pete
ID: 38809174
no options worked
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article runs through the process of deploying a single EXE application selectively to a group of user.
This article outlines the process to identify and resolve account lockout in an Active Directory environment.
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

791 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question