OWA 2010 Delete & Move Errors

Exchange 2010
One Server
Version 14.1 (Build 218.15)

Cannot Move or Delete emails in OWA (light version, yes).  I've read through all the pages of write ups and what to check, but the only post ( http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_27294105.html ) that matches exactly what I'm doing states that their solution was a messed up web.config file.

How can I check to make sure my web.config file is good?

I believe the issue is with EWS.  

I've removed hostnames from Bindings.
I've searched all the web.config file in search of a blank redirect that is set to true.
I've rebuilt the virtual directories
Who is Participating?
shsdConnect With a Mentor Author Commented:
Solved my own problem.  This is what fixed it for me:
imkotteesSenior Messaging EngineerCommented:
you can compare with another CAS server. or else upgrade it to SP2 which will update for you.
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Firstly always make a copy and play not on the Original ....

I would suggest you to run EXBPA to check if there is any issues put forwrd

- Rancy
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!


You can reset your virtual directories in CAS.


In case it doesn't work go for exchange service pace upgradation which required downtime.

Pls do post your digging.
shsdAuthor Commented:
@imkottees - I cannot compare with another working CAS - any issues with SP2 ? Or major changes I need to worry about?

@Rancy - I have run the EXBPA and there's nothing alarming, just some storage drivers that are aging, temporary file path optimization (see attached).

@vivekashu - I've done that... does that create a new web.config file?  Thinking there is something wrong in that file, but not sure.
imkotteesSenior Messaging EngineerCommented:
SP2 would update the web.config file.  Rancy, Vivek please let me know if i'm wrong.

Shsd, How are you so sure that web.config is not correct?

Did you check these links..
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
I agree that SP2 should share a new set of files and we can try to check.

I would like to however understand if you have seen any issues

- Rancy
shsdAuthor Commented:
Tried everything I could think of and read online, but this is what fixed the problem for us.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.