Can't delete private appointment on resource calendar

I am running exchange 2010 and ran into a small problem with a resource.  The HR department has full access to a conference room which I've setup as a resource so it can be scheduled.  A member of the staff accidentally placed a private appointment on the calendar.  She can not delete it and neither can I even with full admin access.  I've tried a number of things including assigning full owner permissions to both my account and the original users.  I can see the appointment in there but it shows a small lock in the bottom right corner and no context menu appears when I click on it.  This is the same for my exchange admin account, the original user, and other accounts that I've tried with owner permissions to the account.  In past versions of exchange I could log in as the resource and remove it but I can't do that with a resource account in 2010.  I'd appreciate any advice on this on!
LVL 1
First LastAsked:
Who is Participating?
 
imkotteesSenior Messaging EngineerCommented:
still you can configure..

give yourself full mailbox permission to Resource mailbox --> configure outlook profile--> when it ask for credentials give yours--> finish--> follow the steps.

one more way... you can enable the Resource mailbox AD account by resetting password ;-) --> and configure the same
0
 
First LastAuthor Commented:
I did see reference to that utility but hesitated...do you know if I remove it forcefully like that if I'll still be able to allocate that block of time for appointments?  That was the core problem...the company CEO (of course!) wants to reserve that block but can't.  I'll review the article now, thanks!
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
imkotteesSenior Messaging EngineerCommented:
Ok, if you are bit worried about it. Export the mailbox before starting to deal with it.


In worst case you can export all items--> disable this mailbox--> create a new one --> import all the items. At any cost do not remove the current mailbox, disable it let it be there in disconnected mailboxes. so that you can reconnect if something goes wrong.
0
 
First LastAuthor Commented:
I reviewed the article and it indicates that I'd need to runt he utility on a machine that has a MAPI profile setup for the account with the problem.  I'm not sure how I can do that since the account is a resource which I can't log on with...I can't create an Outlook MAPI profile for it to connect to.
0
 
First LastAuthor Commented:
Ah, you were right...I should have tried it first.  I'm trying to track down the appointment now but I'm in and I can see everything here.  Thank you for the assist!
0
 
Rajkumar-MCITPCommented:
Check this..

Get-CalendarProcessing -Identity "Resource Mailbox Name"
| fl name, removeprivateproperty

If RemovePrivateProperty set to true, then set the property to false for the resource mailbox for sometime

Set-CalendarProcessing -Identity "Resource Mailbox Name" -RemovePrivateProperty $false

Try to delete the meeting and inform the status

Note: I don't think the resource mailbox AD account can be enabled
0
 
First LastAuthor Commented:
Resource was set to True, I changed it to False but it made no difference.  I'm waiting for the end user to tell me some more detail about the original appointment so I can be sure I'm removing the correct entry using MFCMAPI.
0
 
First LastAuthor Commented:
Ok, success with MFCMAPI!  Thanks for the assist on this, very much appreciated.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.