Solved

Windows roaming profile loading problems

Posted on 2013-01-10
2
618 Views
Last Modified: 2013-02-25
All our users are using roaming profiles. we have users who are logging into windows 7 and windows XP.

The windows 7 and XP profiles used to be stored on a windows 2003 R2 server but now they are on windows 2008 R2  

This is the folder structure on the server

D:\ Workers (folder)
       - Person A (folder shared) / profile.V2
       - Person B (folder shared) / profile.V2
       - Person C (folder shared) /  Profile

When the profiles were stored on windows 2003 R2, the  'OWNERS' of the folders (including the profile folder) were always 'administrators' and we never had any issues with roaming profiles

Since moving all the profiles to windows 2008 R2 we've been having a number of roaming profile issues with 'owner' as 'administrator'. When the user logs in they get a 'you have been logged on with a temporary profile'.

The only fix we found was by making the user the owner of both folders.

EX. Person A becomes the 'owner' of 'Person A (folder shared)' and their 'profile or profile.V2 ' folder. Once this is done the roaming profile error disappears.

The problem with this solution is that we can not see what's inside of their profile folders anymore. Even if administrators are given full access to it in both sharing + NTFS rights.

Is there something we're missing? We can't imagine that we have make every user the owners of their own folders.
0
Comment
Question by:iamuser
2 Comments
 
LVL 18

Accepted Solution

by:
Don S. earned 500 total points
ID: 38765245
There is a requirement in windows 7 that the roaming profile Owner be the User.  there is a setting in GPO that has Windows add the administrator to the profile permissions when it creates it automatically.  set that and set the top level folder permissions as follows and you will achieve what you want.

Roaming profile parent folder:

Creator Owner = Full Control, Subfolders and Files Only
Domain Users = List Folder/Read Data, Create Folders/Append Data - This Folder Only
System =  Full Control, This Folder, Subfolders and Files

And don’t forget to change the GPO for the local computer (not the server) to add the Administrators security group to the roaming user profile share.  It’s in Computer/Administrative Templates/System/User Profiles/Add the Administrators security group to roaming user profiles  - Enable it.
0
 

Author Closing Comment

by:iamuser
ID: 38926657
Perfect that was what I was looking for
0

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
SQL Server 2008 R2 - Execution Plan 3 31
SQL Server memory Issue 7 76
What is this Task? 4 42
Question on security Audit 2 59
You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now